Jump to content
The simFlight Network Forums

Alomon

Members
  • Content count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Alomon

  • Rank
    Newbie

Profile Information

  • Gender
    Male
  • Location
    France
  1. Yes, iVap was running as admin, as instructed by IVAO team. And P3D was not running as admin, as I havn't read such insctruction. So with everything running as admin, it works well.
  2. I finally made it work: P3D was not run as administrator, it seems that it has to! Thanks anyway for your help and great work, Pete. Regards
  3. I'll give it a try and let you know... Thanks.
  4. Thanks Pete, Do you know why would iVap intercept those messages and how I could correct this behaviour? Regards
  5. Hi, I have this configuration: Win10, P3Dv4.1, registered FSUIPC 5.122, iVap 2.0.2-b2773, VRinsight MCP Combo 1, Saitek yoke+rudder My installation is brand new as I re-installed everything recently, even twice due to the problem I am experiencing. Basically, my keypress assignment does not work when iVap is launched. Here are some logs to help you inderstand what happens: *** Without iVap *** * When pressing Shift+1 (effective) * 131890 KEYDOWN: VK=16, Waiting=0, Repeat=N, Shifts=1 131890 .. Key not programmed -- passed on to FS 131968 KEYDOWN: VK=49, Waiting=0, Repeat=N, Shifts=1 131968 .. Key not programmed -- passed on to FS 132156 *** EVENT: Cntrl= 65906 (0x00010172), Param= 0 (0x00000000) PANEL_1 132156 KEYUP: VK=49, Waiting=0 132156 KEYUP: VK=16, Waiting=0 * When pressing MCP button assigned to Shift+1 once (ineffective) * 260531 Button changed: bRef=0, Joy=258, Btn=16, Released 260531 [Buttons] 1=P258,16,K49,9 * When pressing MCP button assigned to Shift+1 a second time (effective) * 187547 Button changed: bRef=0, Joy=258, Btn=16, Pressed 187547 [Buttons] 1=P258,16,K49,9 187547 SendKeyToFS(00040031=[shft+1], KEYDOWN) ctr=0 187547 Sending WM_KEYDOWN, Key=16 (Shift) (Scan code 42), Ctr=2 187562 Sending WM_KEYDOWN, Key=49 (Scan code 2), Ctr=1 187562 KEYDOWN: VK=16, Waiting=0, Repeat=N, Shifts=1 187562 .. Key not programmed -- passed on to FS 187562 KEYDOWN: VK=49, Waiting=0, Repeat=N, Shifts=1 187562 .. Key not programmed -- passed on to FS 187578 *** EVENT: Cntrl= 65906 (0x00010172), Param= 0 (0x00000000) PANEL_1 187672 SendKeyToFS(00040031=[shft+1], KEYUP) ctr=0 187672 Sending WM_KEYUP, Key=49 (Scan code 2), Ctr=2 187687 KEYUP: VK=49, Waiting=0 187687 Sending WM_KEYUP, Key=16 (Shift) (Scan code 42), Ctr=1 187703 KEYUP: VK=16, Waiting=0 *** With iVap (external mode) *** * When pressing Shift+1 (effective) * 240906 KEYDOWN: VK=16, Waiting=0, Repeat=N, Shifts=1 240906 .. Key not programmed -- passed on to FS 241015 KEYDOWN: VK=49, Waiting=0, Repeat=N, Shifts=1 241015 .. Key not programmed -- passed on to FS 241031 *** EVENT: Cntrl= 65906 (0x00010172), Param= 0 (0x00000000) PANEL_1 241187 KEYUP: VK=16, Waiting=0 241187 KEYUP: VK=49, Waiting=0 * When pressing MCP button assigned to Shift+1 once (ineffective) * 260531 Button changed: bRef=0, Joy=258, Btn=16, Released 260531 [Buttons] 1=P258,16,K49,9 * When pressing MCP button assigned to Shift+1 a second time (ineffective) * 269359 Button changed: bRef=0, Joy=258, Btn=16, Pressed 269359 [Buttons] 1=P258,16,K49,9 269359 SendKeyToFS(00040031=[shft+1], KEYDOWN) ctr=0 269359 Sending WM_KEYDOWN, Key=16 (Shift) (Scan code 42), Ctr=2 269375 Sending WM_KEYDOWN, Key=49 (Scan code 2), Ctr=1 269468 SendKeyToFS(00040031=[shft+1], KEYUP) ctr=0 269468 Sending WM_KEYUP, Key=49 (Scan code 2), Ctr=2 269484 Sending WM_KEYUP, Key=16 (Shift) (Scan code 42), Ctr=1 I can't understand why this last action is ineffective. I have tried with LINDA, but I obviously get the same result. I am pretty sure iVap is guilty there, but I can't find how to solve this. I've only found this post which seems to be related: http://forum.simflight.com/topic/81775-button-to-keypress-mapping-not-working-p3d-v335fsuipc-v4955c/ Does anyone has an idea ? Thank you very much. Regards
×