Jump to content
The simFlight Network Forums

David Izzi

Members
  • Content count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About David Izzi

  • Rank
    Newbie
  1. P3D Extreme Booster

    We resolved the issue. extreme isn't compatible with v3. I know have the proper version.
  2. Hi I just bought the P3D extreme Booster for my P3D V3. I run the exe and try to open it and I get this response. P3D cannot connect to the internet. Please allow traffic from firewall. P3D booster will now shut down. I have rights from firewall when i check in McAfee setting. I also turned off firewall for 15min and still will not open. Can you please help?
  3. FS Commander 9.0 (answered)

    Sorry Volker, I'm running FS 2004 and FSX. I am using Windows 8.1 and I only have FS Commander version V9.0.0.4. I would like to update to the furthest but not sure if version 9.6 will work. My fsuipc is 3.999 and I bought your product years ago from PC Aviator. I hope this helps.
  4. Hello friends, I haven't used FSC in quite a long time but am now getting back into it again. I would like to if possible to get this version up to the new 9.6. I can't seem to find any upgraded version from 9.0 and up. Is there a way to upgrade from this older version of 9.0 to 9.6? Your assistance is greatly appreciated. Many thanks again. David :razz: :razz:
×