Jump to content


Photo

FSX Acceleration SP2 Issues with GefOrce series 7XXX cards


  • Please log in to reply
15 replies to this topic

#1 peterhayes

peterhayes

    Advanced Member

  • Members
  • PipPipPip
  • 898 posts

Posted 14 December 2007 - 01:38 AM

Hi all
After a lot of experimentation I have found for me (a suitable) workaround for the issue of FSX with SP2 crashing when using the nvidia 7xxx series Video Card, in full screen mode, and when you select a menu item with a mouse. This is a temporary fix but may help some simmers to enjoy FSX again. If you can get the sim into windowed mode and use the keyborad to select your options, I have found that I do not get any issues withe the Sim "freezing" or crashing. Below are the tips and the direct key controls for FSX which can all be selected just using a keyboard.

Keyboard Controls for the FSX Menu

If you are unable to use ALT + Enter to select WINDOWED mode, edit the fsx.cfg to read:

[MAIN]
Maximized=2
HideMenuNormal=0
HideMenuFullScreen=1

This should make FSX start in Windowed mode –
You can still get rid of the menu bar by pressing the "ALT" key, so you lose very little of the screen - don't forget to “Auto Hide the Task Bar” at the bottom of the screen.

As an “insurance policy” have a small program eg the task manager running at the same time as FSX so that you can hopefully ALT + TAB to it, to attempt to end the FSX session if it seizes.

PAUSE the sim before attempting to access the menus.

Do NOT use the mouse to access the menus - use the keyboard only

MAIN MENU Options – Keyboard Stroke – Standard FSX options:
Use the UP/DOWN Arrows to select a menu option and use the RIGHT arrow to select options in the sub menu.

ALT + F = Flight menu
ALT + A = Aircraft Menu
ALT + W = World
ALT + O = Options.
ALT + V = Views
ALT + D = Add-ons

Individual Menus

Flight Menu
ALT + F = Flight menu
ALT + F + L = Load
ALT + F + R = Reset
ALT + F + S = Save
ALT + F + P = Flight Planner
ALT + F + N = Navigation Log
ALT + F + E = End Flight
ALT + F + X = Exit

Aircraft Menu
ALT + A = Aircraft Menu
ALT + A + A = Select Aircraft
ALT + A + K = Kneeboard
ALT + A + V = Visual Flight Path
ALT + A + S = Smoke System
ALT + A + R = Realism Settings
ALT + A + U = Failures

World Menu
ALT + W = World
ALT + W + T = Time and Season
ALT + W + A = Go to Airport
ALT + W + M = Map
ALT + W + W = Weather
ALT + W + S = Scenery Library

Options Menu
ALT + O = Options.
ALT + O + F = Pause Flight.
ALT + O + M = Simulation Rate.
ALT + O + R = Instant Replay.
ALT + O + V = Flight Video.
ALT + O + A = Flight Analyzer.
ALT + O + S = Sound.
ALT + O + E = Settings.

Views Menu
ALT + V = Views
ALT + V + F = Full Screen
ALT + V + A = Air Traffic Control.
ALT + V + C = Chat Window.
ALT + V + I = Instrument Panel.
ALT + V + N = New View.
ALT + V + M = View Mode.
ALT + V + U = Undock View.
ALT + V + C = Close View.
ALT + V + W = Windows Titles.
ALT + V + A = Axis Indicator.
ALT + V + T = Top Down Orientation.

Add-ons Menu
ALT + D = Add-ons
ALT + D +F = FSUIPC.
(only one add-on shown, these will vary according to what add-ons you have installed.
There may be other options depending on what extras you have installed.

Regards
PeterH
  • 0
P Hayes

#2 westv

westv

    Advanced Member

  • Members
  • PipPipPip
  • 991 posts
  • LocationEssex, UK

Posted 14 December 2007 - 01:57 AM

I wasn't even aware there was a problem (I have a 7900GT) but I hope that people who do have a problem find your post of use.
  • 0
Victor

#3 peterhayes

peterhayes

    Advanced Member

  • Members
  • PipPipPip
  • 898 posts

Posted 14 December 2007 - 02:10 AM

Hi Victor
I didn't have an issue when I first installed SP2/Acceleration but when I changed the driver it started to happen and continued even when I re-installed the original workable driver. There have been quite a few posts in the forums and we are all awaiting an nvidia driver update that hopefully fixes the issue.
Regards
PeterH
  • 0
P Hayes

#4 Francois Dumas

Francois Dumas

    Former Admin

  • Members
  • PipPipPip
  • 15,747 posts
  • LocationEurope

Posted 14 December 2007 - 08:31 AM

I run a 7800GTX, no problems. Was running a 94.something driver, no problems. Updated my driver to 169.19... no problems. No Vista, either 8)
  • 0

Francois A. 'Navman' Dumas

FSAddon.com Publishing
EuropeRides
... and the man's Blog


#5 Benoit

Benoit

    Advanced Member

  • Members
  • PipPipPip
  • 1,207 posts
  • LocationMontreal, Canada

Posted 14 December 2007 - 09:04 PM

I have this problem, though I already know the tips about windowed mode. Post really useful yes.

Though this bug is really annoying (make the game unplayable finally) and there are few folks with the same problem, I can't confirm is linked to nvidia cards.

Thx Peter.
Ben.
  • 0

Sig_4.jpg


#6 peterhayes

peterhayes

    Advanced Member

  • Members
  • PipPipPip
  • 898 posts

Posted 15 December 2007 - 12:19 AM

Francois
Its probably video card/pc type/OS related (I run an AMD 4800 X2 with 2Gb RAM, WINXP SP2, Geforce 7950GT 512Mb RAM). Like you I had no problems until I updated the driver (silly me :oops: ) to a 169.xx series (162.18 think it was) and then even moving back the the previously stable 94.24 driver I still had this freezing/crashing when I accessed the menus using the mouse in full screen mode. A further experiment has shown that with the NGO Optimised 97.92 driver I can now open in full screen and use the mouse to access the menus, after switching from my G5 laser mouse back to a MS optical mouse. I'll experiment more in case the mouse was part the issue??
Thanks for all of the comments
PeterH
  • 0
P Hayes

#7 sreeda

sreeda

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 11 January 2008 - 02:44 PM

I have the same replay-freeze problem but my video card is NVidia GeForce 6800. The keyboard work-around works, but sure would like to know what is causing the problem. Any new ideas?

System:
Dell XPS Gen 5
Win XP Pro
Creative SB Audigy 2ZS
NVidia GeForce 6800
Dell Enhanced Multimedia Keyboard aand mouse

Everything is updated to latest drivers and DirectX.

Thanks,
Spencer
  • 0

#8 peterhayes

peterhayes

    Advanced Member

  • Members
  • PipPipPip
  • 898 posts

Posted 12 January 2008 - 02:22 AM

Hi Spencer
I updated to the 169.21 WHQL driver for WinXp and the issue disappeared.
I now have a GF8800GT and that works very well with no crashing etc.
This problem seems to affect the 6xxx and 7xxx series nVidia cards.
Regards
PeterH
  • 0
P Hayes

#9 westv

westv

    Advanced Member

  • Members
  • PipPipPip
  • 991 posts
  • LocationEssex, UK

Posted 12 January 2008 - 11:15 AM

I'm still running with the 91.47 drivers.
  • 0
Victor

#10 sreeda

sreeda

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 13 January 2008 - 03:17 AM

To: P Hayes,
Thanks for the suggestion. I updated my driver and am still getting the same problem. It appears to be a problem with the GF6800 NVIDIA card, so I'll upgrade to a GF 8800 as you did. That should solve the problem. Thanks.
Spence Anderson
  • 0

#11 peterhayes

peterhayes

    Advanced Member

  • Members
  • PipPipPip
  • 898 posts

Posted 13 January 2008 - 04:33 AM

Hi Spence
Hope the 8800GT works out well.
I'm very pleased with mine which was a Galaxy 8800GT 512Mb.
It works well in FS9 and FSX (In full screen mode).
Regards
PeterH
Edit: PS I see that you have an Intel duo core and I noticed in one of the forums today thst there are some power saving cpu options in the bios that can cause FSX to freeze. It was on the Avsim "FSX/Crash to desktop" forum and the poster [Haldir] stated:
"Look in your bios for any of the following settings and disable the ones you find:
-C1E function
-Enhanced Halt
-SpeedStep
-Enhanced Intel Speedstep (EIST)
Most intel dual or quad core cpus have at least one of these functions available to them. Not sure about single core.
C1E in my case was the one causing full screen menu access CTDs. I have an 8800 Ultra.
These functions allow the system to lower its CPU voltage, multiplier, or FSB speed in cases where cpu load is low, in order to conserve power and reduce heat. Unfortunately for me it turns out they're tripping up my nvidia driver (169.21) somehow. Accessing a menu in the sim is a case where the cpu is going from max to pretty much idle instantly"
Haldir also gave this link: "Some further and very enlightening reading if you're interested:
http://www.overclock...s/220ndows.html"
This may help you??
pH
  • 0
P Hayes

#12 JonP

JonP

    Advanced Member

  • Members
  • PipPipPip
  • 245 posts

Posted 17 January 2008 - 12:05 AM

Hi,

I had the problem reported by the original poster on my new machine which runs two 8600GT cards in SLI. So I don't think it was restricted to older cards. Anyway, although I found the latest drivers solved the problem, I also note that the latest WHQL drivers have the anti-aliasing broken - you can't set game by game (i.e on the Program tab) anti-aliasing via the drivers - you can only set it globally in the drivers or from within the game itself. Not much good when the drivers have the facility to offer much higher levels of AA than the in-game setting does.

Anyway, it looks like currently the only driver I have tried that both solves the problem and does not have the "Program tab AA" broken is 169.13.
  • 0

#13 Oliver Beyer

Oliver Beyer

    Member

  • Members
  • PipPip
  • 26 posts

Posted 19 January 2008 - 07:50 PM

How does windowed mode stack up performancewise? I was always under the impression that windowed mode was much slower than fullscreen. Could anybody who tested it say something about it?
  • 0

#14 jwenting

jwenting

    Advanced Member

  • FScene Mods
  • 3,958 posts
  • Locationhalfway between ARTIP and PAM

Posted 19 January 2008 - 10:05 PM

windowed or fullscreen makes no noticeable difference, unless of course you run windowed at (say) 1600 wide and fullscreen at 800 in which case the lower resolution means higher performance.
  • 0
Posted Image

#15 Oliver Beyer

Oliver Beyer

    Member

  • Members
  • PipPip
  • 26 posts

Posted 19 January 2008 - 10:31 PM

Really? I always thought that it would take a fps hit in windowed mode. In other games I saw a big drop. Maybe FSX is better here, or generally badly optimized :mrgreen:

Anyway, is there a way to set a certain resolution for windowed mode? I can only scale the window like any other Windows window. I'd love to set a fixed res though that corresponds panel resolutions etc.

Thanks for the help.
  • 0

#16 jwenting

jwenting

    Advanced Member

  • FScene Mods
  • 3,958 posts
  • Locationhalfway between ARTIP and PAM

Posted 19 January 2008 - 10:42 PM

In windowed mode the resolution is determined by the resolution of Windows itself and the percentage of the screen your FS window takes up.
There's no way to force a specific resolution.
  • 0
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


About simFlight - simflight.com - simflight.de - simflight.fr - simflight.nl - simflight.pt - simflight.es - simflight.it - simflight.jp - simrussia.com - simMarket