Jump to content


Photo

Sound problem FSX


  • Please log in to reply
5 replies to this topic

#1 neilharris360

neilharris360

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 16 February 2008 - 09:11 PM

Since I upgraded from windows XP to Vista I cant hear ATC and I cant hear the narrator in the missions. ive heard of other people having this problem but i havent heard how to fix it. If anyone can help me it would be apreciated... im tired of doing missions and haveing to read what the narrator is saying.
Thanks
  • 0

#2 Large Alvin

Large Alvin

    Member

  • Members
  • PipPip
  • 27 posts

Posted 22 February 2008 - 10:07 AM

yep, Vista completely revamped their audio stategy. Make sure to DL the latest updates for Vista , heard there is service pack for it now, and your sound card driver as well. It may help, I don't really know if the sound can be turned on or off in fsx for the atc window but I wouldn't overlook that. Have fun
  • 0

#3 Mr Pants

Mr Pants

    Advanced Member

  • Members
  • PipPipPip
  • 195 posts
  • LocationHampshire UK

Posted 22 February 2008 - 10:30 AM

I am still on XP, but had a similar issue when I was sat in my cockpit, no engine sound, well hardly any, but when I turned my head I could hear the engine.

In the sound settings it was set to 5.1 surround which meant it was trying to play the sound through 5 speakers and diverting the sound accordingly and I was only using two speakers. So I set sound settings to two speakers in the creative audio control panel and it sorted it!

You may find if you are the same that the ATC is coming through a center speaker you dont have??
  • 0
Its better to burn out, than to fade away.....
Posted Image
DELL XPS-720

#4 sn.ave

sn.ave

    Advanced Member

  • Members
  • PipPipPip
  • 463 posts
  • LocationSouthern UK

Posted 23 February 2008 - 06:15 PM

FSX allows for different routings of internal and external sounds from comms and narratives. Simply ensure that both are set to the sound card you have.
  • 0
Simon Evans
"It's no matter whether you listen to others, just so long as it gives you cause to think for yourself."

#5 Large Alvin

Large Alvin

    Member

  • Members
  • PipPip
  • 27 posts

Posted 07 April 2008 - 07:50 AM

It might be a mixer setting, perhaps the narrator is on a separate channel and you need to turn it up or switch off the mute button. Also carefully read the control panel for your audio card, it might have a switch to not allow changes to its channel settings from a program. You might be able to try a usb or fire wire sound card, they are available. Check out any pro audio sound card. Here is something for 20 dollars http://www.usbgear.c...cable_d=136,121

This might be a better choice though, It's 30 dollars.
http://www.zzounds.com/item--BEHUCA202

Good luck
  • 0

#6 mproy3

mproy3

    Newbie

  • new Members
  • Pip
  • 1 posts
  • LocationCanada

Posted 16 January 2012 - 03:30 PM

Flight Simulator X sound problem when in Mission mode.

Here is how I fixed my sound problem in FSX Mission mode. First, I chose a FSX Mission, and then I chose the Display Menus through the Alt key, selected Settings under Options, and then selected Sound to obtain the following window menu.

SETTINGS - SOUNDS

Volume Levels
Engines,
Cockpit
Environment
Voice

Windows Sound Devices
Sounds Voice
Speakers/... Speakers/...



I then selected Speaker / Headphones (IDT High) in both Sounds and Voice submenus boxes under Windows sound devices, as shown in the above window menu. Hope that this solution will help others who are having the same problem as I had.
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


About simFlight - simflight.com - simflight.de - simflight.fr - simflight.nl - simflight.pt - simflight.es - simflight.it - simflight.jp - simrussia.com - simMarket