Jump to content
The simFlight Network Forums
Sign in to follow this  
PeteEHAM

Strange behavior WideFS

Recommended Posts

Hello,

I don't know how but as of today I'm having problems with my WideFS configuration.

This is what happens:

1) It makes no diffrence if I start FSX and then WideFS or the other way around.

2) On the 1st attempt there is no connection, WideFS is "waiting for connection".

3) So through FSUIPC on my FSX computer I disable WideFS which causes FSX to hang...

4) After starting up FSX again and enable WideFS again via FSUIPC on my FSX computer.......I have a connection!

5) So ASV6 refreshes the weather and AI traffic automaticly as soon as there is a connection.

6) When I start RC4 (after ASV6 is finished) my plane jumps (default and payware) and again FSX hangs...

Before I had a good working connection and never have encountered these problems.... The only thing I did is installing scenery (cloud 9 Xclass and FEX)

Help please? Thanks in advance,

Peter

Amsterdam

Share this post


Link to post
Share on other sites

1) It makes no diffrence if I start FSX and then WideFS or the other way around.

By "WideFS" here, I assume you mean a copy of WideClient running on a Networked PC?

3) So through FSUIPC on my FSX computer I disable WideFS which causes FSX to hang...

Ouchyou have something really wrong if turning off the Server action hangs FSX!

Help please? Thanks in advance

I would need to see the FSUIPC, WideServer and WideClient logs.

But please note that after tomorrow (Tuesday) I am away for a while -- back on the 25th.

Pete

Share this post


Link to post
Share on other sites

Hi Pete,

Enclosed the requested files. I tried 2 times today, so you'll find 2 logfiles.

Thanks in advance.

Peter

Amsterdam

********* FSUIPC4, Version 4.50 by Pete Dowson *********

Reading options from "D:\FSX\Modules\FSUIPC4.ini"

User Name="Peter Aertssen"

User Addr="peteraertssen@orange.nl"

FSUIPC4 Key is provided

WideFS7 Key is provided

Running inside FSX on Windows Vista (using SimConnect Acc/SP2 Oct07)

Module base=61000000

Wind smoothing fix is fully installed

DebugStatus=255

156 System time = 14:15:07

218 FLT UNC path = "\\PC_PETER_FSX\Users\acer\Documents\Flight Simulator X Files\"

218 FS UNC path = "\\PC_PETER_FSX\FSX\"

1466 LogOptions=00000000 00000001

1466 SimConnect_Open succeeded: waiting to check version okay

2979 Running in "Microsoft Flight Simulator X", Version: 10.0.61472.0 (SimConnect: 10.0.61259.0)

2979 Initialising SimConnect data requests now

2979 FSUIPC Menu entry added

3088 \\PC_PETER_FSX\Users\acer\documents\flight simulator x files\EHAM default.FLT

3088 \\PC_PETER_FSX\FSX\SimObjects\Airplanes\Aircreation_582SL\Aircreation_582SL.AIR

15225 C:\Users\acer\Documents\Flight Simulator X Files\DAL70RW09L.PLN

76378 System time = 14:16:23, Simulator time = 16:10:04 (20:10Z)

110121 NWI weather clear actioned

110121 External weather discarded

110261 Weather Mode now = Theme

110261 Weather Mode now = Custom

138934 Sim stopped: average frame rate for last 47 secs = 9.8 fps

158044 FSUIPC Display Title set = "Radar Contact"

163707 User aircraft crashed!

179635 System time = 14:18:06, Simulator time = 16:13:16 (20:13Z)

179635 *** FSUIPC log file being closed

Average frame rate for running time of 66 secs = 10.0 fps

Memory managed: 47 Allocs, 47 Freed

********* FSUIPC Log file closed ***********

********* WideServer.DLL Log [version 7.50] *********

Blocksize guide = 4096 (double allowed)

Date (dmy): 13/04/09, Time 13:39:53.232: Server name is PC_PETER_FSX

15163 Initialising TCP/IP server

15163 Initialising IPX/SPX server

15163 IPX/SPX socket() failed [Error=10044] Socket type not supported

15163 Failed to start IPX/SPX Server

15163 Initialising UDP/IP server

16208 Broadcasting service every 1000 mSecs

16848 Incoming connection Accepted ok (skt=8924) TCP

16957 Connected to computer "PC_VAN_PETER" running WideClient version 6.780 (skt=8924) TCP

1144033 Close signalled to clients

1145141 Closing down now ...

Memory managed: Offset records: 47 alloc, 46 free

Read buffer usage: 1129 alloc, 1129 free, max in session: 1

Write buffer usage: 6483 alloc, 6483 free, max in session: 1

Throughput maximum achieved: 10 frames/sec, 350 bytes/sec

Throughput average achieved for complete session: 2 frames/sec, 89 bytes/sec

Average receive rate from "PC_VAN_PETER": 1 frames/sec, 94 bytes/sec

********* Log file closed *********

********* WideServer.DLL Log [version 7.50] *********

Blocksize guide = 4096 (double allowed)

Date (dmy): 13/04/09, Time 14:16:33.437: Server name is PC_PETER_FSX

15273 Initialising TCP/IP server

15273 Initialising IPX/SPX server

15273 IPX/SPX socket() failed [Error=10044] Socket type not supported

15273 Failed to start IPX/SPX Server

15273 Initialising UDP/IP server

16349 Broadcasting service every 1000 mSecs

17941 Incoming connection Accepted ok (skt=8912) TCP

18034 Connected to computer "PC_VAN_PETER" running WideClient version 6.780 (skt=8912) TCP

90637 Error 10053: client socket disconnected at Client: removing (skt=8912) TCP

90731 Close signalled to clients

91838 Closing down now ...

Memory managed: Offset records: 47 alloc, 46 free

Read buffer usage: 66 alloc, 66 free, max in session: 1

Write buffer usage: 567 alloc, 567 free, max in session: 1

Throughput maximum achieved: 14 frames/sec, 404 bytes/sec

Throughput average achieved for complete session: 3 frames/sec, 97 bytes/sec

Average receive rate from "PC_VAN_PETER": 0 frames/sec, 115 bytes/sec

********* Log file closed *********

********* WideClient Log [version 6.78] Class=FS98MAIN *********

Date (dmy): 13/04/09, Time 13:36:43.053: Client name is PC_VAN_PETER

3463 Attempting to connect now

4477 Trying to locate server: Need details from Server Broadcast

4477 Failed to connect: waiting to try again

6521 Attempting to connect now

56425 New Client Application: "ASv6" (Id=2084)

71745 Trying to locate server: Need details from Server Broadcast

255046 Server = PC_PETER_FSX

255093 Trying TCP/IP host "PC_PETER_FSX" port 8002 ...

255093Okay, IP Address = 192.168.0.199

255093 Connection made okay!

1345040 New Client Application: "rcv4" (Id=868)

1379673 Received shutdown offset code = ADBC

1379673 FS closing down (param=ADBC), disconnecting

1379673 ********* Interim performance summary *********

1379673 Total time connected so far = 1123 seconds

1379673 Reception maximum so far: 10 frames/sec, 337 bytes/sec

1379673 Reception average whilst connected so far: 5 frames/sec, 182 bytes/sec

1379673 Transmission maximum so far: 13 frames/sec, 442 bytes/sec

1379673 Transmission average whilst connected so far: 2 frames/sec, 95 bytes/sec

1379673 Max receive buffer = 216, Max send depth = 13, Send frames lost = 0

1379673 **************** Individual client application activity ****************

1379673 Client 2084 requests: 4777 (Ave 4/sec), Data: 157376 bytes (140/sec), Average 32 bytes/Process

1379673 Client 868 requests: 131 (Ave 0/sec), Data: 3257 bytes (2/sec), Average 24 bytes/Process

1379673 ***********************************************

1379766 Received shutdown offset code = ADBC

1386303 Connection closed by server!

1386303 Attempting to connect now

1389469 ****** End of session performance summary ******

1389469 Total time connected = 1123 seconds

1389469 Reception maximum: 10 frames/sec, 337 bytes/sec

1389469 Reception average whilst connected: 5 frames/sec, 182 bytes/sec

1389469 Transmission maximum: 13 frames/sec, 442 bytes/sec

1389469 Transmission average whilst connected: 2 frames/sec, 95 bytes/sec

1389469 Max receive buffer = 216, Max send depth = 13, Send frames lost = 0

1389469 **************** Individual client application activity ****************

1389469 Client 2084 requests: 4794 (Ave 4/sec), Data: 157803 bytes (140/sec), Average 32 bytes/Process

1389469 Client 868 requests: 140 (Ave 0/sec), Data: 3419 bytes (3/sec), Average 24 bytes/Process

1389469 ********* Log file closed (Buffers: MaxUsed 13, Alloc 11874 Freed 11874 Refused 0) *********

********* WideClient Log [version 6.78] Class=FS98MAIN *********

Date (dmy): 13/04/09, Time 14:13:06.022: Client name is PC_VAN_PETER

2855 Attempting to connect now

3869 Trying to locate server: Need details from Server Broadcast

3869 Failed to connect: waiting to try again

5913 Attempting to connect now

40607 New Client Application: "ASv6" (Id=812)

71121 Trying to locate server: Need details from Server Broadcast

278727 Server = PC_PETER_FSX

278758 Trying TCP/IP host "PC_PETER_FSX" port 8002 ...

278758Okay, IP Address = 192.168.0.199

278758 Connection made okay!

330317 New Client Application: "rcv4" (Id=1444)

349380 ****** End of session performance summary ******

349380 Total time connected = 69 seconds

349380 Reception maximum: 13 frames/sec, 438 bytes/sec

349380 Reception average whilst connected: 8 frames/sec, 254 bytes/sec

349380 Transmission maximum: 18 frames/sec, 1065 bytes/sec

349380 Transmission average whilst connected: 2 frames/sec, 125 bytes/sec

349380 Max receive buffer = 216, Max send depth = 13, Send frames lost = 0

349380 **************** Individual client application activity ****************

349380 Client 812 requests: 343 (Ave 4/sec), Data: 16234 bytes (235/sec), Average 47 bytes/Process

349380 Client 1444 requests: 115 (Ave 1/sec), Data: 2969 bytes (43/sec), Average 25 bytes/Process

349380 ********* Log file closed (Buffers: MaxUsed 13, Alloc 1051 Freed 1051 Refused 0) *********

Share this post


Link to post
Share on other sites

I tried 2 times today, so you'll find 2 logfiles.

You say "tried", but the logs show "succeeded". There are no errors, nothing showing wrong, excepting a very poor frame rate

Unfortunately, for the FSUIPC log, you only had FSX running properly for a minute, which is too short to tell what might be goping on -- and programs like ASV6 are very heavy users in that first period. This might explain this awful FSX frame rate:

Average frame rate for running time of 66 secs = 10.0 fps

reflected also in the WideServer and WideClient results:

Throughput maximum achieved: 10 frames/sec, 350 bytes/sec

Throughput average achieved for complete session: 2 frames/sec, 89 bytes/sec

Throughput maximum achieved: 14 frames/sec, 404 bytes/sec

Throughput average achieved for complete session: 3 frames/sec, 97 bytes/sec

1379673 Reception maximum so far: 10 frames/sec, 337 bytes/sec

1379673 Reception average whilst connected so far: 5 frames/sec, 182 bytes/sec

1379673 Transmission maximum so far: 13 frames/sec, 442 bytes/sec

1379673 Transmission average whilst connected so far: 2 frames/sec, 95 bytes/sec

1389469 Reception maximum: 10 frames/sec, 337 bytes/sec

1389469 Reception average whilst connected: 5 frames/sec, 182 bytes/sec

1389469 Transmission maximum: 13 frames/sec, 442 bytes/sec

1389469 Transmission average whilst connected: 2 frames/sec, 95 bytes/sec

349380 Reception maximum: 13 frames/sec, 438 bytes/sec

349380 Reception average whilst connected: 8 frames/sec, 254 bytes/sec

349380 Transmission maximum: 18 frames/sec, 1065 bytes/sec

349380 Transmission average whilst connected: 2 frames/sec, 125 bytes/sec

But there are no errors, and nothing wrong with the operations as far as WideFS and FSUIPC are concerned. It simply looks as if you are overloading FSX to an extreme. I suspect the symptoms you are seeing are merely the outward appearance of everything slowing down to a near halt.

Try taking stuff off, reducing things in FSX. You said "the only thing I did is installing scenery (cloud 9 Xclass and FEX)". Could one or the other of those be bringing FSX to its knees? Maybe one or the other installed some additional activity, other SimConnect clients or modules, which are soaking up processor power?

Regards

Pete

Share this post


Link to post
Share on other sites

YES!!!

Thanks Pete! Silly me.... I did put my target framerate to "unlimited" for a test and forgot to put it back to its original setting....

And silly me that I didn't saw the frame rate in those logs right under my nose!

I'm happy flying right now and thanks for your fast and excellent support!

Peter

Amsterdam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×