Jump to content


Photo

How To Disable FSX ATC iN FSUIPC?


  • Please log in to reply
5 replies to this topic

#1 aoja1118

aoja1118

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts

Posted 09 February 2010 - 05:12 PM

I recently started using radar contact 4.3 for fsx. I disabled the atc functions in fsx per the r/c instructions but i'm starting to get random crashes caused by an atc.dll error. I read in another forum that the fsx atc can be disabled in fsuipc and that would clear up this problem.I couldn't find this option in the fsuipc config. I'm running the payware version of fsuipc 4.57 and wide fs.

Could really use some help!
  • 0
Alex

#2 Pete Dowson

Pete Dowson

    Advanced Member

  • Moderators
  • 27,109 posts
  • LocationNear Stoke-on-Trent, UK

Posted 09 February 2010 - 05:54 PM

I recently started using radar contact 4.3 for fsx. I disabled the atc functions in fsx per the r/c instructions

There's no way to "disable" FSX ATC. You just need to turn its sound right off in the Sounds menu.

... but i'm starting to get random crashes caused by an atc.dll error.

In FSX? I've never heard of any ATC crashes in FSX. I've been using Radar Contact with FSX ever since FSX was in Beta and never had a single ATC crash. There were certainly nasty problems in FS9, for which I provided patch facilities via FSUIPC3, but those certainly weren't carried over into FSX.

I read in another forum that the fsx atc can be disabled in fsuipc and that would clear up this problem.

I think you must has misread something. There are such facilities in FSUIPC3 for FS9, but they do not apply in FSX and are not needed.

I think you must have some other problem in your FSX installation. I realy have no idea what could cause ATC.DLL to crash in that. Sorry.

Regards
Pete
  • 0

#3 airforce2

airforce2

    Advanced Member

  • Members
  • PipPipPip
  • 163 posts

Posted 17 February 2010 - 10:47 PM

Hi Pete;

I am seeing the same thing... a lot of crashes due to atc.dll in FSX when using Radar Contact v4.3, and also I am hearing FSX's ATC voices at low level in FSX even with the "voice" checkbox unchecked in the sound dialogue. I run RC on a remote PC via WideFS.

Regards

Bob Scott
Colonel, USAF (ret)
ATP IMEL Gulfstream II-III-IV-V
Colorado Springs, CO
  • 0

#4 Pete Dowson

Pete Dowson

    Advanced Member

  • Moderators
  • 27,109 posts
  • LocationNear Stoke-on-Trent, UK

Posted 18 February 2010 - 12:11 AM

I am seeing the same thing... a lot of crashes due to atc.dll in FSX when using Radar Contact v4.3, and also I am hearing FSX's ATC voices at low level in FSX even with the "voice" checkbox unchecked in the sound dialogue. I run RC on a remote PC via WideFS.

Strange. I've been running RC 4.3 like that with FSX for over three years and have never seen an ATC.DLL crash. I think you must have some sort of corruption in your FSX installation.

Either way, I know of no fixes possible to any bugs in FSX, and I do know the main one that was in FS9 is not in FSX.

Maybe you aren't using a fully updated install of FSX and there was a bug in the original or SP1 versions? I never heard of one though. Of course I've been using SP2/Acceleration ever since that was in Beta, so pretty nearly for all of the three years or more.

Oh, and with the ATC volume turned down I hear no ATC voices on the FSX PC at all, so that's a bit strange too.

Sorry. I would refer you to Microsoft support but we know that's not going to get anywhere! :-(

Regards
Pete
  • 0

#5 airforce2

airforce2

    Advanced Member

  • Members
  • PipPipPip
  • 163 posts

Posted 21 February 2010 - 09:35 PM

A quick post-script on this--it appears the problem with ATC.DLL crashes was related to either flashing a new BIOS that put my overclock right on the ragged edge of stability, or some issues with nVidia's 196.21 drivers, or some combo of the two.

Not sure why I saw the same ATC.DLL fault each time, but getting the overclock stable again with a Vcore change and reverting to 182.50 drivers seems to have slain the dragon. Or maybe it was the dried lizard's feet positioned facing towards Salem on top of the CPU case...

Also, FWIW, I had unchecked the voice checkbox in the FSX sound control dialog, but left the slider up--turns out that does not turn off the voices. That checkbox only allows the voice sounds to be redirected to a different sound device than the other acft and environment sounds (i.e. to a headset). Turning the voice slider down is what's needed to kill the ATC sounds.

Cheers

Bob Scott
Colonel, USAF (ret)
ATP IMEL Gulfstream II-III-IV-V
Colorado Springs, CO
  • 0

#6 Pete Dowson

Pete Dowson

    Advanced Member

  • Moderators
  • 27,109 posts
  • LocationNear Stoke-on-Trent, UK

Posted 22 February 2010 - 12:13 AM

A quick post-script on this

Thanks Bob. Always nice to learn of happy endings! ;-)

Pete
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


About simFlight - simflight.com - simflight.de - simflight.fr - simflight.nl - simflight.pt - simflight.es - simflight.it - simflight.jp - simrussia.com - simMarket