Jump to content
The simFlight Network Forums
787flyer

One solution for "My signature check fails on the installed FSUIPC4.DLL. (Error 80092026)"

Recommended Posts

Hi Pete and Folks,

I have been experiencing similar problems on my brand new Windows 7 PC and trying to correctly install FSUIPC v4 (v4.70b). I am running Windows 7 Professional 64bit with SP1 installed and IE9. :(

Symptoms were:-

  • a failed installation error log stating the GlobalSign root failed. Error 80092026.
  • no Add-ons menu in FSX appears
  • No sign of the Simflight Certificate in IE e.g. Internet Options/Content/Publishers /Certificates (Trusted or Untrusted)
  • Was running the FSUIPC4 install file with "Run as Administrator"
  • The Simflight Certificate shows it is OK.

Here's what I did to fix it...:wink:
I added the Simflight GmbH certificate manually into the certificate store. For those that don't know how to do this, read below the specific steps:-
  • Deleetd any FSUIPC references in the [Trusted] section of the FSX.cfg file.
  • Run the FSUIPC app as per instructions
  • Locate/select the FSUIPC4.dll file in FSX/Modules folder and right click and select Properties
  • Navigate to Digital Signatures tab, select the Simflight Gmbh signature in the signatures list and click the "Details" button
  • Now click View Cetificate button and then the "Install Certificate" button. A Certificate Import wizard starts.
  • Click the Next button and then select the radio button with the option "Place all certificates in the following store"
  • Now click the "Browse" button and select "Trusted Publishers" from the drop-down menu and click "Next".
  • Follow the remaining wizard instructions to complete the import operation

To check, open IE and select Tools/Internet Options/Content, then click the Publishers button and then the Trusted Publishers tab and Simflight should be listed.

Then run FSX and the Add-ons menu should appear with the FSUIPC option.

Fixed!

Anyway, I hope this helps someone else out. ;)

Best Regards

Mark

BTW: I tried the System Update readiness tool but this failed on install.

Share this post


Link to post
Share on other sites

Mark,

 

could you post the certificate here or could you mail it to me?

 

Best

 

Fritz B. Hoering

(Google my Name and you will find an email address)

Share this post


Link to post
Share on other sites

could you post the certificate here or could you mail it to me?

 

There's no certificate in use any more, not for a while! You are referring to a 2-year old problem. Just make sure you are using an up-to-date version of FSUIPC, not one which is over two years old!

 

Pete

Share this post


Link to post
Share on other sites
On 18/04/2011 at 1:14 PM, 787flyer said:

Hi Pete and Folks,

I have been experiencing similar problems on my brand new Windows 7 PC and trying to correctly install FSUIPC v4 (v4.70b). I am running Windows 7 Professional 64bit with SP1 installed and IE9. :(

Symptoms were:-

 

  • a failed installation error log stating the GlobalSign root failed. Error 80092026.
  • no Add-ons menu in FSX appears
  • No sign of the Simflight Certificate in IE e.g. Internet Options/Content/Publishers /Certificates (Trusted or Untrusted)
  • Was running the FSUIPC4 install file with "Run as Administrator"
  • The Simflight Certificate shows it is OK.


Here's what I did to fix it...:wink:
I added the Simflight GmbH certificate manually into the certificate store. For those that don't know how to do this, read below the specific steps:-

 

  • Deleetd any FSUIPC references in the [Trusted] section of the FSX.cfg file.
  • Run the FSUIPC app as per instructions
  • Locate/select the FSUIPC4.dll file in FSX/Modules folder and right click and select Properties
  • Navigate to Digital Signatures tab, select the Simflight Gmbh signature in the signatures list and click the "Details" button
  • Now click View Cetificate button and then the "Install Certificate" button. A Certificate Import wizard starts.
  • Click the Next button and then select the radio button with the option "Place all certificates in the following store"
  • Now click the "Browse" button and select "Trusted Publishers" from the drop-down menu and click "Next".
  • Follow the remaining wizard instructions to complete the import operation

 

To check, open IE and select Tools/Internet Options/Content, then click the Publishers button and then the Trusted Publishers tab and Simflight should be listed.

Then run FSX and the Add-ons menu should appear with the FSUIPC option.

Fixed!

Anyway, I hope this helps someone else out. ;)

Best Regards

Mark

BTW: I tried the System Update readiness tool but this failed on install.

Hi there,

Is there any way to do this on windows 10, I am having the same problem but there is not a digital signitures tab on the fsuipc4.dll properties.

thanks

 

Share this post


Link to post
Share on other sites

Hi,

as you can read in Pete's answer above there is no signature anymore, it was removed couple years ago. Which windows you use doesn't matter. Make sure you use latest FSUIPC version.

Thomas

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×