Jump to content
The simFlight Network Forums
Sign in to follow this  
Philburt

Compil "bgl" issue

Recommended Posts

Hello,

I have a problem when i want to compil the traffic with upgraded or new airports with My TrafficX 5.3b

Everything is fine, traffic is created in new or reworked airports but when compiling, no error message but compilation in dosbox is very (too) fast and i cannot see (new) traffic at new or reworked airports (new gates types - military for example...).

After a very long search, i have noted that the "modified file" date of the 4 .bgl files (commercial, mil, closed, global) were never updated.

The ".dat" files in my traffic directory are modified at the day date (and the Departure info show new created traffic for the new airports) but date of the the .bgl in mytraffic\scenery is not updated.

The log files associated at the .dat after the compilation process are all reporting an error in MyAirports.dat :

K:\Win7 Games\Microsoft Flight Simulator X\MyTraffic\countries_regions.csv : Reading country data...

K:\Win7 Games\Microsoft Flight Simulator X\MyTraffic\MyAirports.dat : Reading airport data...

K:\Win7 Games\Microsoft Flight Simulator X\MyTraffic\MyAirports.dat(389029) : error: Unknown airspace class: 1

To be sure the 3 new airports were not "wrong", i created manualy a little traffic in the two new airports direct with the Microsoft SDK including some MytrafficX planes and then i can see the new traffic.

So no FS9 traffic issue i mean !

What am i doing wrong ?

Hope you will have an idea to help me solving this issue ? Automatic shedules with My TrafficX engine is far amazing than ...

Thanks for advance and have a nice day.

Philburt

Share this post


Link to post
Share on other sites

That is a good one... However the error message is correct that there should be no airspace class of "1" - airspace normally comes in lettered degrees of awkwardness from A (don't even think about entering it unless you're an ATPL holder in a fully equipped aircraft) to G (open FIR, do what you like within the law).

That's oversimplified obviously - a normal PPL can enter Class A within certain conditions - but I've never seen Class 1.

Hopefully Burkhard can shed some light on this?

Ian P.

Share this post


Link to post
Share on other sites

That is a good one... However the error message is correct that there should be no airspace class of "1" - airspace normally comes in lettered degrees of awkwardness from A (don't even think about entering it unless you're an ATPL holder in a fully equipped aircraft) to G (open FIR, do what you like within the law).

That's oversimplified obviously - a normal PPL can enter Class A within certain conditions - but I've never seen Class 1.

Hopefully Burkhard can shed some light on this?

Ian P.

It looks like the string that your airport uses for "country" is spelled in a different way than defined in the country_region.csv file, and not the 100ds of translations from known variants the MyTraffic editor knows. Could you edit MyAircraft.dat and just copy the sections about the new airports into your response?

Share this post


Link to post
Share on other sites

Hello Burkhard,

I think you want to say edit MyAirports.dat and catch the new airports datas... the txt file is join.

I have done more new investigations and i believe i now understand what was wrong : not in fact my three reworked airports but one of the few add-ons i have loaded in FSX.

A lot of Payware from different editors but some nice freeware too ! I am a real fan of this great game.

I still don't know the name of the "snake" but I would find it.

To find what was wrong, i compil the MymilRoutes.dat, MyAirports.dat, MyAircraft.dat direct with SDK and have the same error log witch clearly show the problem is MyAirports.dat.

So i take the sames files but replace MyAirports.dat with the Fs10.Airports.dat of Microsoft SDK after adding my 3 brand new airports manualy with notepad.

I compil stil direct in SDK and all was ok !!! just a lot of parking place not found but the bgl was created.

The append with the "dump airports list" from fsx was clearly the issue and i make a new dump airports in fsx after having deactivate all add-on except my three new afcad : EBLG, EBSU and EBSP.

I start My Traffic Editor, reload MTX_V53b.myt and import the new Airports.txt.

I verify my three new airports were udated and delete all traffic in maintenance option of My Traffic Editor.

I make an "autoschedule my planes" and can now compil with success and the new traffic was finally in my reworked airports.

I can believe it was so easy and need me so much time to find the solution.

I am now seeking for the "snake" with adding some scenery to fsx and re dump in Fsx and test compil and so on....

I want to thank you for the fast reply and especially for this great add-on which give lifes in fsx and wish you a good day.

Philburt

MyNewAirports_ from_MyTraffic.txt

Share this post


Link to post
Share on other sites

Hello Burkhard,

I think you want to say edit MyAirports.dat and catch the new airports datas... the txt file is join.

I have done more new investigations and i believe i now understand what was wrong : not in fact my three reworked airports but one of the few add-ons i have loaded in FSX.

A lot of Payware from different editors but some nice freeware too ! I am a real fan of this great game.

I still don't know the name of the "snake" but I would find it.

To find what was wrong, i compil the MymilRoutes.dat, MyAirports.dat, MyAircraft.dat direct with SDK and have the same error log witch clearly show the problem is MyAirports.dat.

So i take the sames files but replace MyAirports.dat with the Fs10.Airports.dat of Microsoft SDK after adding my 3 brand new airports manualy with notepad.

I compil stil direct in SDK and all was ok !!! just a lot of parking place not found but the bgl was created.

The append with the "dump airports list" from fsx was clearly the issue and i make a new dump airports in fsx after having deactivate all add-on except my three new afcad : EBLG, EBSU and EBSP.

I start My Traffic Editor, reload MTX_V53b.myt and import the new Airports.txt.

I verify my three new airports were udated and delete all traffic in maintenance option of My Traffic Editor.

I make an "autoschedule my planes" and can now compil with success and the new traffic was finally in my reworked airports.

I can believe it was so easy and need me so much time to find the solution.

I am now seeking for the "snake" with adding some scenery to fsx and re dump in Fsx and test compil and so on....

I want to thank you for the fast reply and especially for this great add-on which give lifes in fsx and wish you a good day.

Philburt

FSX has changed some ways countries are spelled from FS9 to FSX, so some addon airports that are based on FS9 may show this. If you do not find it easily, zip the airports.txt file and try to attach it here, so that I can try.

Share this post


Link to post
Share on other sites

Hello Burkhard,

I think it could help other users one day so here are the final step.

Finding the "snake" was a hard job because i have a lot of installed Add-ons in FSX (maybe too much !!!) but i finally have found the "guilty payware" scenery which corrupt the MyAirports.dat after "dumping the new airports inside FSX" : FSAddon Lysander Special Opération. A very funny peace of Software in fact !

Maybe there is something wrong with my copy or an issue in the install process, maybe not ?

I will try soon a re-download and re-install to be sure...

Not a great issue because when i know the "guilty", i must just deactivate the scenery, dump in fsx and rebuild traffic in My trafficX editor, compil and reactivate the scenery in FSX and everything is ok !

Thanks again for the quick support of this great add-on.

Philburt

Share this post


Link to post
Share on other sites

Hello Burkhard,

I think it could help other users one day so here are the final step.

Finding the "snake" was a hard job because i have a lot of installed Add-ons in FSX (maybe too much !!!) but i finally have found the "guilty payware" scenery which corrupt the MyAirports.dat after "dumping the new airports inside FSX" : FSAddon Lysander Special Opération. A very funny peace of Software in fact !

Maybe there is something wrong with my copy or an issue in the install process, maybe not ?

I will try soon a re-download and re-install to be sure...

Not a great issue because when i know the "guilty", i must just deactivate the scenery, dump in fsx and rebuild traffic in My trafficX editor, compil and reactivate the scenery in FSX and everything is ok !

Thanks again for the quick support of this great add-on.

Philburt

If you could just put their airports like the other ones, must be easy to fix.

Share this post


Link to post
Share on other sites

Hello Burkhard,

I redump Airports.txt with Lysander SO scenery activated, the part of the "txt" file is in attachment.

Refering the Lysander doc, only one airfield is added in FSX : ICAO : RN - Name : Tangmere Air Base 1942.

Waiting for the final fix :rolleyes:.

Thanks.

Philburt

Tangmere Air Base.txt

Share this post


Link to post
Share on other sites

Just out of interest, I have Jaap's Tangmere scenery installed (I was also involved in parts of that package and beta tested it, so have a slight interest here... ;)) and I've just been looking at it in ADE9X to see if there's anything obviously odd about it. There isn't really. There's a single 13.81m RAMP_MIL_COMBAT (Parking 4) and very little else. The layout and connections all look OK, the airport details look OK, ADE doesn't report any errors in the file, so I'm not sure why it wouldn't work.

I wonder if it is one of the "remote landing zones" - in the same directory - at fault rather than Tangmere itself? I'm not in a position to spend much time looking at this right now, but if you temporarily disable the remote LZ sceneries by moving them out of the folder (JvH*.* and Lizzie*.*) and just leaving Hurricane.bgl and the RAF_Tangmere*.* files in there then try the compile again, does it work? If so, I know who to point at this and see if we can get it fixed. ;)

Cheers,

Ian P.

Share this post


Link to post
Share on other sites

Just out of interest, I have Jaap's Tangmere scenery installed (I was also involved in parts of that package and beta tested it, so have a slight interest here... ;)) and I've just been looking at it in ADE9X to see if there's anything obviously odd about it. There isn't really. There's a single 13.81m RAMP_MIL_COMBAT (Parking 4) and very little else. The layout and connections all look OK, the airport details look OK, ADE doesn't report any errors in the file, so I'm not sure why it wouldn't work.

I wonder if it is one of the "remote landing zones" - in the same directory - at fault rather than Tangmere itself? I'm not in a position to spend much time looking at this right now, but if you temporarily disable the remote LZ sceneries by moving them out of the folder (JvH*.* and Lizzie*.*) and just leaving Hurricane.bgl and the RAF_Tangmere*.* files in there then try the compile again, does it work? If so, I know who to point at this and see if we can get it fixed. ;)

Cheers,

Ian P.

I will check, but the solution may be as simple that ICAOs are 4 Letters, and 3 Letters as exception, but never two letters, so the software does not know what to do with it. If you just edit airports.txt and add two blanks,

RN ,...

I wouldn't wonder if that fixes it, can check this night.

Share this post


Link to post
Share on other sites

If I get to it before you do, I'll try changing that to "X2TG", which is the code from Bones's historical UK airfield list which I would apply to any Tangmere that I created.

Ian P.

Share this post


Link to post
Share on other sites

Hello Ian, hello Burkhard,

I think you are both right, i change the Icao from RN to RN ,(with two spaces) and the compiler runs fine !

No compil issue and new (day-date) "bgl" files.

Bye and thanks for great support (I (we) feel much better when i (we) know why ???).

Philburt

Share this post


Link to post
Share on other sites

Hello Ian, hello Burkhard,

I think you are both right, i change the Icao from RN to RN ,(with two spaces) and the compiler runs fine !

No compil issue and new (day-date) "bgl" files.

Bye and thanks for great support (I (we) feel much better when i (we) know why ???).

Philburt

Simply, a two digit ICAO code does not exist in FSX, nor in real world, so it is a severe airport design bug and will cause problems to many tools...

Share this post


Link to post
Share on other sites

I'll point it at Francois and see if we can get it changed.

Ian P.

Share this post


Link to post
Share on other sites

Hi all,

Ian drew my attention to this topic.

I’m the author of the “guilty” Tangmere scenery. Tangmere has an airport ID of RN. That’s no ICAO code, never meant to be. It’s the airport ID Tangmere had back in the old days. I understand RN causes problems so I changed it in X2TG as Ian suggested. Here is a new version of the airfield now using the new Airport ID X2TG. Unzip the file and place the contents (RAF_Tangmere.bgl) in the FSAddon Lysander folder structure (I believe it is [FSX Mainfolder]\FSAddon\Lysander-SO\Lysander-Scenery\scenery\) thereby overwriting the older version. Or, if you’re not sure, backup the old version under the name ‘RAF_Tangmere.bg#’ or something like that first.

Happy flying!

RAF_Tangmere.zip.

Regards,

Jaap van Hees

Bush Flyer

Share this post


Link to post
Share on other sites

I'll be happy to try and get it changed.

But I didn't make it, it is a freeware addition made by Jaap van Hees and I have no clue on what to change... yet.

But, just chatting with Ian and he offered to change it for me... so it will be done. Thanks Ian !!! :smile:

Share this post


Link to post
Share on other sites

LOL ! 'We' seem to have solved it. Thanks Jaap !

Thanks a lot. Usage of different schemes in one software make a lot of problems behind the scenes, IATA vs ICAO codes as example can create real fuzz...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×