Sign in to follow this  
Followers 0
Jess-b

PMDG MD-11 conflict with FSUIPC

8 posts in this topic

Hi guys,

I'm having trouble with PMDG's MD-11 and fsuipc. Basically, with fsuipc installed, the MD-11 refuses to load up it AIRAC database on startup, leaving FSX hung. If I remove the fsuipc.dll, the aircraft works fine. At the moment there is nothing else interacting with FSX as I'm running just FSX + acceleration, fsuipc and the MD-11 as it seemed the best way to troubleshoot the issue. I'm using the latest update of 4.84 although I have checked it using an older version, v4.74 but with no luck. I've checked the dll.xml and all seems fine. I've even edited the dll file to load fsuipc before the PMDG software, again to no avail.

So I'm kind of stumped. With the md-11 installed, FSX hangs, I reset, then FSX tells me the problem is with the fsuipc.dll. I click yes and all is well until I try and load the aircraft up.

Any ideas guys would be welcome.

Best wishes,

Jessica Bannister-Pearce

0

Share this post


Link to post
Share on other sites

So I'm kind of stumped. With the md-11 installed, FSX hangs, I reset, then FSX tells me the problem is with the fsuipc.dll. I click yes and all is well until I try and load the aircraft up.

So it isn't an initialisation problem? It can occur later, after you are able to use FS?

It must be something specific to your system as the PMDG MD11 is used with FSUIPC quite successfully by most folks. there are even macro libraries for it (see the thread PMDG MD11X commands in the User Contributions subforum).

What information does Windows give as to why it is an FSUIPC problem? (Check the Windows error log).

Pete

0

Share this post


Link to post
Share on other sites

Hi Pete,

Thanks for Getting back to me. Here's the details from the last windows event viewer error report. it doesn't mention FSUIPC just Fsx. Hope it helps.

Log Name: Application

Source: Application Hang

Date: 12/08/2012 17:55:01

Event ID: 1002

Task Category: (101)

Level: Error

Keywords: Classic

User: N/A

Computer: Chillblast-PC

Description:

The program fsx.exe version 10.0.61637.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.

Process ID: 1270

Start Time: 01cd78aae07d1145

Termination Time: 45

Application Path: F:\fsx\fsx.exe

Report Id: 68fe3a91-e49e-11e1-abf9-c860000a8d6e

Event Xml:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

<System>

<Provider Name="Application Hang" />

<EventID Qualifiers="0">1002</EventID>

<Level>2</Level>

<Task>101</Task>

<Keywords>0x80000000000000</Keywords>

<TimeCreated SystemTime="2012-08-12T16:55:01.000000000Z" />

<EventRecordID>11710</EventRecordID>

<Channel>Application</Channel>

<Computer>Chillblast-PC</Computer>

<Security />

</System>

<EventData>

<Data>fsx.exe</Data>

<Data>10.0.61637.0</Data>

<Data>1270</Data>

<Data>01cd78aae07d1145</Data>

<Data>45</Data>

<Data>F:\fsx\fsx.exe</Data>

<Data>68fe3a91-e49e-11e1-abf9-c860000a8d6e</Data>

<Binary>430072006F00730073002D00740068007200650061006400000044006500610064006C006F0063006B0000000000</Binary>

</EventData>

</Event>

This is also a copy of the FSUIPC log file

********* FSUIPC4, Version 4.84 by Pete Dowson *********

User Name="Jessica Bannister-Pearce"

User Addr="j.bannister-pearce@virgin.net"

FSUIPC4 Key is provided

WIDEFS7 not user registered, or expired

Running inside FSX on Windows 7

Module base=61000000

515 System time = 12/08/2012 17:52:43

515 FLT path = "C:\Users\Chillblast\Documents\Flight Simulator X Files\"

531 Trying to connect to SimConnect Acc/SP2 Oct07 ...

531 FS path = "F:\fsx\"

796 LogOptions=00000000 00000001

796 Wind smoothing fix is fully installed

796 G3D.DLL fix attempt installed ok

796 SimConnect_Open succeeded: waiting to check version okay

796 Trying to use SimConnect Acc/SP2 Oct07

2075 Running in "Microsoft Flight Simulator X", Version: 10.0.61637.0 (SimConnect: 10.0.61259.0)

2075 Initialising SimConnect data requests now

2075 FSUIPC Menu entry added

2122 F:\fsx\FLIGHTS\OTHER\FLTSIM.FLT

2122 F:\fsx\SimObjects\Airplanes\Aircreation_582SL\Aircreation_582SL.AIR

For the record I'm using a Nvidia Surround setup. (I thought I'd mention it because i've seen several people comment on errors when using such a system.)

Hope this helps,

Jessica Bannister-Pearce

0

Share this post


Link to post
Share on other sites

Thanks for Getting back to me. Here's the details from the last windows event viewer error report. it doesn't mention FSUIPC just Fsx. Hope it helps.

No, sorry. There's really no indication there that it's specifically fSUIPC. Please see the thread near here about SimConnect and BGLMANX. That remains unresolved too. However, you should try version 4.85, the current release, please.

Does everything run okay without this "surround" setup? I've actually never heard of that, by the way. Is it new?

Regards

Pete

0

Share this post


Link to post
Share on other sites

Hi Pete,

I'll give version 4.85 a try soon. At the moment I'm checking against a second computer which strangely, doesn't suffer with from the issues I'm finding on. The other. (btw I also checked the PMDG 747 on the problem system and the results are the same. Hmmmm).

With reference to the surround system. It's just nvidia's answer to ATI/AMD eyefinity. I'm currently running i7 2600k machine via a nvidia 680 Gtx feeding 3 screens. It was working but for some reason I can't fathom, now it's throwing it's toys out of the pram.

Anyway I'm about to update to the same nvidia driver on the good system to see if that's causing the issue. (this system is running fsuipc 4.827 with no issues.)

I'll report back soon.

Best wishes,

Jess B

0

Share this post


Link to post
Share on other sites

With reference to the surround system. It's just nvidia's answer to ATI/AMD eyefinity.

I have three monitors on one of my systems with a humber nVidia 7600GS driving through a Matrox TripleHead2Go. I think that was one of the first real "surround" video setups.

The other two reports of problems with nVidia Surround are at start-up -- FSX never loads. In one case it is sometimes in combination with another DLL (BGLMANX.DLL), but the inconsistent results from trying different things strongly suggests timing issues -- i.e. bugs between SimConnect and the video drivers or the trust verification system. Your report is the only one which suggests problems later on, well past the trust verification -- except maybe that for the PMDG MD-!! components?

I noticved there was no sign of the MD-11 having loaded in the FSUIPC log you showed. The last entry appears to be the loading of the standard FSX default.

Regards

Pete

0

Share this post


Link to post
Share on other sites

Solved it!

Turns out it is directly related to nvidia surround. More importantly to the current beta driver 304.79. Rolling the drivers back to 304.48 (or even the last official 301.42) stops the issue with various .dll files not loading.

Thanks for your help Pete. I hope this info is useful to others, and more importantly, enjoy your holiday. (I just got back from mine, hence the driver update that did the damage.)

Best wishes,

Jess B

0

Share this post


Link to post
Share on other sites

Solved it!

Turns out it is directly related to nvidia surround. More importantly to the current beta driver 304.79. Rolling the drivers back to 304.48 (or even the last official 301.42) stops the issue with various .dll files not loading.

Super! Thanks for working it out!!

Pete

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0