phickey

FS9, FSUIPC 3.99, and Win7 Pro (64 bit) trouble

8 posts in this topic

Hello Pete,

I've been happily using FSUIPC (registered) on FS9 for many years, thank you very much for this awesome program.

I have not updated to the latest version, my last download is version 3.99, which was done a few months back.

I've built a new PC, and upgraded to Win7 Pro 64 bit from WinXP.

I installed FS9 into it's own folder on the root directory (c:\Flight Simulator 9), away from Program Files and Program Files (x86). I right clicked on fs9.exe and told Win7 to run it as administrator.

At this point, FS9 would load and run. So, I began installing the many add-ons.

When I got FSUIPC 3.99 installed and input the key, FS9 would not run. Win7 would start FS9, showing the start up screen then show that "Flight Simulator has stopped running", and return to the desktop.

When I removed the FSUIPC.dll from the FS9 modules folder and restarted FS9, it would run.

I've got something in Win7 setup wrong for it not to allow FS9 to run with FSUIPC.dll in the modules folder, but I have no idea what that could be. I'm so new to Win7 that I feel like a noobie.

I browse through the many postings here at simFlight, and the FAQ section, searching for similar Win7 solutions but didn't see any. Not sure if my error is a signature verification issue or not.

I greatly appreciate your assistance with this problem. Let me know if more details about this new system of my are needed.

Paul

0

Share this post


Link to post
Share on other sites

I have not updated to the latest version, my last download is version 3.99, which was done a few months back.

You need to be on the current version for support.

When I got FSUIPC 3.99 installed and input the key, FS9 would not run. Win7 would start FS9, showing the start up screen then show that "Flight Simulator has stopped running", and return to the desktop.

When I removed the FSUIPC.dll from the FS9 modules folder and restarted FS9, it would run.

Download and Install 3.999z and try again.

Pete

0

Share this post


Link to post
Share on other sites

Ok, I've updated to the latest version 3.999z, followed the install instructions, and placed the SimFlight certificate in the Trusted Publishers location per the FAQ posting.

I still get the "Flight Simulator has stopped running" error message with the FSUIPC.dll file in the modules folder.

When I remove the fsuipc.dll file from the modules folder, FS9 runs.

FS9 runs with and without XP SP3 compatility set, and with or without "run as administratror". As long as the FSUIPC.dll is renamed or absent from the modules folder, FS9 runs.

What else am I doing wrong?

Edited by phickey
0

Share this post


Link to post
Share on other sites

... and placed the SimFlight certificate in the Trusted Publishers location per the FAQ posting.

There's never been any need to do that except in versions of Wiindows before XP SP1. You seem to be making some assumption about whatever it is going on without information.

I still get the "Flight Simulator has stopped running" error message with the FSUIPC.dll file in the modules folder.

When I remove the fsuipc.dll file from the modules folder, FS9 runs.

Show me the FSUIPC Install log file and, if one is present the FSUIPC.LOG file. You'll find both in the FS Modules folder. Also see if you can find the Windows crash data fr this -- in the Event Viewer, Windows Logs, Application. I need most of the details there -- module name, offset, and error code.

Paste logs into a message.

Pete

0

Share this post


Link to post
Share on other sites

Thanks for responding so quickly. I've pasted below as much of the information from Win7 you asked for as I could find.

Thanks again for all your help.

Here's the Install Log

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Installer for FSUIPC.DLL version 3.999z

Looking in registry for FS9.1 install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.1

Parameter"EXE Path"

Not there, so looking in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.1

Parameter"EXE Path"

... NOT found! ...

Looking in registry for FS9 install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.0

Parameter"EXE Path"

... >>> OK! FOUND FS9! <<< ...

===========================================================

INSTALLATION FOR FS9:

EXE Path="C:\Flight Simulator 9"

Checking if there's already a version of FSUIPC installed in:

C:\Flight Simulator 9\Modules\FSUIPC.DLL

... No previous valid version found.

Okay -- installed FSUIPC into "C:\Flight Simulator 9\Modules\FSUIPC.DLL"

"Modules\FSUIPC Documents" folder already exists.

Now installing additional files into the "Modules\FSUIPC Documents" folder:

Installed "FSUIPC User Guide.pdf" okay

Installed "FSUIPC for Advanced Users.pdf" okay

Installed "FSUIPC History.pdf" okay

Installed "List of FS2004 controls.pdf" okay

Installed "GlobalSign Root.exe" okay

Installed "FSUIPC Lua Library.pdf" okay

Installed "FSUIPC Lua Plug-Ins.pdf" okay

Installed "Lua License.pdf" okay

Installed "Lua Plugins for VRInsight Devices.pdf" okay

Installed "LuaFileSystem.pdf" okay

Installed "Example LUA plugins.zip" okay

Installed "SIMSAMURAI+FSUIPC+TUTORIAL.pdf" okay

Installed "FSUIPC for Programmers.pdf" okay

FSUIPC.DLL installed and signature checked out okay!

Deleted GlobalSign Root fix program ... no longer relevant

===========================================================

All installer tasks completed okay!

Registration for FSUIPC was successful! (result code 00)

*************** End of Install Log ***************

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

The Event Viewer showed 4 Errors and 1 Information event when attempting to run FS9 at 6:13 pm this evening

Error #1: - System

- Provider

[ Name] Application Error - EventID 1000

[ Qualifiers] 0 Level 2 Task 100 Keywords 0x80000000000000 - TimeCreated

[ SystemTime] 2013-03-06T23:36:13.000000000Z EventRecordID 3462 Channel Application Computer Paul-PC Security - EventData

fs9.exe 9.0.0.30612 3ee94003 ntdll.dll 6.1.7601.17725 4ec49b8f c0000005 00033ab5 ee0 01ce1ac35b04b3ab C:\Flight Simulator 9\fs9.exe C:\Windows\SysWOW64\ntdll.dll a1509d96-86b6-11e2-b45d-50465d59eb68

Edited by phickey
0

Share this post


Link to post
Share on other sites

Thanks for responding so quickly. I've pasted below as much of the information from Win7 you asked for as I could find.

Was there no FSUIPC.LOG file? If not, then FSUIPC hasn't actually been run. The crash would be occurring before it is loaded.

The Event Viewer showed 4 Errors and 1 Information event when attempting to run FS9 at 6:13 pm this evening

And did FS9 actually crash 4 times at 6:13?

The only information wanted out of all that appears in only two of those, just this:

Error #1:

TimeCreated [ SystemTime] 2013-03-06T23:36:13.000000000Z

EventData fs9.exe 9.0.0.30612

ntdll.dll 6.1.7601.17725

c0000005

C:\Flight Simulator 9\fs9.exe

C:\Windows\SysWOW64\ntdll.dll

The other, the "information at the end" is similar.

This is an Access Violation occurring in "ntdll.dll". And unless your computer's clock is wrong, occurred at 23:36, not 6:13. There's nothing indicating any involvement of FSUIPC at all.

It is looking like your problem is not specifically realted to fSUIPC, except possibly just that with FSUIPC loading the timing and memory layout would be slightly different.

I think there is one really big problem, and that is your FS9 installation is out of date. Version 9.0 is the original one with all its bugs. I most strongly suggest you install the update to bring it up to 9.1 level. The FS9.EXE version number will then read "9.1.0.40901". I cannot really help with the original one because everyone should have updated to fix the many bugs. Maybe when you built your new PC you forgot to install the update?

If the problem still occurs after you've updated, I think you need to think about ways of narrowing down the problem further. If you have other add-ons, try without as many of them as possible, then gradually add them in. Make sure there are no other DLLs in the Modules folder other than genuine FS9 DLLs plus FSUIPC.DLL.

Regards

Pete

0

Share this post


Link to post
Share on other sites

By the way, one clarification on this:

I think there is one really big problem, and that is your FS9 installation is out of date. Version 9.0 is the original one with all its bugs. I most strongly suggest you install the update to bring it up to 9.1 level. The FS9.EXE version number will then read "9.1.0.40901". I cannot really help with the original one because everyone should have updated to fix the many bugs. Maybe when you built your new PC you forgot to install the update?

I did not intend to imply that FSUIPC 3.999z shouldn't work with FS9.0. It does -- in fact I installed the original version on a separate PC just to make sure I'd not messed anything up. But there are many changes which other add-ons you have might tangle with which are fixed in FS9.1.

Regards

Pete

0

Share this post


Link to post
Share on other sites

Thanks Pete,

I did forget to run the 9.1 update yesterday. I uninstalled then reinstalled FS9 to the same folder that contained the other add-on installs, FSNav, GEPro, etc...Then installed FSUIPC 3.999z, forgetting to run the FS9.1 update.

I'll scrub everything off the harddrive, reinstall FS9, the 9.1 update, then FSUIPC 3.999z only and see what happens.

Paul

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now