Jump to content
The simFlight Network Forums

Recommended Posts

Well, after updating to the newest version (installing all interm updates since the final 3.2.3 version does not say it's all inclusive), I get the following JIT error:

 


***************************************************************************************************************
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IndexOutOfRangeException: Index was outside the bounds of the array.
   at TOPER_B777X.Form1.btnCalc_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
TOPER B777
    Assembly Version: 3.2.0.3
    Win32 Version: 3.2.0.3
    CodeBase: file:///C:/FSUtils/Topper/TOPER%20Calculator%20Tool/B777/TOPER%20B777.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 12.0.51209.34209 built by: FX452RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34238 built by: FX452RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34251 built by: FX452RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34270 built by: FX452RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34245 built by: FX452RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
******************************************************************************************************************************************************************************************

   Looks like Topper is trying to access an array element that's outside the bounds of the array when I click the calculate button.  I'm running in Admin mode and Windows 7, btw.  Ideas?  Thanx.

 

-Rick

Share this post


Link to post
Share on other sites

Well, after updating to the newest version (installing all interm updates since the final 3.2.3 version does not say it's all inclusive), I get the following JIT error:

 

...

   Looks like Topper is trying to access an array element that's outside the bounds of the array when I click the calculate button.  I'm running in Admin mode and Windows 7, btw.  Ideas?  Thanx.

 

-Rick

Dear RIck,

 

I am sorry to hear you had issues running TOPER. Does is crash all the time or at some particular set of parameters (please provide me with the info. you used to perform the calculation when the crash happened)?

 

You could also try uninstalling TOPER and deleting everything in the destination folder and re-installing it again with all the updates (3.0.12, 3.0.15, 3.0.16, 3.1.0, 3.2.0, 3.2.1, 3.2.2, 3.2.3),

 

Kind regards,

Share this post


Link to post
Share on other sites

It happens Nikola..  I've never seen (or written) any program that is 100% bug free right at the start.  :-)  It seems to do it on TO/TO-1 but not on TO2. Here's the info entered (in Imperial wgts)

 

RJAA

34R

Itxn  blank

Dry

wind 0/6/kts

temp 1c

2991

flap 5

ac On

a/i off

TO-2

TOW 493112

 

   Using TO and TO-1 causes the crash.  Let me know if you can reproduce it and if you need any other info.  Thanx.

 

-Rick

Share this post


Link to post
Share on other sites

Dear Rick,

 

there was a corrupt database file causing the exception error you have mentioned. This has been addressed in the new update 3.2.4. Please visit the updates section to download it.

 

Thank you for helping out in making TOPER better.

 

Kind regards,

Share this post


Link to post
Share on other sites
Hello!
 
I would like to report a possible bug into the TOPER 777 tool.
 
This is happening at MMMX, when I try  to get the values of MTOW allowed for RWYS 05's TOPERS's calculation shows  very low values around 142 tons MAX which it is really low, ok?  While for the RWY 23R INTX B gave me a MAX of 226400KGS  it makes more sense. Apparently this problem is because I can't choose an option in the INTX box, and the tool show me an under rated value.
 

Anyway I did a test with a 777-300ER empty and just with 30 tons of fuel in order to be above of the minimum take off weight. 

 

185899prueba1.jpg

 

 

494559prueba2.jpg

Share this post


Link to post
Share on other sites

 

Hello!
 
I would like to report a possible bug into the TOPER 777 tool.
 
This is happening at MMMX, when I try  to get the values of MTOW allowed for RWYS 05's TOPERS's calculation shows  very low values around 142 tons MAX which it is really low, ok?  While for the RWY 23R INTX B gave me a MAX of 226400KGS  it makes more sense. Apparently this problem is because I can't choose an option in the INTX box, and the tool show me an under rated value.
 

Anyway I did a test with a 777-300ER empty and just with 30 tons of fuel in order to be above of the minimum take off weight. 

 

 

Indeed there was a bug in the code after new intersections feature was added: this has now been resolved and update 3.3.4 can be downloaded from the updates section.

 

Thank you for your patience and valuable feedback provided.

 

Kind regards,

Share this post


Link to post
Share on other sites

Hi Nikola

 

I've updated to the latest version v3.3.5

Something is totally wrong with the TO weight calculation. Just try this :

 

B777-300ER

KIAH

RWY 15L

FULL

DRY

Wind 0/0

OAT 15C

QNH 2992 IN

Takeoff Weight 340000 KG

FLAP 15

 

==> Overweight Message appears ==> Aircraft weight exceeds the limit for selected runway length (TOW>max TOW=224900kg)

 

According the Boeing data for standard day at sea level TO Weight 340000kg a runway length of less than 3000m is required!

 

Thanks for help

Bruno

Share this post


Link to post
Share on other sites

Hi Nikola

 

I've updated to the latest version v3.3.5

Something is totally wrong with the TO weight calculation. Just try this :

 

B777-300ER

KIAH

RWY 15L

FULL

DRY

Wind 0/0

OAT 15C

QNH 2992 IN

Takeoff Weight 340000 KG

FLAP 15

 

==> Overweight Message appears ==> Aircraft weight exceeds the limit for selected runway length (TOW>max TOW=224900kg)

 

According the Boeing data for standard day at sea level TO Weight 340000kg a runway length of less than 3000m is required!

 

Thanks for help

Bruno

 

Hello Bruno,

 

thank you very much for providing me with this information. I will investigate and let  you know of my findings as soon as possible.

 

Kind regards,

Share this post


Link to post
Share on other sites

Hi Nikola

 

I've updated to the latest version v3.3.5

Something is totally wrong with the TO weight calculation. Just try this :

 

B777-300ER

KIAH

RWY 15L

FULL

DRY

Wind 0/0

OAT 15C

QNH 2992 IN

Takeoff Weight 340000 KG

FLAP 15

 

==> Overweight Message appears ==> Aircraft weight exceeds the limit for selected runway length (TOW>max TOW=224900kg)

 

According the Boeing data for standard day at sea level TO Weight 340000kg a runway length of less than 3000m is required!

 

Thanks for help

Bruno

 

Dear Bruno,

 

the issue has been fixed in update 3.3.6. Please visit the http://forum.simflight.com/topic/75665-toper-tool-boeing-777-updates/

 

Thank you very much for your help.

 

Kind regards,

Share this post


Link to post
Share on other sites

Hi there

Just updated 3.3.6, but for some reason it won't let me type in anything i.e. Airport, weather etc........

 

Can you help?

Thank you

Mark

Share this post


Link to post
Share on other sites

Dear Mark,

 

I am very sorry to hear that TOPER no longer works after the update. Please try uninstalling it completely, deleting the installation folder and re-installing. This is the first time I hear about this issue.

 

Please let me know how it went.

 

Kind regards,

Share this post


Link to post
Share on other sites

Hi Nikola

 

I've updated to the latest version v3.3.5

Something is totally wrong with the TO weight calculation. Just try this :

 

B777-300ER

KIAH

RWY 15L

FULL

DRY

Wind 0/0

OAT 15C

QNH 2992 IN

Takeoff Weight 340000 KG

FLAP 15

 

==> Overweight Message appears ==> Aircraft weight exceeds the limit for selected runway length (TOW>max TOW=224900kg)

 

According the Boeing data for standard day at sea level TO Weight 340000kg a runway length of less than 3000m is required!

 

Thanks for help

Bruno

 

Updated from Version 3.3.5 directly to 3.3.7 and the behavior is still the same...

 

Any help???

Share this post


Link to post
Share on other sites

Updated from Version 3.3.5 directly to 3.3.7 and the behavior is still the same...

 

Any help???

 

Yes, I am getting the same thing. Let me check it out to see what is causing this issue. I think I am having another problem which is kind of opposite of this one-so I fix one and the other one shows up. Sorry for the inconvenience.

Share this post


Link to post
Share on other sites

Updated from Version 3.3.5 directly to 3.3.7 and the behavior is still the same...

 

Any help???

 

Dear Bruno,

 

I have fixed the issue you have reported: it had to do with runway and intersection units getting mixed up. I will, however, do some testing before I release the new update-just to make sure everything is working properly.

Kind regards,

Share this post


Link to post
Share on other sites

Dear Bruno,

 

I have fixed the issue you have reported: it had to do with runway and intersection units getting mixed up. I will, however, do some testing before I release the new update-just to make sure everything is working properly.

Kind regards,

 

Dear Bruno,

please go ahead and download version 3.3.8. The issue you have reported is no longer there. I still need to do some extensive testing, which should be done in the next week or so.

 

Thank you for your patience.

 

Kind regards,

Share this post


Link to post
Share on other sites

Hello,

I have just found something with the t/o calculations for the rwy 13R at KJFK for the -300ER, it reverts with an error message.

I have tried with the other runways, other airports and other versions of the T7, the mistake seems to be specific to that config.

You may try the following parameters:

KJFK rwy 13R

Aircraft: 777-300ER, flaps 15, A/C on, A/I off, rtg TO

Weather: dry, 180/13kt, 15 deg C, 3009 IN

t/o weight: 299100kg

 

Could you please check that issue?

 

Thanks.

Romain

Edited by Budbud

Share this post


Link to post
Share on other sites
On 19/05/2016 at 1:08 AM, Budbud said:

Hello,

I have just found something with the t/o calculations for the rwy 13R at KJFK for the -300ER, it reverts with an error message.

I have tried with the other runways, other airports and other versions of the T7, the mistake seems to be specific to that config.

You may try the following parameters:

KJFK rwy 13R

Aircraft: 777-300ER, flaps 15, A/C on, A/I off, rtg TO

Weather: dry, 180/13kt, 15 deg C, 3009 IN

t/o weight: 299100kg

 

Could you please check that issue?

 

Thanks.

Romain

Dear Romain,

thank you for reporting this issue. I am currently in the process of re-building TOPER which will make it more precise and less prone to bugs like the one you have mentioned.

Thank you once more for your post.

Kind regards,

Share this post


Link to post
Share on other sites

Hi,

I'm having trouble upgrading from 3.3.8 to 3.3.9.  Every time I run the installer it tells me that " Previous version of Toper 777 already installed." along with requisite uninstall instructions.  I've tried uninstalling and starting again with 3.0 and then installing 3.3.9 but I end up with the same message.

Any ideas?

Cheers

Richard

 

 

Share this post


Link to post
Share on other sites
8 hours ago, Wiseblood said:

Hi,

I'm having trouble upgrading from 3.3.8 to 3.3.9.  Every time I run the installer it tells me that " Previous version of Toper 777 already installed." along with requisite uninstall instructions.  I've tried uninstalling and starting again with 3.0 and then installing 3.3.9 but I end up with the same message.

Any ideas?

Cheers

Richard

 

 

Dear Richard,

I admit that it seems a bit confusing, but this is the only way of connecting old with the new. Here is what you need to do:

  1. Run the provided uninstaller for the version that was initially installed. In your case it's now 3.0
  2. After this is completed, just run 3.3.9 installer and it should work

Please let me know if the issue persists.

Kind regards,

 

Share this post


Link to post
Share on other sites

Thanks for replying.  Unfortunately the issue simply repeats itself with each attempted update following those instructions.  Problem persists with 3.3.10 too.

The error message mentions a 'Toper Uninstaller', but I can't find that option in Toper, so instead simply run the Windows 10 Control Panel uninstaller.  I've also noticed that the V.3.0 i originally purchased from Simmarket is actually 3.04.  Is this the likely problem?

Anyway, as it stands 3.3.8 is the last version of Toper I can successfully install and run.

Cheers

Share this post


Link to post
Share on other sites
19 hours ago, Wiseblood said:

Thanks for replying.  Unfortunately the issue simply repeats itself with each attempted update following those instructions.  Problem persists with 3.3.10 too.

The error message mentions a 'Toper Uninstaller', but I can't find that option in Toper, so instead simply run the Windows 10 Control Panel uninstaller.  I've also noticed that the V.3.0 i originally purchased from Simmarket is actually 3.04.  Is this the likely problem?

Anyway, as it stands 3.3.8 is the last version of Toper I can successfully install and run.

Cheers

Please navigate to TOPER installation folder and delete the 'B777' directory only. You should be able to run the new update, then. The only reason why new versions, 3.3.9 and higher, request you to run uninstaller is because the main executable is now in a different location and any shortcuts from previous versions will not work. 

Please let me know how it went.

Kind regards,

Nikola

 

Share this post


Link to post
Share on other sites

Hi Nikola,

Appreciate the support, and following your instructions 3.3.10 installs ok now, but on running the activation utility I'm getting a 'DLL library is out of date' message from a CMD window, at which point the utility shuts down.

Cheers

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×