Jump to content
The simFlight Network Forums
Sign in to follow this  
flying-w

STB V3.3 for Prepar3D V2 published, and sent to the shops!

Recommended Posts

STB V3.3 for Prepar3D V2 is now complete, and will shortly become available in those shops able to sell it.  Full details below, including how the various versions of STB for each simulator relate to each other!  This information is also included in the FAQ post.

 

Which Flight Simulators do you support?

  • FSX SP2 and Gold edition.  You require STB V3 for FSX.  SP1 and RTM may work, but we can no longer investigate and resolve any support issues. 
  • Prepar3D V1.4.  You require STB V3 for Prepar3D (V1)
  • Prepar3D V2.  You require STB V3 for Prepar3D V2

STB for FSX and STB for Prepar3D are separate products and you must purchase a licenses appropriate to the simulators you wish to use.

 

As Prepar3D V2 and be installed at the same time as V1.4 (i.e. it is not so much an upgrade but rather a "side by side" product), the same is true for STB.  STB for Prepar3D V1 can be installed at the same time as STB V3.3 for Prepar3D V2, and used indepdently.  If you already own STB V3 for Prepar3D (V1), V3.3 for Prepar3D V2 is available to you free of charge.  Please visit the shop where you made your original purchase to obtain it, but note it may take some time for the shops to make it available.  As it becomes available, I'll try to update the information here with specific details.

 

If you have STB V3 for FSX, you can acquire STB V3.3 for Prepar3D V2 at a massively discounted price of 75% from your original place of purchase.  Again please be patient while the shops do the publishing work.

 

Any problems, please contact me for help.  If you are desperate for V2 right now, I quite understand and if you'd rather not wait please contact me and I'll try to help you out.

 

Simon

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×