Jump to content
The simFlight Network Forums
Sign in to follow this  
flying-w

STB for FSX-SE Update

Recommended Posts

Following the recent FSX Steam Edition update (62615), STB for FSX-SE is no longer able to connect.  This seems to be business as usual for Steam, whenever an update arrives SimConnect changes and older clients are in trouble.  However this time the FSX Acceleration Pack SimConnect client was installed automatically by Steam.  I've redesigned STB to use that (back to it's roots you might say) which does not reduce the capability of STB in anyway and I hope makes us immune to future steam updates.

 

STB for FSX-SE V3.3.2.15 is now available and I've sent an email to all those I have on record with STB for FSX-SE.  If you've not receive an email, please contact me.

 

If your an STB for FSX customer and would like to receive STB for FSX-SE, please contact me.

 

Simon

Share this post


Link to post
Share on other sites

installed the update today - up and running

 

just a reminder to others: I made the mistake to install the STB on a remote computer before updating the simconnect client, didn't work :???: ....

 

FIRST update simconnect -> THEN update STB :idea: (lesson learned)

 

Thanks for the fast support!

 

happy landings

 

Juergen

Share this post


Link to post
Share on other sites

Thanks for sharing the experience.  I'd like to think now we are using the "xpack" client, no simconnect client updates will be required in the future.

 

simon

Share this post


Link to post
Share on other sites

well - I hope dovetail learned their lesson - "don't change anything you don't neet to change"

 

...they didn't make many fans by doin' it (and I don't only speak of addon developers having to do hotfixes)

Share this post


Link to post
Share on other sites

Hey Simon- I was not aware about the FSX Steam update. I am trying to use Steam but the stb's I have are not finding the right folder. (Duh)    Anyway...my Simarket order number is 878971 FSX  and 1056976 for P3D. Do I have to buy the update or can you email me whatever.  unc1rlm@gmail.com.   Maybe once I get that resolved I can get the logos to work. I am usimg My Traffic 6 from Burkhard... If I need to buy the update..ok...not that I want too..lol...but hey I know your time and development frustrations are worth it. :)   The update page for fsx-steam doesn't work.. you probably took down.. Have a good one.

 

Robert Morehead

Share this post


Link to post
Share on other sites

Well Thank you Simon :) Now that's support!!!

 

Bob Morehead

 

Simon.. Everything  works great networked for p3dv3.1 but the data server I am using for Steam is obviously wrong and its looking for fsx. Which ds should I use. I have just fsx steam and p3dv3.1 (ON the same computer) no boxed version of fsx at all.  Thanks...You sent me the fsx steam proggy but I need the data server for fsx steam steam if you would be so gracious to email it to me unc1rlm@gmail.com

 

 

PS I am reading the instructions now for Steam and downloading stb-ds 3 .....maybe it will work lol...no such luck. I have fsx steam and p3dv3.1 both on same machine but the readme is not clear (at least for me) doesn't spell this out?

 

The files in this zip are the installers for SuperTrafficBoard Data Server (STBDS).  This must be installed on your simulator computer (i.e. FSX or Prepar3D computer) when you wish to use STB on a separate computer.  Each installer will upgrade old versions of STBDS.  Please choose the installer relevent to your environment from the list below:

STBDS_FSX_Setup_3.2.1.5.exe
---------------------------
This is SuperTrafficBoard Data Server for Microsoft Flight Simulator X (Both Original Microsoft Boxed, and Steam Edition when not installed on the same computer as the original Microsoft Version). 

 

STBDS_FSXSE_Setup_3.3.2.15.exe
------------------------------
This is not included in this package, but available to you if you send me a request.  This is only required if you run both the original FSX and FSX Steam edition side by side on the same computer.

 

STBDS_P3DV1_Setup_3.2.0.49.exe
------------------------------
This is SuperTrafficBoard Data Server for Lockheed Martin Prepar3D Version 1 only.  It is not compatible with Prepar3D V2 or later, nor any edition of Microsoft Flight Simulator X.

 

STBDS_P3DV2_Setup_3.3.2.11.exe
------------------------------
This is SuperTrafficBoard Data Server for Lockheed Martin Prepar3D Version 2 including V2.5.  It is not compatible with Prepar3D V1, V3 nor any edition of Microsoft Flight Simulator X.

STBDS_P3DV3_Setup_3.4.0.5.exe
------------------------------
This is SuperTrafficBoard Data Server for Lockheed Martin Prepar3D Version 3. It is not compatible with Prepar3D V1, V2 nor any edition of Microsoft Flight Simulator X

Share this post


Link to post
Share on other sites

Hi Bob,

The deciding factor here is the version of STB you have on your non Simulation computer:

 

1) If you have STB for FSX, you require STBDS_FSX_Setup_3.2.1.5.exe.

2) If you have STB for FSX-SE, you require STBDS_FSXSE_Setup_3.3.2.15.exe

 

The problem here was caused by FSX-SE not providing a backwardly compatible SimConnect client in the early days, which meant STB for FSX-SE was always required even if the original FSX had never been used on the simulator PC.  Now that's changed, STB for FSX-SE is only required when installing both FSX and FSX-SE side by side.

 

STB for FSX-SE is being repurposed for that environment only (dual FSX based simulators), but will take time.

 

Simon

Share this post


Link to post
Share on other sites

hi simon i had the previous super traffic board for steam edition do i still have to provide the details of my previous order for the update? if not here is my e-mail NickBusby34@gmail.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×