Jump to content
The simFlight Network Forums
Mr_LoL

Can't control WOAI traffic

Recommended Posts

Hey

STB cannot control AI traffic in WOAI. I can view AI ok and the board tells me whats arriving/departing but when it comes to deleting planes or preventing go arounds, the program will tell me BA 1554 is at gate due to approach separation yet it will still be on  on approach or going around. This is a brand new install of Prepar3d V3.4. STB works perfectly fine with MyTraffic but I hate the models with that package.

Any ideas?

Share this post


Link to post
Share on other sites

Not sure that should be happening, unless something changed in Prepar3D and AI are getting recreated in the vicinity of the airport after being deleted.  Most WOAI modes are FS9 format, so maybe that has something to do with it also.  In any case, the thing to do is to set up a trace as per Appendix C of the user guide, recreate the problem, and take a screenshot of STB.  Make sure the "FS ID" column is showing on STB, and tell me which flight is affected.

Simon

Share this post


Link to post
Share on other sites

Hi Simon.

I have done what you have requested and attached the files. As you can see STB tells me that the planes are now on stand, yet they keep going around. Heathrow is now full of traffic going around lol. Is there something I should add to a config file? All flights are affected. 

It's a strange problem as I can order an aircraft to depart and it will it's just all these go arounds that suck.

TrafficBoardFrontEnd.txt

crash.txt

stb.jpg

Share this post


Link to post
Share on other sites

Any News please Simon? I appreciate the fact you have a life and all but anything I should be doing?

Share this post


Link to post
Share on other sites

Some news yes.  Can you tell me please which version of STB for Prepar3D you have installed please?  The trace is telling me 3.4.0.6 which is rather old now, we are on 3.4.0.29 public release and V3.4.1.1 for forum visitors now.

From what I see in the trace, there are significant mismatches between STB's knowledge of your flight plan schedule and what is going on in the simulator.  Now I wonder if that's something to do with WOAI scheduling files.  Are the BGLs you are using for WOAI FS9 or FSX format?  You might want to compile the airport database with the trace active and send that to me also.  I'd also like to understand whether the compile makes any difference to the problem.

Thanks
Simon

Share this post


Link to post
Share on other sites

Yes. I'm using 3.4.06. This is the latest version that's available on simmarket. How do I get the update? 

The BGL's are FSX format...I think. I have uploaded an image

fsxxx.jpg

Share this post


Link to post
Share on other sites

Hi Simon

Thanks that update fixed it. Wondering why it's not on Simmarket. 

All I have to figure out is why some woai traffic doesn't show on V4.

Share this post


Link to post
Share on other sites

Simon I know this isn't your forte but in V4 some woai aircraft that were showing in V 3.4 aren't displaying in V4. Any ideas?

Share this post


Link to post
Share on other sites

Glad the original problem is fixed now.  The updates have never been on Simmarket, it's part of the problem of having multiple publishers and ensuring releases occur in an orderly fashion.  Rebuilding the base package and testing it is always a chore, so it ends up easier to push out updates.

When I last looked a long time ago, a lot of WOAI models were FS8/9 format.  It's possible Prepar3D have withdrawn support for that, as even in FSX the older models were a drag on overall simulator performance.  AFAIK P3D is supporting FSX format, and there is a P3D format also that very few have used so far.  Would be a good question to ask on the prepar3d.com forums.

Simon

  • Upvote 1

Share this post


Link to post
Share on other sites
On 5/31/2017 at 8:41 PM, flying-w said:

Glad the original problem is fixed now.  The updates have never been on Simmarket, it's part of the problem of having multiple publishers and ensuring releases occur in an orderly fashion.  Rebuilding the base package and testing it is always a chore, so it ends up easier to push out updates.

When I last looked a long time ago, a lot of WOAI models were FS8/9 format.  It's possible Prepar3D have withdrawn support for that, as even in FSX the older models were a drag on overall simulator performance.  AFAIK P3D is supporting FSX format, and there is a P3D format also that very few have used so far.  Would be a good question to ask on the prepar3d.com forums.

Simon

You're correct. Prepar3d no longer supports FS9 models which is a good thing because they run like crap.

Share this post


Link to post
Share on other sites

Indeed, back in the day I recall Phil Taylor saying some kind of emulation code in FSX was required for FS9 models, which slowed the simulator down.  Least I think it was him, so much becomes lost in the mist of time!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×