flying-w

The journey to Prepar3D V4

103 posts in this topic

44 minutes ago, flying-w said:

Glad you found the problem and thanks for the picture - proves transparency is still working!

Simon

Yes transparency still working at the best !!

I will run more others tryouts and i will report for any eventually faults !!

Thankx for your great work !!

0

Share this post


Link to post
Share on other sites

Any beta testers tried to "Follow AI", "Shadow AI" or "Chase AI" with UTLive aircraft?  I tried with UT2 which is equivalent in terms of the way AI are created in the simulator and it did not work well.  Every time UT2 reacted to the change in the user aircraft by deleting and recreating all traffic which destroys what STB is trying to achieve.  If I look back to FSX, I see I disabled Follow AI etc for UT2 flights.  I plan to do the same for UTLive in STB V4, any objections?

Thanks
Simon

0

Share this post


Link to post
Share on other sites

I'd like to produce the final beta/release candidate early next week.  All beta testers, please send in any final reports or problems before the end of this weekend please.  Many thanks for your participation, STB V4 has already improved incredibly as a result of your efforts.

Thanks

Simon

0

Share this post


Link to post
Share on other sites
3 hours ago, flying-w said:

Any beta testers tried to "Follow AI", "Shadow AI" or "Chase AI" with UTLive aircraft?  I tried with UT2 which is equivalent in terms of the way AI are created in the simulator and it did not work well.  Every time UT2 reacted to the change in the user aircraft by deleting and recreating all traffic which destroys what STB is trying to achieve.  If I look back to FSX, I see I disabled Follow AI etc for UT2 flights.  I plan to do the same for UTLive in STB V4, any objections?

Thanks
Simon

I thought we were waiting for the Shadow/Chase/Follow features to be implemented. I remember this working fine with UT2 in P3Dv3. I don't know the differences between UT2 and UTL and how they affect STB, but I realize that P3Dv4 is quite different and P3Dv4 is what I understood to be the issue that you were working on concerning these features. 

I was waiting on the deployment tab to get the invisible aircraft.

0

Share this post


Link to post
Share on other sites
11 minutes ago, pracines said:

I thought we were waiting for the Shadow/Chase/Follow features to be implemented. I remember this working fine with UT2 in P3Dv3. I don't know the differences between UT2 and UTL and how they affect STB, but I realize that P3Dv4 is quite different and P3Dv4 is what I understood to be the issue that you were working on concerning these features. 

Shadow/Chase/Follow have been there all along. The only thing that's missing is the extended View AI cameras which we could be waiting a long time for (from LM), but you can use these facilities without it. The issue is the way UT2/UTLive works rather than P3DV3 or P3DV4.  All I see is UTx deleting all traffic whenever STB moves the user aircraft in response to Shadow/Follow/Chase, and other testers have reported the same thing.  Please check, and if you have a way to make it work reliably please share how to do that. 

Thanks
Simon

0

Share this post


Link to post
Share on other sites
16 minutes ago, pracines said:

I was waiting on the deployment tab to get the invisible aircraft.

The invisible aircraft has been there all along as well.  It's deployed into the simulator as part of the "Common Sim Content" deployment.

0

Share this post


Link to post
Share on other sites
3 minutes ago, flying-w said:

Shadow/Chase/Follow have been there all along. The only thing that's missing is the extended View AI cameras which we could be waiting a long time for (from LM), but you can use these facilities without it. The issue is the way UT2/UTLive works rather than P3DV3 or P3DV4.  All I see is UTx deleting all traffic whenever STB moves the user aircraft in response to Shadow/Follow/Chase, and other testers have reported the same thing.  Please check, and if you have a way to make it work reliably please share how to do that. 

Thanks
Simon

No I have no way/method of getting Shadow/Chase/Follow to work in V4 - I get the same thing, UTLive traffic deleting in P3Dv4. 

I know UT Live was working with STB fine in P3Dv3. Shadow/Chase/Follow,  Extended AI camera views, and Depart/App/Arrive now, all worked in V3 .

P3Dv4 is when the Shadow/Chase/Follow, Depart/App/Arrive now, and extended views stopped working. Coms, flight data, Delete, and View AI work fine.

0

Share this post


Link to post
Share on other sites

Here's the state of the nation:

Depart now cannot work with UTLive as STB does not know the intended destination of the aircraft (it did work in UT2 as we had schedule info available to us).

Approach now also cannot work, as we only know about arrivals that are active flights and not those planned for later (again it did work in UT2).

Arrive now also cannot work, as we don't know what the following departure schedule is (this probably worked in UT2 also).

Shadow, Chase, Follow, Depart Now, Approach Now, Arrive Now all can't be fixed, I'm sorry to say those are limitations associated with the way UTLive works.  Extended views may get fixed, that will be up to the simulator supplier to consider assuming the problem can be reproduced outside STB and third party traffic.

Simon

0

Share this post


Link to post
Share on other sites

All n All STB remains a great product. 

Maybe someday UT Live will develop into something that can talk to STB better, in the mean time, I'm happy.  

0

Share this post


Link to post
Share on other sites

I am using MT6, STB, and Lorby Live Traffic in V4. Strange situation is P3DV4 when all is active will cause the sim to dead stall still movement but cannot get the sim to change aircraft or to exit the sim. Any help would be appreciated.

0

Share this post


Link to post
Share on other sites
13 hours ago, chrisd6340 said:

I am using MT6, STB, and Lorby Live Traffic in V4. Strange situation is P3DV4 when all is active will cause the sim to dead stall still movement but cannot get the sim to change aircraft or to exit the sim. Any help would be appreciated.

Never seen this problem before, nor heard it reported anywhere else.  It sounds like the Prepar3D is hung.  Please create a repeatable scenario then disable add-ons one by one until the problem goes away.  It may be necessary for you to try to reproduce it without any add-ons, it's difficult to get LM to address simulator issues where add-ons are included.

What does task manager say about CPU consumption of Prepar3D.exe?

Simon

0

Share this post


Link to post
Share on other sites
21 hours ago, chrisd6340 said:

I am using MT6, STB, and Lorby Live Traffic in V4. Strange situation is P3DV4 when all is active will cause the sim to dead stall still movement but cannot get the sim to change aircraft or to exit the sim. Any help would be appreciated.

I would focus on  MyT 6. It contains a number of outdated FS9 aircraft  which are no longer supported in P3d V4. There is a thread over at AVSIM that explains  how to compensate  for this problem.

0

Share this post


Link to post
Share on other sites
Hi Simon,
Finally installed P3Dv4 this weekend along with MyTraffic 6 via .xml add-on file.
FSUIPC5.103, SODE1.5.3, UTP3D, GEP3D, FSDT airports and GSX and nothing else save for ASP4 on a networked client. All working just fine and sim stable so far.
I realize it's late in the process but if you want me to test I am willing.
Clayton
0

Share this post


Link to post
Share on other sites

Hi Clayton

It's never too late!  The release candidate will be coming this week, it would be great if you could take a look at that!

Thanks

Simon

0

Share this post


Link to post
Share on other sites

Super Simon. I will check back for that RC periodically then, or will you email me?

C

0

Share this post


Link to post
Share on other sites
5 hours ago, Psybear2 said:

Super Simon. I will check back for that RC periodically then, or will you email me?

C

I'll email , but check back here if you don't here from me by next weekend!

0

Share this post


Link to post
Share on other sites

I've started testing the release candidate, and as soon as I'm satisfied with it I'll provide it to beta testers for a final look.

Simon

0

Share this post


Link to post
Share on other sites

STB Client V4.0.2017.21200 is now available for testing, which is both Beta 3 and the release candidate.  Download details have been sent to all of the active beta testers, please contact me if yours did not arrive.  All being well, we will look to release next week.

Changes since beta 2:
- Update the MakeRunways Prereq dialogue text following user comments.
- Improved error handling for SimConnect server and makerunways deployment.
- If saving the trace level following a UI change throws a UnauthorizedAccessException, we immediately try again with elevated permissions.
- Added scroll bars to the scrollable dialogue!  Without them, text can overflow the area available making it difficult to navigate.
- Make the scrollable dialogue smaller, to give a better presentation of smaller messages while maintaining capability for large messages.  Add a maximize box.
- Reset UnDeployer application icon to null to avoid confusion with STB Client when uninstalling.
- Improved exception formatter to include exception type.
- Fixed bugs in DeleteStbRootAppDataFolder where the STBDS app data folder was not deleted
- Revised "Settings Deletion Warning dialogue" to be much more descriptive about the settings being deleted.
- Rewrote the VRMF comparison routines to support UInt16 values in each field of a Microsoft Version string.
- Fixed size of Keep or Remove Settings dialogue
- Fixed bug where the STB Client first time configuration wizard lost the deployment settings if the configuration screen was returned to from the status screen.
- Rewrote exception handler for SimConnect assembly load failure:
  - Detected whether C++ 2015 x64 is installed
    - If it is, throw exception as we don't know what just happened.
    - If not, offer to install the redist to correct the problem.
- Updated Settings Notebook to move deployment tab to the last in the sequence of tabs
- Added deployment infrastructure for View AI and Enhanced View AI to the deployment tab.
- Added "Exit" menu item to "User Flight" pulldown
- Fixed bug where the first time configuration wizard lost the deployment settings if the configuration screen was returned to from the status screen. 
- For flights created enroute and externally (e.g. UT2/Live), push the absolute departure 10 hours back from now.  This pushes all airbourne departures back before any flights on the ground for the default time based sort order.  Otherwise newly created enroute departures can be mixed with taxiing flights.
- Add a control that determines whether the  Shadow AI/Follow AI/Chase AI commands are supported for non-BGL flights.
- Add warning messages to the Shadow AI/Follow AI/Chase AI commands when a non-BGL flight is selected and support for such is disabled.

Simon

0

Share this post


Link to post
Share on other sites

Installation went great, will test as vigorously as I can.

P3Dv4 with UTLive at 100% and using generic paints.

Thank you Simon!

Paul

0

Share this post


Link to post
Share on other sites

So far I've not heard of any major problems, so I'd like to close the beta by the end of Sunday.  If you've any final reports to make, please let me have them asap.  Of course you can continue using the beta and reporting problems after today, but they may get address in a later update.

Thanks

Simon

1

Share this post


Link to post
Share on other sites

Working as expected here also. The only interesting thing that has happened is that the sim CTD at DD KEWR, but the Windows error message was attributed to SODE losing its SimConnect connection.  I've seen this before when the SimConnect channel was "flooded" by a 3rd party app, but I doubt that it has anything to do with STB. Just an FYI.

 

0

Share this post


Link to post
Share on other sites

So the beta is now complete, and I am indebted to all the beta testers for their comprehensive efforts to prove STB V4 for Prepar3D-V4. Beta 3 will become the released product so there's nothing new to download, it's V4.0.2017.21200. Now we go on to launch mode with the shops, and that too takes time to make happen.  Thanks once again everyone.

Simon

0

Share this post


Link to post
Share on other sites

The only oddity I observed while spotting was in the NYC area. An airliner turned West to approach KLGA-LaGuardia visually but it kept going East on the map in ASP4, even after landing. Granted the area is as busy and taxing (pun intended) an airspace as possible and probably has nothing to do with STB given the location and other add-ons - ASP4, MyTraffic, FSDT KJFK, DD KLGA- KTEB.  Maybe a SimConnect overload as Jabloomf noted? Other than that, all nominal and good to go.

Late to the party again, 
Clayton

0

Share this post


Link to post
Share on other sites

I did notice a few times that "Arrive now" resulted in the AI aircraft ending up either underground (!) or at a nearby airport.

Also, I sent a debug mode SODE log file to Jeffrey Stahl as he felt that SODE 1.5.3 was having an issue with AI detection in P3d V4.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now