Jump to content
The simFlight Network Forums
Sign in to follow this  
SebastianStorb

P3Dv4 stuttered extremely in the first minutes with FSUIPC 5.121b.

Recommended Posts

Moved to Main forum, as the FAQ subforum is not the place to ask questions. Questions should always be asked in Main Forum, otherwise it might not be seen at all.

Dear Sir and Miss,

P3Dv4 stuttered extremely in the first minutes with FSUIPC 5.121b. It is so extreme that the LM standard aircraft with standard scenery can not be rolled accident free to the runup-area. After 1-2 minutes the simulator is completely liquid. I've noticed that the following error occurs in the log file:


[error.0]
error=Payload station indexes should be between 1 - Number of Stations

[error.1]
error=Payload station indexes should be between 1 - Number of Stations

[.....]

[error.999]
error=Payload station indexes should be between 1 - Number of Stations

I have the guess that FSUIPC is not running completely flawless or P3Dv4 has problems with the addon and therefore the Simmulator shakes until the error number 999 is reached.

In my installation there was only one error message, of which I do not know whether you are important and how I could correct this:

Attempt to set the ACL entries for Modules access permissions failed, error = 1332

If FSUIPC is disabled, the error does not occur, so I suspect a connection. Is a solution known for this problem or will there be an update that fixes the behavior?

Share this post


Link to post
Share on other sites

Hi,

in case there is no other report (yet) it might be related to your setup. I don't and didn't see that before.

6 hours ago, SebastianStorb said:

In my installation there was only one error message, of which I do not know whether you are important and how I could correct this:

Attempt to set the ACL entries for Modules access permissions failed, error = 1332

If FSUIPC is disabled, the error does not occur, so I suspect a connection. Is a solution known for this problem or will there be an update that fixes the behavior?

That means you will have installed P3D in Programs folder with limited access for writing. The Error 1332 is a Windows reported error (not a internal FSUIPC error code) and means:
Error 1332: No mapping between account names and security IDs was done. Cannot find Approved_Groups

Did you install Both with same privilegs? I.e. As administrator, right click on installer.

Maybe you also use Winows 10? Best is to supply a Install.log file and the currect FSUIPC5.log file.

Thomas

Share this post


Link to post
Share on other sites
22 hours ago, SebastianStorb said:

I've noticed that the following error occurs in the log file:


[error.0]
error=Payload station indexes should be between 1 - Number of Stations

[error.1]
error=Payload station indexes should be between 1 - Number of Stations

[.....]

[error.999]
error=Payload station indexes should be between 1 - Number of Stations

I have the guess that FSUIPC is not running completely flawless or P3Dv4 has problems with the addon and therefore the Simmulator shakes until the error number 999 is reached.

No. Those errors are only advisory and shouldn't occur. I am n disagreement with L-M about them -- they are when FSUIPC is requesting information about the payloads to be supplied whenever it changes. It does this for all paystations, all engines, all pumps, etc etc, but L- have decided, only in the case of paystations, that requesting payloads for stations which don't exist at present is an error -- NOT one reported back to the program, as it should be, but only logged in that OPTIONAL log.

It most certainly is not responsible for any stuttering as it is all over is an instant. Just turn the logging off, as it is by default. (BTW how do you know that your "shaking" (not stuttering? Visible shakes up/down/left/right?) is precisiely for the period of that logging?). Maybe it is bad disk access with retries? Obviously logging will write to disk, though Windows should be caching that.

Certainly any view shaking has got to be something else. FSUIPC and WideFS do have a lot of setting up to do before the aircraft is "ready to fly", but after the aircraft is loaded, which is why both of them delay many operations, like connecting to clients, till then. However, there never had been any measurable performance hit, not with any version of FSX or P3D and it really cannot be responsible now.  And FSUIPC doesn't touch graphics.

Pete

 

Share this post


Link to post
Share on other sites

Dear Sirs,

Many sincere thanks for your answers and help! I am trying to explain the comments to help others who have a similar problem:

On Saturday, October 07, 2017 at 7:10 PM, Thomas Richter said:

That means you will have installed P3D in Programs folder with limited access for writing.

This is not correct: I have installed it as an administrator. The installation path is:

c:\P3D\...

On Saturday, October 07, 2017 at 7:10 PM, Thomas Richter said:

Did you install Both with same privilegs

YES a) I've installed P3D as an administrator b) I installed FSUIPC as administrator.

On Saturday, October 07, 2017 at 7:10 PM, Thomas Richter said:

Maybe you also use Winows 10

Yes Build 15063.608

 

I will test your tips. I will get back with logfiles here to you as soon as possible. Many Thanks

Edited by SebastianStorb

Share this post


Link to post
Share on other sites
On Sunday, October 08, 2017 at 10:31 AM, Pete Dowson said:

Just turn the logging off,

That makes no difference, P3Dv4 stutters(?shaking better?) (GERMAN-> ruckelt, i do not know the correct translation). It is not a fluid process, but it comes to a halt and goes on again, maybe a correct translation is not possible.

best regards

Share this post


Link to post
Share on other sites
On Sunday, October 08, 2017 at 10:31 AM, Pete Dowson said:

Certainly any view shaking has got to be something else. FSUIPC

In the meantime, I believe you are right. I have tested a lot and believe it is a scenery problem, because standard was not quite standard. In the background, Orbx is additionally installed and in the aircraft RealityXP. If I completely everything turn off, it no longer persist (with the standard fighter jet at the standard airport of P3Dv4).

Unfortunately, the error message during the installation problem persists. I will try to post a log file later.

Best regards.

Share this post


Link to post
Share on other sites
6 minutes ago, SebastianStorb said:

Unfortunately, the error message during the installation problem persists. I will try to post a log file later.

Do you mean this one?

Attempt to set the ACL entries for Modules access permissions failed, error = 1332

Error 1332 is documented as meaning "No mapping between account names and security IDs was done.", whatever that means.

So my questions would be:

1. Did you run the installer "as administrator" as instructed?
2. Was the end result effective?  i.e are there FSUIPC5.INI and FSUIPC5.LOG files in the Modules folder?
3. What does the Security tab in the modules folder properties show? Is "Everyone" included as a user name, and if so, when selected, are there ticks below against "Full control" and "Modify"?

Pete

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×