Jump to content
The simFlight Network Forums
Pete Dowson

Prepar3D version 4.0: any users not updating to 4.1?

Recommended Posts

As development of FSUIPC5 proceeds I'm starting to use new facilities which are being added to Prepar3D v4, which were not in previous versions.

I really no not want to complicate matters by trying to make my code work on all versions, as I had to do for FSX (RTM, SP1, SP2/ACC, then FSX-SE) and later for P3D 2-3. It becomes messy, inefficient, and much more difficult to maintain and develop further.

So, here's a question. Do any users here want or need to stay on P3D version 4.0 and not move on to 4.1 then 4.2 ... into the future? If so, why?

This question is relevant at present because I've deleloped a version of FSUIPC5 which obtains the assignable P3D4 controls list directly from P3D. However, the functions needed did not exist before 4.1. The list is quite a lot more extensive than the one included statically in previous versions of FSUIPC5.  The list will also automatically stay relevant to future P3D4 releases as they are developed.

There are other additions and enhancements likely in the future too. This is a live product!

As FSUIPC5 develops to match P3D4, I don't want to have to support previous versions. Therefore those who do stick to an earlier P3D4 release would have to also stick to an earlier version of FSUIPC5 -- but I cannot support older versions!

So, feedback on this now, please. Before I take the first step down this path, one i've avoided in the past, but in ways which did really compromise FSUIPC.

Thanks,
Pete

 

 

Share this post


Link to post
Share on other sites

Hello Pete,

 

For me I'm ready to follow the future of P3D. I'm already using the latest P3Dv4.1 with PROSIM.

Of course I've your registered FSUIPC 5 (latest version installed is 5.121c)

Once more many thanks for your great job.

Best Regards from Belgium.

Marc

Share this post


Link to post
Share on other sites

I'm on 4.1. I usually upgrade pretty much straight away when an update is released (as long there is an updated FSUIPC version to go with it! )

Share this post


Link to post
Share on other sites

There is a lag of some weeks before payware developers are ready supporting the new P3D version.

If FSUIPC is updated (goes to new version on day 1 of P3D update) then leave an old unsupported versions of FSUIPC available for old P3D version users to download.

Share this post


Link to post
Share on other sites
30 minutes ago, von said:

There is a lag of some weeks before payware developers are ready supporting the new P3D version.

If FSUIPC is updated (goes to new version on day 1 of P3D update) then leave an old unsupported versions of FSUIPC available for old P3D version users to download.

4.1 has been out a while now (3 weeks) and I'm not ready to release a 4.1-version-only FSUIPC at present in any case. Maybe another 3 weeks yet, as I'm away for 14 days from Friday.

But, yes, I could leave older unsupported versions linked in Download Links subforum.

Pete

 

Share this post


Link to post
Share on other sites
22 minutes ago, Pete Dowson said:

4.1 has been out a while now (3 weeks) and I'm not ready to release a 4.1-version-only FSUIPC at present in any case. Maybe another 3 weeks yet, as I'm away for 14 days from Friday.

But, yes, I could leave older unsupported versions linked in Download Links subforum.

Pete

 

Thanks.

Have a good day.

Share this post


Link to post
Share on other sites

I'll still run P3D Pro v3.4 awhile, but I've upgraded my P3D Pro 4.0 client to 4.1 and plan to stay up to date.  My opinion: onward !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×