Jump to content
The simFlight Network Forums

johnk515

Members
  • Content Count

    35
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by johnk515

  1. I have Carenado DA62 using the G1000. I've tried using ap alt var inc and dec to change the alt, but it doesn't work. I can do the hdg, vs with ap vs var inc and dec. I can inc / dec speed with fsuipc. I've asked on the Carenado da62 forum at avsim, but I don't think Carenado developers look at that site very often. I've had about 30 people look at the message, but no responses.
  2. I'm using a simple LUA file to switch the capt baroset STD select. The button is a stay constant on button. It comes on, but when I push the button again it doesn't change the select button on the panel. Then when I push again it changes. I have to push the button 2x to get the panel to go on then off, then 2x to go back on. I have other aircraft that I use constant on/off switches/buttons that it works. STD Select.lua
  3. Oh, the PMDG I have no problems. I have all the control codes for the 737, 777, 747. Those were the easies to setup. My problem is making a LUA file I.E. auto_brake_switch with a value/range of -1-6, and assigning one of my switches to inc and the other switch do dec. This is for the QW 787 in P3P v4.5
  4. Yes, but it does the same thing. I can live without that. I'm just trying to find away to use the buttons on my stick to turn the autobrake and tcas knob. PMDG has them in their key commands.
  5. That's probably right. PMDG lets you sync the the STD button. Plus they have all their events as control codes which makes it easier for me. And I can live with just clicking on the button. 2 of my biggest problems is the autobrake and the tcas button. I've been trying to set up the 2 so I can use my T1, T2 for rotating the know for the tcas, and my T3, T4 rocker switches for the autobrake. These are on my Saitek X52 stick. Most of my other planes that use the tcas and autobrake have keyboard commands that you can make keyboard letters then assign them to switches with fsuipc. But making a Lua file to make them move right and left is a little bad on the brain. I've looked at all kinds of lua stuff, but it gets confusing.
  6. johnk515

    Ejets P3D v4

    I bought the wilco ejets 175/195 for p3d v4 and been having problems getting it to work. I contacted wilco about it. Then today I got an email from them saying: Dear Sir, The E-Jets serie is not compatible with P3Dv4.X. To let us keep track of this e-mail, please reply without changing the content. Thank You ! Best regards, Christophe Modave Technical Consultant EASA ATPL(A) Yet on the product page it said it was for (P3D v4). After I installed it, it's folders are Feelthere. Is the ejets on the Feelthere site the same as Wilco's? If not, I'll get a refund from Wilco and get the one on Feelthere's .
  7. johnk515

    Ejets P3D v4

    It turned out to be the database. I let Navigraph fms data manager do a search and now it does the correct database. I guess ejets in fsx:se used the mdb and not db3 database files. It's working now.
  8. johnk515

    Ejets P3D v4

    Yes I did and I disable my anti-virus software also till I'm done. I also have my sims excluded from the AV so they don't get messed up. I'll reinstall again. Oh and one more thing is the airac when I install has nd.db3, but when I update with navigraph, its nd.mdb. Shouldn't they match?
  9. johnk515

    Ejets P3D v4

    Well most of the time when I start either the 175 or 195 in cold/dark the VC clickspots don't work and I can't start it up. If I use ready to start, the displays are blank and the overhead clickspots don't work. The 2d popups do, but nothing turns on. Sometimes after going to an airport with the default plane and select the house plane, the VC works and the displays are on and the overhead panel works. Then I switch to one of the addon planes like the 2016 Alaska 175. It might work or work for a little while. It's pretty iffy. I'd like to get it working like it should. This is for p3d v4.4
  10. johnk515

    QW787 Offsets

    The only things I've been able to do is the exterior lights I.E. landing taxi... They use the fsuipc standards. I can also do the autobrakes, and toggle the efb and the fmc to make it easier to use. It would be nice if they did like PMDG has their's.
  11. I've got one control I've been trying to get working. I want to use a 3-way switch to inc/dec the wrx tilt. For the 747 the control number is 70756 from the sdk. I've tried the mouse flag left single and right single, and the mouse wheel up / down parameters. Yet none work. I have other controls that work, and my 737 and 777 all work fine. Any one have this problem?
  12. It turns out that the wxr tilt that I had used was for the standard 744. Then the section that said for the 744f and 747-8 had the left and right wxr tilt, and that one worked. I have three 3-way toggle switch which springs back to center like the switches I have on my Saitek x52. So when I push up the tilt inc. and when I push down it dec. It works very well. And the control number for the left wxr tilt was 71034.
  13. I have wilco's tecnam p2006t. I've been trying how to assign the chokes to buttons. I have L:tecnam_lever_choke1_number, and L:tecnam_lever_choke2_number. I know how to use trim up/down or inc dec with buttons. But the chokes just have a number. I have lua files, but I want to use the T1,T2,T3, and T4 to move the chokes. T1 would be left engine up and T2 would b left engine down. Then T3/4 would be for the right engine. I don't know how to make the numbers go higher or lower with the buttons.
  14. johnk515

    Tecnam p2006t

    Thanks Pete
  15. Turns out I was trying to use the wrong control. Now it works. It's AP VS Var Inc & Dec.
  16. I have the Flysimware C402 Cessna. I'm trying to assign the AP alt pitch wheel to my Saitek x52 stick. On the Flysimware's site they said use (>K:AP_PITCH_REF_INC_UP) and (>K:AP_PITCH_REF_INC_DN) to change the pitch when autopilot's on. In FSUIPC you have the control numbers for the ap pitch ref inc up and down. So I assigned C66584 to R0, 8 and C66583 to RO, 9, but it doesn't work. I still have to use the mouse to adjust the pitch when climbing or descending. The pitch wheel is on the pedestal below the throttles, making it difficult to use the mouse and watching out side. That's why I want to use buttons. I have the latest registered FSUIPC for FSX: SE.
  17. I'll do that. Finding out new things every day.
  18. I'm trying to add mjc's anti collision lights to a 3 way switch. The name is OHD_EXT_LT_ACOL_SW. I tried using -1, 0, 1 to move the switch on the panel to have just the beacon on , off, or anti collision / beacon on. That didn't do. I'm not very good with LUA, how to have the switch go down when flipping my switch down or flipping the switch up add the anti collision, or off when switch is in the middle. Some one said to try a mouse macro, but no luck with that either. Any one have away to put this in a macro or LUA file? This is FSUIPC 4. FSX:SE
  19. Here's the file. MJC_acol.lua
  20. I got it all fixed. I removed a lot of stuff not needed. So, it works fine with only 3 actions, -1 up, 0 off, 1 down. Works great, thanks for the help Pete.
  21. Here's the settings in FSUIPC for mjc D8-400: 25=P2,22,CL13:R,0 -{Lua acol}- 26=P2,21,CL13:R,-1 -{Lua acol}- 27=P2,23,CL13:R,1 -{Lua acol}-
  22. I was trying it in the mjc84.ini file, but that didn't work. Some one on their site suggested using lua to change it. They said "There I use the LVar L:OHD_EXT_LT_ACOL_SW with -1, 0 and +1." My problem is that when I look at lua, it can get confusing. I have a 3 way switch J2:21, 22, 23. Just trying to tell it, if I have the switch in the middle 22 and switch to 21 it flips the switch up or I switch it down to 23, the switch in the plane flips down. I attached a lua file that works some what. I start with the switch in the middle b22. when I flip the switch to b21 the red beacon light comes on, but when I switch back to b22, it doesn't switch back to off. I have to flip up again and it goes off and flip back down to the off position. It does the same thing when flipping down to b23, the anti-collision lights come on, but stay on if I flip the switch back to b22. I have to flip down, then up again. Can some one look and tell me what I'm missing? acol.lua
  23. If you go to https://www.myhomecockpit.de/index.php/en/ From the main menu look at tips & tricks then PMDG event ID's. There he has the 737 and 777 pdf files that have the correct <custom control> number for each offset. I'm just waiting for the 747. He also has the parameters to use. This way you don't have to go through the PMDG_NGX_SDK.h file and fine the (THIRD_PARTY_EVENT_ID_MIN + ) and add it to the control events number, which is 69632. He did that for you at his website.
  24. I got a lua file from Bruce Buckley in the Carenado Phenom 100 so I could the taxi/landing light switch to a button. -- Parameters by Number -------------------------------------------- -- 1 Move Ldg_Taxi Lt SW UP one position -- E50P -- 2 Move Ldg_Taxi Lt SW DN one position -- E50P -- 3 Turn ON NAV & STROBE Lts -- E50P, PA28, C172 -- 4 Turn OFF NAV & STROBE Lts -- E50P, PA28, C172 -- 5 Turn ON Fuel Pump -- PA28, C172 -- 6 Turn OFF Fuel Pump -- PA28, C172 -------------------------------------------- ---- Variables -------------------------------------------- SW_Pos = "L:ASD_SWITCH_LANDING_TAXI_EMB500" -------------------------------------------- ---- Scripts -------------------------------------------- -- Move Ldg_Taxi Lt SW UP one position if ipcPARAM == 1 then SWPos = ipc.readLvar(SW_Pos) if SWPos == 0 then ipc.writeLvar(SW_Pos, 1) ipc.setbitsUW(0x0D0C, 8) end if SW_os == 1 then ipc.writeLvar(SW_Pos, 2) ipc.clearbitsUW(0x0D0C, 8) ipc.setbitsUW(0x0D0C, 4) end end -- Move Ldg_Taxi Lt SW DN one position if ipcPARAM == 2 then SWPos = ipc.readLvar(SW_Pos) if SWPos == 2 then ipc.writeLvar(SW_Pos, 1) ipc.clearbitsUW(0x0D0C, 4) ipc.setbitsUW(0x0D0C, 8) end if SWPos == 1 then ipc.writeLvar(SW_Pos, 0) ipc.clearbitsUW(0x0D0C, 8) end end This is the script that I got. I left out the ones for variable 3-6. But nothing happens when I try it. Here's the lua log that comes up. ********* LUA: "Luacmds" Log [from FSUIPC version 4.971] ********* 314391 System time = 30/08/2017 14:42:02, Simulator time = 14:37:27 (21:37Z) 314391 LUA: beginning "D:\Steam\steamapps\common\FSX\Modules\Luacmds.lua" 314391 *** LUA Error: D:\Steam\steamapps\common\FSX\Modules\Luacmds.lua:1: unexpected symbol near ' ' 314391 >>> Thread forced exit (ipc.exit or os.exit) <<< 314391 System time = 30/08/2017 14:42:02, Simulator time = 14:37:27 (21:37Z) ********* LUA execution terminated: Log Closed ********* ********* LUA: "Luacmds" Log [from FSUIPC version 4.971] ********* 315188 System time = 30/08/2017 14:42:03, Simulator time = 14:37:28 (21:37Z) 315188 LUA: beginning "D:\Steam\steamapps\common\FSX\Modules\Luacmds.lua" 315203 *** LUA Error: D:\Steam\steamapps\common\FSX\Modules\Luacmds.lua:1: unexpected symbol near ' ' 315203 >>> Thread forced exit (ipc.exit or os.exit) <<< 315203 System time = 30/08/2017 14:42:03, Simulator time = 14:37:28 (21:37Z) ********* LUA execution terminated: Log Closed ********* ********* LUA: "Luacmds" Log [from FSUIPC version 4.971] ********* 347766 System time = 30/08/2017 14:42:36, Simulator time = 14:37:42 (21:37Z) 347766 LUA: beginning "D:\Steam\steamapps\common\FSX\Modules\Luacmds.lua" 347766 *** LUA Error: D:\Steam\steamapps\common\FSX\Modules\Luacmds.lua:1: unexpected symbol near ' ' 347766 >>> Thread forced exit (ipc.exit or os.exit) <<< 347766 System time = 30/08/2017 14:42:36, Simulator time = 14:37:42 (21:37Z) ********* LUA execution terminated: Log Closed ********* ********* LUA: "Luacmds" Log [from FSUIPC version 4.971] ********* 349000 System time = 30/08/2017 14:42:37, Simulator time = 14:37:43 (21:37Z) 349000 LUA: beginning "D:\Steam\steamapps\common\FSX\Modules\Luacmds.lua" 349000 *** LUA Error: D:\Steam\steamapps\common\FSX\Modules\Luacmds.lua:1: unexpected symbol near ' ' 349000 >>> Thread forced exit (ipc.exit or os.exit) <<< 349000 System time = 30/08/2017 14:42:37, Simulator time = 14:37:43 (21:37Z) ********* LUA execution terminated: Log Closed ********* Bruce says it works for him and many others. I'm using steam, but I have other lua files that work just fine. Any ideas what the problem is?
  25. Well, it works now. Thanks Bruce.
×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.