Jump to content
The simFlight Network Forums

flying-w

Members
  • Content Count

    2,812
  • Joined

  • Last visited

  • Days Won

    40

Everything posted by flying-w

  1. Yes, I think the problem in your case is you don't have 7zip installed. If Windows does not recognise the file extension, I'll need to recreate it as a .zip file. I'll do that sometime this week. Simon
  2. Can't really talk about new features which may or may not come to light. The only one I'm prepared to hint at is doing something with AI boats. Whatever that turns out to be, if anything, will be a straightforward and simple implementation as SimConnect does not have much to say about them. Otherwise keeping up to date with the platform is most definitely important. No dobut when Prepar3D V5 comes along, there will be some new .net requirement at least. Simon
  3. flying-w

    Cannot contact Flying W

    Hi Concerning outlook, that will be the way Windows is set up for you. All STB does is say to Windows "I want to send email", it's up to Windows how it goes about that. On the website, if you hover the mouse over the link you'll see my mail address. It's the bit after "mailto:". When you contact me via email, please explain what you require and a copy of your order for STB for FSX if you are looking for upgrade pricing. Thanks Simon
  4. From an STB perspective there's little difference between Prepar3D V4.3 and V4.4. What I'd expect is the both the official updates and betas will probably all work just fine with Prepar3D V4.3 as indeed they do with Prepar3D V4.4. In others words "STB for Prepar3D V4" should work with both P3D V4.3 and V4.4 That said, if we do come across problems I'd need them to be reproduced in Prepar3D V4.4 so I can be sure I'm not chasing ghosts. If you are having problems with a link, you'll need to tell me which one. Thanks Simon
  5. flying-w

    Duplication of flights

    Bob, The trace file does not match the screenshot. No AI flights whatsoever in the trace, in fact I never see you try to connect to the simulator nor compile the database as per the instructions above, so this must be from some other session. If you do this again I will have a look, but please stretch out the FS ID column so the values are not truncated. Simon
  6. Updated following the decision to retire STB for (all editions of) Flight Simulator X from active development. It's been an incredible journey over the last 11 years, but the time has come to focus my efforts on the "current" Prepar3D platform. Please see the above for details on what this means to you, which given the maturity of the product I would say is little if any. Thanks Simon
  7. flying-w

    Duplication of flights

    One thing I'd like to introduce is the ability to display which BGL we beleive a particular flight has come from, although that's a singificant piece of work to get done. In the meantime, please do the following 1) Change your display so you are showing the "Object ID" column in the flights list 2) Set up a verbose trace as per Appendix C of the user guide 3) Compile the airports database 4) Reproduce the problem where the flights are duplicated or otherwise incorrectly listed 5) Take a screenshot that includes the ObjectID column, describe the problem you are seeing. 6) Close STB, send me the above and the trace file please. Thanks Simon
  8. flying-w

    Duplication of flights

    Not seeing any systematic problems here with either Prepar3D V4.4 nor the STB 344 beta. Here's my test results with ORBX AU Traffic: No Duplicates, and as AI show up in the simulator they are correctly reconciled with those flights already listed. Here's the picture a little later: The ANA arrival and those after it are now being operated by AI aircraft in the simulator, and are correctly applied to their preexisting slots in the list. When you "compile airport database", you start with a clean sheet every time and build upwards using your scenery library and P3D addon configurations. Your problem is almost like you have the BGLs duplicated or appearing multiple times in the library/Prepar3D addons infrastructure. Simon
  9. flying-w

    Pre-buy few questions

    Yes, works fine with Prrepar3D V4.3 There are some issues to be aware of with UT Live, as not all information we require is available to us. Please see: http://supertrafficboard.com/ExternalSchedulingEngineSupport.html When two AI aircraft are in conflict, one is deleted to give the other a better chance of success. So you might call it "brute remove", although I use a call within Prepar3D to perform the deletion. AI will disappear from this point of view, but where possible we recreate them with the next schedule (.e.g arrivals that are deleted are recreated as departures). In Prepar3D there is only windowed mode. "Full screen" is not the same as it was in FSX, it is just a big window without borders. I don't control that part, you'll need to discuss that with whereever you want to buy it from. Many thanks for the questions. Simon
  10. flying-w

    No arrival for user aircraft

    Thanks for the test results. Sorry to say there's nothing I can do to fix this one. The complexity of PMDG aircraft is well understood and one of it's strengths, but perhaps the complex system implementation somehow stops the flight numbers working. Simon
  11. flying-w

    No arrival for user aircraft

    Here's what's in the trace concerning your flight number: 26-Dec-18 21:42:00.101: > FsUserDescriptionUpdate(): Received Type: BOEING, Model:B738, Title:Boeing 737-800NGX LH fictional (D-ABZA), atcId:D-ABZA, atcAirline:LUFTHANSA, flightNumber:0 DepAirport:LROP, ArrAirport:LWOH, Cruise:514, GearsWork:1, FlapsWorks:1 So it would appear when STB asks for it, the simulator says it is zero. I will have to think about this one, but I really don't know what to suggest when the simulator does not provide the correct information. In the mean time, please take a flight in one of the standard Prepar3D aircraft in the same way you would with PMDG, and see if you get the flight number then. For example: "Lockheed Martin C-130J-30 - USAF" Simon
  12. flying-w

    STB with P3D v4.4

    🙂 Works fine for me without any modifications, and I've not received any error reports from customers. Simon
  13. flying-w

    No arrival for user aircraft

    Thanks for the aircraft.cfg. The important thing is this: atc_flight_number=738 And it can also be set through the Prepar3D UI when configuring your flight. Either way, it's working for me so far: Let's try to find where it goes wrong for you. Please set up a verbose trace as per Appendix C of the user guide, restart STB, reproduce the problem and send me the trace file. Many thanks Simon
  14. flying-w

    No User aircraft data at start up

    Thanks for the traces. I can see we are receiving information from the simulator about the user aircraft, but the values received don't match any of the departure states we have on the board. For example: 16/12/2018 10:00:46 AM.436: EvaluateState: Converting departureAirportClosest:True, fsState:(OnGround:1, pushingBack:0, exitIsOpen:0, landingLightsOn:0, parkingBrakeOn:1, engine1Running:0, engine2Running:0, engine3Running:0, engine4Running:0, avionicsCircuitOn:1, flapsDown:0, gearDown:1, fastenBelts:0) to User State (fsState: unknown, sequence: 0). You can see in the above the various elements of aircraft state we are intereted in. Compare this to the spreadsheet in the STB install folder that shows you how the above is translated (data\UserAircraftStates.xls, and you will see there is no match based on the aircraft state elements received. What state do you think you should be in here on STB? To make it work, you need to have aircraft elements state that match a row in the spreadsheet. As far as I can see, you state should be "pre-taxi" but it isn't because "Fasten Seat Belts" is off. Not all third party aircraft play nice with FS internals, and it's not suprising to find the seat belt switch in a third party does not update the simulator internals. Thanks Simon
  15. flying-w

    I got an issue among many :)

    How does each application know which simconnect settings group it should use? There's nothing to distinguish them, so I think STB will try to use port 500 because it's the first in the file. In your simconnect.xml, you do not open port 500 so it stands no chance. If you have two seperate simulator computers that you are trying to address from a single client, that's beyond the support available in STB which is designed to deal with the 99.9% of simpler scenarios. In your case you'd need to change the simconnect.cfg file each time according to the simulator PC you wish to use. The SimConnect.cfg file The SimConnect.cfg file contains communications information for a client (the SimConnect.xml file contains information for a server). This file is only required if a client is going to access Prepar3D running on a remote machine, and should be placed in the Documents folder, or in the same folder as the client application or library, on the computer the client is running on. Note: SimConnect.msi is no longer needed due to the fact that the WinSxS library has been depreciated. The SimConnect.cfg file can contain a number of configurations, identified in sections with the [SimConnect.N] title. The index number is used as a parameter in the SimConnect_Open function. This is useful for applications that communicate with a number of different machines that are running Prepar3D. The default configuration index is zero, and if there is only one configuration in the file, no index number is required.
  16. flying-w

    I got an issue among many :)

    Bob, you have two entries sharing the same name in simconnect.cfg, that probably won't work. Why two? Simon
  17. flying-w

    No User aircraft data at start up

    Very interesting setup, sorry to say that running two clients at the same time isn't a supported configuration. But don't panic, that's not to say it won't work and I won't try to help, but please try to reproduce this problem by shutting down one of the clients and just using the other. If it does still occur on a single client, please do the following: 1) Set up a "Verbose" trace as per Appendix C of the user guide. 2) Reproduce the problem, describing the steps you took (and the airports involved) as you did above. Please send screenshots of the dialogues once you have entered values but before you press the "OK" button. 3) Close STB, send me the trace file. Thanks Simon
  18. flying-w

    No arrival for user aircraft

    Thanks - I must have fixed this issue at some point then forgot about it! I'll take a look at the flight number. Can you send me the aircraft.cfg (or sim.cfg) from the user aircraft you are using please? Thanks Simon
  19. Coming soon, just need to test STB to STB-DS connection. In the meantime, here's the new stuff: Summary of Changes in V4.2.2018.34000 Update Make Runways utilities to V4.8.6.4. Deploy all files associated with Make Runways, not just the .exe file. Added Lorbi-SI redistributables to the Make Runways package included with STB. Added dialog describing the Make Runways related redistributables with links to author webpages and readmes. Removed MakeRunways prerequisite info dialogue. A separate Lorbi-SI install to support Make Runways is no longer mandatory. Tolerate the presence of P3D "AddOn" related entries in the scenery library configuration file. Added a new Content Error Reporting system to capture STB errors relating to simulator content (Scenery Library, SimObjects, Schedules, Airports and Logos). Added debug to catch and better explain any exceptions occurring during instantiation of the P3DFileHelper class that are directed to the Windows Event Log Added atc_type and atc_model values to Flying-W Invisible Aircraft to avoid Simulator and STB Content Errors. Fix for STB operated flights never begining their departure cycle. Fix for incorrect "Next Flight Departure Time" vthat occurred in the flight details dialogue under certain circumstances. Simon
  20. flying-w

    STB V4 for Prepar3D Next Beta

    lol, "the road to nowhere" or "the road to hell", take your pick 😉
  21. flying-w

    No arrival for user aircraft

    While investigating your problem I noticed the user aircraft was being counted twice in the airport summary, so it would count +2 departures or +2 arrivals for the airports concerned. That's fixed in the above beta, so it's already been a fruitful journey. Simon
  22. flying-w

    STB V4 for Prepar3D Next Beta

    Thanks - it's a long road I'm travelling but the journey has begun. Simon
  23. flying-w

    No arrival for user aircraft

    Thanks, however I can't reproduce this one. Would you be interested in installing the latest beta update and checking whether your problem exists there? If it does, that's a better place to debug it from and any fixes would require this level of code in any case? If the problem does exist, please set up a "Verbose" trace as per Appendix C of the user guide, reproduce the problem and send me the trace file please. Update is here: Many thanks Simon
  24. flying-w

    No arrival for user aircraft

    Can you send me the .pln file please? When I try to load this plan by copying it to a file, Prepar3D tells me:
×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.