Jump to content
The simFlight Network Forums

rightstuffer

new Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About rightstuffer

  • Rank
    Newbie

Profile Information

  • Gender
    Male
  • Location
    Texas
  1. I am try to install the Aerosoft's GA28R simulator on a new Windows 7 computer with FSX installed with all service packs. Aersoft has informed me that they no longer support this device. Have several problems: Where can I download GA28R.dll 1.00? When I lauch the GA28R software, it is only looking for FS2002 or 2004, and there is no option to point the software to FSX. Does anyone know of a work around for this? Thank you
×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.