Jump to content
The simFlight Network Forums

Search the Community

Showing results for tags 'P3D'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Product Support Forums
    • FSUIPC Support Pete Dowson Modules
    • MyTraffic Support Forum
    • FeelThere Support Forums
    • FS Commander Support Forum
    • Flying W Simulation
    • AConstable Traffic Sounds Support Forum
    • Fabio Merlo Products Support Forum
    • Elite-Air Studio Support Forum
    • Nikola Jovanovic Support Forum
    • Intrasystems Support Forum
    • FScene Support Forum
    • Taburet & DanVFR Support Forum
    • Environ Scenery
  • simFlight DE
  • FS MAGAZIN (DE)
  • simRussia
  • FSUIPC Client DLL for .NET

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 54 results

  1. Hello guys, Im trying to learn more how to take more advantage of fsuipc and founded the "Controlling A Brand New Decade of Flight Simulation Hardware" tutorial, I just want to know if this is still applicable for p3dv4.5 or if any other detailed tutorials are available, thanks! here some break time at work so im reading! thanks.
  2. *** Moved from FAQ Support Forum *** Dear fellow simmers, it is a long time since I last modified my flight simulator setup, about 10 years and more! I had built my own console with switches and LEDs, to interface with FSX. It was working until now with FSX and Windows 7. I had programmed it myself using FSUIPC (4 I think) and Visual Basic. Now, just 2 weeks ago I installed Windows 10 and also P3D V4.5. When trying my old program (called RealSwitches) some switches still brought the correct reactions in P3D as they did before in FSX. For example gear up and down still worked. However many things are not working. So I decided to go ahead and write a new program for my old switch console. Reading the FSUIPC documentation I discovered Lua and did some experimenting with it. It generally works, and I tried some of the examples. But what I cannot get working is even the simplest routine using the Lua event library. No event fires. I tried for example timer events and key events. I thought maybe someone here knows or knows where to look. Here is my Lua code, which should just react on pressing the "V" key. From looking at the log file for the lua script I can see that the event function KeyReceived() is never called. The same was the case when I tried with timer events. ipc.display("eins") gCount = 10 ----------------------------------------------------- function KeyReceived() ipc.log("gotcha") gCount = gCount-1 end ------------------------- init ------------------------ event.key(TIC_MS, 86, 0, "KeyReceived") -- Key v (normally make screenshot) event.cancel("KeyReceived") ipc.sleep(50) event.key(TIC_MS, 86, 0, "KeyReceived") -- Key v (normally make screenshot) ---------------------------- loop, event handlers doing their job while gCount>0 do ipc.sleep(50) end ---------------------------- close sOutput = "Fertig" ipc.display(sOutput) ipc.exit() Any help would be most appreciated. Thank you Detlef
  3. Hi, I'm new to this forum but have been building a set of switches and buttons with arduino by using the com ports and joystick functionality of FSUIPC. At first I used FSX and the aerosoft A320 bundle and everything was great (Also using FSUIPC v4), buy then i changed to P3D, Aerosoft's professional A320 and FSUIPC v5 and problems started. In the beginning I thought it was random. My plane would turn off at any point of the flight, sometimes twice if I was in the ground on the first shutdown. But then I've managed to find out that I can replicate the error when I plug a new device to the computer. The FSUIPC log will say "HID USB device reconnected: re-initialising FSUIPC connections" and in that point it wont read the actual state of my joystick switches. (For example, if the engine switches on the joystick are ON, FSUIPC will read all switches as off after the "sudden" reconnection, until I move any of the switches, and now it would read all the actual states of the switches, but at this point the plane is already off with several switches moved to zero positions) The thing is, to summarize, sometimes my PC (and i've tried on different PCs, reinstall windows and p3d and everything) reconnects all USB devices randomly on FSUIPC (not on actual windows since I dont listen to the connection sound) Maybe the device that reconnects are the bluetooth ones, but it doesn't matter, what I need to get working is to stop this "reconnection" of FSUIPC every time a new device is recognized by my computer.
  4. Hi folks, Currently use a sidewinder for all airbus on P3D v4.5 and it works good. I would like to seek advice on making the sensitivities smoother as its quite erratic and not as smooth as the other sim I use.... Tried slope curves but this seems to help a little. Any recommendations. Thanks Steve.
  5. Hello Pete, My apologies to bother you with a problem. I am a registered user of FSUIPC and I have a new problem since I installed the update 4.5 of P3D. The problem is that the throttle and the propeller pitch of the Saitek Quadrant moves together with the Ailerons, also when trying to re-calibrate it withing FSUIPC. I have been trying for days to solve this without finding the solution. Latest FSUIPC update has been installed. Windows 10 P3D 4.5 FSUIPC 5.151 All registered. Could you please help? Many thanks. Kr, Enrico
  6. Hi! I am having a strange issue with FSUIPC and P3D v4.3. I have browsed for solution, but haven't found anyone with the same issue. When I have FSUIPC installed, non registered version, the controls of the aircraft get stuck, I can't move them. I have tried with different aircraft, for example, on the FSLabs A320 I lost all controls. On the PMDG NGX I lost all controls, and also the trim wheel on the pedestral moves, but the trim value doesn't. On the PMDG 777 I can use the yoke, but can't move the thrust levers. If I remove FSUIPC, everything gets normal, however, I need it for the ACARS of my VA. This issue is happening after buying a new computer. Kind regards, Joao Nunes.
  7. Pete; I ran into an issue with the FSL A320 and FSUIPC steering tiller control. The steering control in the FSL panel sets the nosewheel steering angle as an exponential function of the tiller input, which makes fine control of the nosewheel at steering angles above ~10 deg nearly impossible using the short-throw (~15 deg) twist-grip axis on my T.16000M stick. I tried using the slope function by assigning the rudder and steering tiller axes as direct to calibration and then setting a negative slope (-4) in the tiller axis calibration to counteract the excessive nonlinearity, but the rub is that apparently the combined tiller/rudder input is being made to the rudder axis and not to the steering axis in P3D. I was able to make it work programmatically in my flight control driver by reading the post-calibration tiller value at offset 0C08 and then rewriting that direct to the FS steering set control (66818 via write to offset 3110). But...it would probably be helpful for others that don't have custom-programmed flight control drivers to be able to send a calibrated steering input to the steering axis rather than the rudder axis. The FSL Scarebus does its own mixing of the tiller and rudder inputs, and expects the tiller input to come in via the P3D steering control. Perhaps a special case where MaxSteerSpeed=0 could be used to force no mixing, but still allow a calibrated value to be sent via the direct-to-calibration path to the native steering axis rather than mixed and sent as a rudder input? Cheers Bob Scott
  8. Hallo und guten Tag zusammen, ich habe festgestellt dass wenn ich einen Flugplan erstelle und diesen dann mittels Save as abspeichern möchte, ich eine Fehlermeldung bekomme die mir sagt dass der angegebene Pfad für den Simulator nicht richtig ist und ich diesen bitte anpassen möchte. Der Pfad ist allerdings richtig angegeben so dass ich leider nicht mehr weiter weiß. Des weiteren ist mir aufgefallen dass wenn ich den Database Manager nutze die Pfade auch nicht mehr stimmen und ich sie aber auch nicht anpassen kann da das Fenster ausgegraut ist. Ich nutze Windows 10 Professional mit Build 1803 vielen Dank im Voraus mfG Andreas
  9. Moved to Main Forum. Please ask questions related to FSUIPC always in Main Forum as it might not be seen in a Sub-Forum. Hi Pete, Just upgraded to FSUIPC 5.13 for P3D V4 and noticed you have now included the mouse macro functionality. So thankful! I wanted to get it running with my iFly 737 add-on, though not sure what I am doing wrong. The mouse macro feature seems to work with single inputs, though it seems to disappear if I program a macro with more than one input (ie moving a overhead switch twice). Any ideas? Thanks Troy
  10. Moved to Main Forum. Please ask questions related to FSUIPC always in Main Forum! Is there a way to get the ground elevation for a given latitude/longitude position. I need to get the current ground elevation (representing the scenery) at a given position, which is NOT my own aircraft's position and NOT the position of another AI aircraft. I know how to do it with FSX and P3d/simConnect, but need a similar function for FS9. Any hint how I can do it (if possible)?
  11. Here is a Lua file that progressively apply and/or disengage brakes, adjustable in both directions, for those who only have a button for brakes. [INSTALLATION] FS closed Copy the complete code block below, paste it into an empty .txt file & rename it Smooth_Brake.Lua Place the above file in the FS/Modules folder Add the following to the [Auto] section of the FSUIPC(4).ini file - X=Lua Smooth_Brake - Where X is the next available number in the [Auto] section. (pg. 42 - FSUIPC4 for Advanced Users.pdf) Comment out ( ; ) or remove the original brake button listing in the [buttons] section. Start FS Make sure the button is not programmed through the FS assignments dialog. For a simple, non-complex assignment to the joystick button see the picture below. For a complex assignment see pg. 22 - FSUIPC4 for Advanced Users.pdf - Using something similar to this for a button press - xx=CP(-0,11)0,0,CL6:S,211 and this for release - xx=CU(-0,11)0,0,CL6:C,211. Where 6 is the numbered lua under the [LuaFiles] section of FSUIPC(4).ini in my case as an example. Use the FSUIPC facility, "Reload Buttons", from the user interface in the Buttons tab to confirm assignment. Adjust user settings to ones own liking. Assign a keyboard key to reload the file using Lua Smooth Brake as the control sent to use for reloading tuning modifications. One can use the Logging facilities in FSUIPC, using the right hand side of the dialog (FSX + only), using 0BC4, 0BC6 & 0BC8 with a type of U16, display to FS Window, to help in adjusting user settings. The above settings result in this - 1=P0,0,CL6:S,211 2=U0,0,CL6:C,211 [USAGE] Basically all this does is gradually increase (depending on settings) the brake strength as the assigned brake button is pushed. It also works in reverse, on brake disengagement. One could, for instance press the brake button for only 1 second and after that toggle the brakes on & off at a repetitive rate to keep, lets say, ~ 50% brake strength. It's much better than full on or full off. The settings as given below give around a 2.75 second span between brakes off to full brake strength. Smooth_Brake.Lua - --------------------- USER SETTINGS rate_on = 300 -- RATE AT WHICH BRAKES ARE APPLIED minimum = 3500 -- MINIMUM BRAKES ON FIRST APPLY = REQUIRED PERCENT * 16384 rate_off = 300 -- RATE AT WHICH BRAKES ARE RELEASED dis_pbrake = 1 -- DISENGAGE PARKING BRAKE ON BRAKE APPLICATION? REQUIRES A REAPPLY FOR BRAKE ACTIVATION! diff_brake_override = 0 -- !!!! GIVES AN ALTERNATE DIFFERENTIAL BRAKE AXIS PRIORITY OVER BRAKES -- EXAMPLE - THE "T_FLIGHT HOTAS" ALTERNATE AXIS ON THROTTLE SECTION -- SEE PG.1 "FSUIPC LUA LIBRARY" - "n = ipc.axis(joynum, "axis")" FOR MORE INFORMATION. --------------------- END USER SETTINGS function stop() brake = ipc.readUW(0x0BC4) -- Get Parking Brakes If Button Pressed And Parking Brake Disengage Is Active if ipc.testflag(211) == true and dis_pbrake == 1 then p_brake = ipc.readUW(0x0BC8) -- Disengage Parking Brakes If Set if p_brake == 32767 then ipc.control(65752, 0) end end -- Brakes On while brake < 16383 and ipc.testflag(211) == true do -- Differential Braking Override if diff_brake_override == 1 then -- REQUIRES CUSTOM ATTRIBUTES FOR SPECIFIC HARDWARE special = ipc.axis(0,"S") if special > 1000 or special < -1000 then brake = 0 break end end brake = math.min(16384, brake + rate_on) brake = math.max(minimum, brake) brake_shift = logic.Shl(brake, 16) + brake ipc.writeUD(0x0BC4, brake_shift) end -- Brakes Off while brake > 0 and ipc.testflag(211) == false do -- Differential Braking Override if diff_brake_override == 1 then -- REQUIRES CUSTOM ATTRIBUTES FOR SPECIFIC HARDWARE special = ipc.axis(0,"S") if special > 1000 or special < -1000 then brake = 0 break end end brake = brake - rate_off brake = math.max(0, brake) brake_shift = logic.Shl(brake, 16) + brake ipc.writeUD(0x0BC4, brake_shift) end end event.flag(211, "stop")
  12. Thanks again Pete for your great work with FSUIPC5. Looking forward to the purchase. One interesting aspect of P3D for me has been the way that it handles add-ons; Umberto from FSDT was talking about it on AVSIM earlier this week and his scenery utilities when migrating content to P3Dv4 use it. Essentially, each add-on defines its contents in a separate XML file allowing it to be easily enabled/disabled, etc. After installing FSUIPC5 into my P3Dv4 setup, I took the liberty of disabling FSUIPC5 in the global DLL.XML file and instead did the following: Created an FSUIPC directory in the $MyDocuments\Prepar3D v4 Addons directory. Created an add-on.xml file with the following content: <SimBase.Document Type="AddOnXml" version="4,0" id="add-on"> <AddOn.Name>FSUIPC5</AddOn.Name> <AddOn.Description>FSUIPC v5</AddOn.Description> <AddOn.Component> <Category>DLL</Category> <Path>D:\Program Files\Prepar3D v4\Modules\FSUIPC5.dll</Path> <DLLType>PDK</DLLType> </AddOn.Component> </SimBase.Document> Loads just fine; the directory of course will differ based on the install. I like the new install mechanism for modules and scenery; it allows better control over what to enable/disable. Something to consider for the installers going forward? It might make your life simpler as there's no risk of stepping on the toes of another add-on. Cheers! Luke
  13. I have configured registered version of latest FSUIPC together with latest of FSLabs A320 in latest P3Dv4 but cannot extend or retract both the landing gears and the flaps. Any solution for this?
  14. Hello, I got P3D v4 today and went to get FSUIPC so I could fly on VATSIM. Then I went to install it which installed successfully, however, when I went to start up the game, it would "crash" after the splash screen dissapears. However, on task manger, P3D is a background process, rather than appearing as an active app. I have reinstalled FSUIPC and restarted my PC many times and still no luck. I don't have any scenery addons installed and the only addon I have installed in the PMDG 737. Here are the install logs if that helps:
  15. Title says most of it: With 5.122 installed, P3d will attempt to start, but then will not show up (even though it is up and running when you look in the task manager). When I uninstall FSUIPC, the problem instantly goes away. I know Pete wrote a great program, so there's something unique to my setup, I'm sure, that's caused this. What I'd like to know is how to troubleshoot this so that I can use FSUIPC eventually. Does anyone have any ideas for how I can begin? Thanks. :-)
  16. Hi, I need to remotely connect to P3D via SimConnect. I have 2 PCs. Server: PC1 with P3D v4 installed, IPv4:192.168.10.139 Client: PC2 has a C# WPF app that does some reading & writing to P3D on PC1 via SimConnect. IPv4:192.168.10.167 I have put SimConnect.cfg file on PC2, Documents folder, put SimConnect.xml, EXE.xml and DLL.xml files on PC1, C:\Program Files\Lockheed Martin\Prepar3D v4 folder, put SimConnect.ini file on PC1, C:\Users\Administrator\Documents\Prepar3D v4 Files folder. I save all these 5 files as Unicode type for encoding. In SimConnect.cfg: In SimConnect.xml: In SimConnect.ini: As for EXE.xml and DLL.xml files, I didn't do any changes as I found no instructions about them. In the WPF app code on PC2: private const int WM_USER_SIMCONNECT = 0x0402; //user-defined this.SimConnect = new SimConnect("Managed Data Request", Handle, WM_USER_SIMCONNECT, null, 0); // it can be executed with no error or exception as long as the SimConnect.cfg file is OK. private IntPtr HandleSimConnectEvents(IntPtr hWnd, int message, IntPtr wParam, IntPtr lParam, ref bool isHandled) { isHandled = false; switch (message) { case WM_USER_SIMCONNECT:// This is never met! But if P3D and the WPF app run on the same PC then it works. { if (SimConnect != null) { try { this.SimConnect.ReceiveMessage(); } catch { RecoverFromError(); } isHandled = true; } } break; default: break; } return IntPtr.Zero; } The remote connection between P3D and the WPF app is not successful. I appreciate any help.
  17. So, PLEASE HELP. I've searched all over to see if anyone is having the same problem as me and can not find it anywhere. I have P3Dv4 installed and working perfectly fine. Once i install FSUIPC V5.122(registered), i try to run P3D and the little loading screen pops up, loads for about 10 seconds, then disappears. I check the task manager and P3D is still running in the background and the only way to close it is throug task manager. Once i delete the Modules file with FSUIPC in it, P3D loads right up again with no problem at all. Add ons, Fly Tampa Sceneries, PMDG 737, 777, 747, GSX, Active Sky Weather, Chase plane and 737 immersion(which does not work due to FSUIPC not working). Not sure if this means anything but the .ini file is always empty when i open it. Here is my log file. ********* FSUIPC5, Version 5.122 (17th November 2017) by Pete Dowson ********* Running inside Prepar3D v4 Module base=7FFF44BC0000 Windows 10 Pro 64 Bit reported as Build 16299, Release ID: 1709 (OS 10.0) Prepar3D.exe version = 4.0.28.21686 Checking the Registrations now ... User Name="***********" User Addr="*************" FSUIPC5 Key is provided WIDEFS7 not user registered, or expired 0 System time = 22/11/2017 00:36:12 0 FLT path = "C:\Users\***\Documents\Prepar3D v4 Files\" 0 ------ Module Version Check ------ 0 acontain.dll: 4.0.28.21686 0 api.dll: 4.0.28.21686 0 controls.dll: 4.0.28.21686 0 fs-traffic.dll: 4.0.28.21686 0 G3D.dll: 4.0.28.21686 0 language.dll: 4.0.28.21686 0 sim1.dll: 4.0.28.21686 0 visualfx.dll: 4.0.28.21686 0 weather.dll: 4.0.28.21686 0 window.dll: 4.0.28.21686 0 ----------------------------------
  18. Hello Peter, I'm using MobiFlight, a freeware software which lets Arduino boards communicate with P3D via FSUIPC or Simconnect. I'm using it with PMDG airplanes along with their custom offset & event list without any problem. Yet i need to find the default planes' output offsets like B58, B350 etc, but in the huge Offset list you provide with FSUIPC, i can't find any annunciator offsets like "LOW RPM", "OVERSPEED", "LOW PRESS" etc, you name it. Isn't there any kind of offsets for them as well ? Another question is, i need some basic info about the abbrevations used in FSUIPC like FLOAT,U32,U16 etc. There's a project which you probably know about called XPUIPC, and there are a lots of arrays, floats, int's in it's tutorial, and i don't know how they work and what are the differences :) Is there any source in which i can find some even brief explanation about all of these ? Thanks in advance
  19. After I updated to the latest FSUIPC version (v4.969), I cannot open any door but the main. The pushback (CTRL + P + 1 or 2) doesn't work also. If I remove the FSUIPC module, everything goes back to normal. Does anyone know how to fix this?
  20. PLEASE ALWAYS POST SUPPORT QUESTIONS IN THE SUPPORT FORUM! So, I've had the Saitek X-56 Rhino for a while, and it's worked without problems, until about a week ago. Neither the stick or trottle quadrant is working in P3D at the moment, but the wierd thing is it's working in the Saitek program. I've tried most of the usual stuff like changing USB port, I've also done a troubleshooting in Windows, with no results. I am using FSUIPC 4 and I have disabled my controllers in P3D. I've been told you can change the JoyNames in the fsuipc.ini file, but to what, and what numbers to change? Very wierd problem, seems like it should be an easy fix. Thanks in advance /Fred
  21. Hi guys, I want to ask you about my problem. I have problem that i can't install FSUIPC for my p3d v3. the problem is the FSUIPC installer cannot checking the correct version of "p3d v3.exe". it's said that "Couldn't obtain Version Info! Asking user to find Prepar3D v3.EXE ..." and this is my FSUIPC installer log Installer for FSUIPC4.DLL version 4.949h Looking in registry for FSX install path: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0 Parameter"SetupPath" Not there, so looking in: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0 Parameter"AppPath" ... NOT found! ... Looking in registry for FSX-SE install path: HKEY_LOCAL_MACHINE\SOFTWARE\DovetailGames\FSX Parameter"Install_Path" Not there, so looking in: HKEY_CURRENT_USER\SOFTWARE\DovetailGames\FSX Parameter"AppPath" Not there, so looking in: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator - Steam Edition\10.0 Parameter"SetupPath" Not there, so looking in: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator - Steam Edition\10.0 Parameter"AppPath" ... NOT found! ... Looking in registry for Prepar3D v1 install path: HKEY_LOCAL_MACHINE\SOFTWARE\LockheedMartin\Prepar3D Parameter"SetupPath" Not there, so looking in: HKEY_CURRENT_USER\SOFTWARE\LockheedMartin\Prepar3D Parameter"AppPath" ... NOT found! ... Looking in registry for Prepar3D v2 install path: HKEY_LOCAL_MACHINE\SOFTWARE\Lockheed Martin\Prepar3D v2 Parameter"SetupPath" ... >>> OK! FOUND Prepar3D v2! <<< ... SetupPath=E:\Games\Lockheed Martin\Prepar3D v3 Looking in registry for Prepar3D v3 install path: HKEY_LOCAL_MACHINE\SOFTWARE\Lockheed Martin\Prepar3D v3 Parameter"SetupPath" ... >>> OK! FOUND Prepar3D v3! <<< ... SetupPath=E:\Games\Lockheed Martin\Prepar3D v3 ************ BUT this is the same path as for Prepar3D v2! Will only install for Prepar3D v3 ************ =========================================================== INSTALLATION FOR Prepar3D v3: SetupPath="E:\Games\Lockheed Martin\Prepar3D v3\" Checking version of the Prepar3D v3 EXE: Couldn't obtain Version Info! Asking user to find Prepar3D v3.EXE ... User identified path: "E:\Games\Lockheed Martin\Prepar3D v3" Checking version of the Prepar3D v3 EXE: Couldn't obtain Version Info! Asking user to find Prepar3D v3.EXE ... User identified path: "E:\Games\Lockheed Martin\Prepar3D v3" Checking version of the Prepar3D v3 EXE: Couldn't obtain Version Info! Asking user to find Prepar3D v3.EXE ... User identified path: "E:\Games\Lockheed Martin\Prepar3D v3" Checking version of the Prepar3D v3 EXE: Couldn't obtain Version Info! Asking user to find Prepar3D v3.EXE ... User identified path: "E:\Games\Lockheed Martin\Prepar3D v3" Checking version of the Prepar3D v3 EXE: Couldn't obtain Version Info! Asking user to find Prepar3D v3.EXE ... User identified path: "E:\Games\Lockheed Martin\Prepar3D v3" Checking version of the Prepar3D v3 EXE: Couldn't obtain Version Info! Asking user to find Prepar3D v3.EXE ... User aborted attempt to find Prepar3D v3. Installation failed. =========================================================== *************** End of Install Log *************** Last, i really need your help for resolve my problem. so desperate. Thanks, Azhari
  22. Hi, We have a win-10 machine with P3D-v4 running. After install FSUIPC5 P3D starts, but after 5 seconds it totally freeze. Reject the Modules folder P3D runs without problems. It is a fresh installation of P3D, and currently only the KA350 as default plane is used. We would like to use P3D in combination of Warpalizer, but this isn't installed yet. (first solve this issue) Of course all used software is registered... This is the log- file created by FSUIPC: ********* FSUIPC5, Version 5.10 (1st June 2017) by Pete Dowson ********* Windows 10 Pro 64 Bit reported as Build 14393, Release ID: 1607 (OS 10.0) FSUIPC5.dll version = 5.1.0.0 Reading options from "D:\P3D-v4\Modules\FSUIPC5.ini" Running inside Prepar3D v4 on Windows 10 Module base=7FFEC0B40000 User Name="Matthijs Thijssen" User Addr="matthijs@flightillusion.com" User WideFS Addr="administratie@flightillusion.com" FSUIPC5 Key is provided WideFS7 Key is provided 0 System time = 27/06/2017 10:34:58 0 FLT UNC path = "\\FALCON-SIM\Users\Simulator\Documents\Prepar3D v4 Files\" 0 ------ Module Version Check ------ 0 acontain.dll: 4.0.23.21468 0 api.dll: 4.0.23.21468 0 controls.dll: 4.0.23.21468 0 fs-traffic.dll: 4.0.23.21468 0 G3D.dll: 4.0.23.21468 0 language.dll: 4.0.23.21468 0 sim1.dll: 4.0.23.21468 0 visualfx.dll: 4.0.23.21468 0 weather.dll: 4.0.23.21468 0 window.dll: 4.0.23.21468 0 ---------------------------------- 15 FS UNC path = "\\FALCON-SIM\d\P3D-v4\" 156 ---------------------- Joystick Device Scan ----------------------- 250 ------------------------------------------------------------------- 250 ------------------------------------------------------------------- 281 LogOptions=00000000 00000001 281 ------------------------------------------------------------------- 281 SimConnect_Open succeeded: waiting to check version okay 281 Opened separate AI Traffic client okay 1156 Running in "Lockheed Martin® Prepar3D® v4", Version: 4.0.23.21468 (SimConnect: 4.0.0.0) 1156 Initialising SimConnect data requests now 1156 FSUIPC Menu entry added 1156 ... Using Prepar3D with Professional License 1172 \\FALCON-SIM\Users\Simulator\Documents\Prepar3D v4 Files\default.fxml 1172 \\FALCON-SIM\d\P3D-v4\SimObjects\Airplanes\Beech_King_Air_350\Beech_King_Air_350.air 12375 User Aircraft ID 2 supplied, now being used 12375 Aircraft loaded: running normally now ... 13031 System time = 27/06/2017 10:35:11, Simulator time = 14:06:20 (12:06Z) 13047 Aircraft="Beech King Air 350" 21109 Starting everything now ... 106578 **** No SimConnect events or states being received! Re-connecting now ... **** 106937 SimConnect_Open succeeded: waiting to check version okay 106937 Opened separate AI Traffic client okay Does someone know whats wrong? Thanks in advance, Matthijs Thijssen
  23. Hi, I have used mytaffic for a long time with good results. Although installation still need some reading but thats ok. I noticed my p3d installation got very slow with startup. I today used a stopwatch and got at 3m20s. Disabling the many add ons I use did not matter at all. I found a google entry mentioning mytraffic did this for another user. I first turned it also off with Sceneryconfig Editor but did not help. Reading the google result again I noted the person deleted the entry from simobject.cfg. Did helped me a lot. P3D now loads within a minute or maybe even 30 seconds. But afcource no planes now. Any idea for this problem. Thanks in advance. Maikel-PE1123. Netherlands.
  24. Hi, I am having a big issue with my simulator, everytime I save a flight in P3D menu or Pro-ATC/X, it freezes around 30 seconds to 1 minute which is very unusual. I found in FSUIPC.log there are 2 lines that I think can do something with it: "**** No SimConnect events or states being received! Re-connecting now ... ****" " **** SimConnect Data Stalled! Re-connecting now ... ****" My Pro-ATC/X is set to autosave every 5 minutes and it has been working flawlessly without issue, now every 5 minutes I get hang up for 1 minute. I open ProcessMonitor and see P3D keeps loading these 2 when I save the flight, usually it does it very fast, now it keeps continuously for around a minute "D:\Game\Lockheed Martin\Prepar3D v3\FSLabs\A320\PanelState\LastProATCX.fxml.sav" "C:\Users\******\Documents\Prepar3D v3 Files\KLAXKSLC_20170410-0901_RTE-EnRoute_142.fxml" It happens to PMDG aircrafts too so I believed it does not relate to FSLabs. I have reinstall the Simconnect in P3D/redist and also the P3D SDK but does not fix the problem. I don't know if this relates anything to FSUIPC but FSUIPC might point out something wrong in my simulator. Thank you, Hoang Le EDIT: Is this the correct version of Simconnect? "Running in "Lockheed Martin® Prepar3D® v3", Version: 3.4.22.19868 (SimConnect: 3.4.0.0)" Found out in FSUIPC.ini "SimConnectStallTime=20" which default should be =1? I never edit this line.
  25. Hi! Is there any offset in FSUIPC that can tell me if the simulator is connected to a multiplayer session or if it's flying "offline"? Thanks!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.