Jump to content
The simFlight Network Forums

Search the Community

Showing results for tags 'p3dv3'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Product Support Forums
    • FSUIPC Support Pete Dowson Modules
    • MyTraffic Support Forum
    • FeelThere Support Forums
    • FS Commander Support Forum
    • Flying W Simulation
    • AConstable Traffic Sounds Support Forum
    • Fabio Merlo Products Support Forum
    • Elite-Air Studio Support Forum
    • Nikola Jovanovic Support Forum
    • Intrasystems Support Forum
    • FScene Support Forum
    • Taburet & DanVFR Support Forum
    • Environ Scenery
  • simFlight DE
  • FS MAGAZIN (DE)
  • simRussia
  • FSUIPC Client DLL for .NET

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 5 results

  1. This is the first of two issue reports - I just upgraded the P3D to the latest P3Dv3/P3Dv4 version, and I'm getting a consistent crash in PMDG_777X_2.dll on shutdown. Ordinarily, I'd report straight to PMDG, but I'm seeing the following issue in the FSUIPC log at the end: 89638 === Closing session: waiting for DLLStop to be called ... 114973 === DLLStop called ... 114973 === Closing external processes we started ... 115971 === About to kill any Lua plug-ins still running ... 116127 === Closing global Lua thread 117125 === About to kill my timers ... 117328 === Restoring window procs ... 117328 === Unloading libraries ... 117328 === stopping other threads ... 117328 === ... Button scanning ... 117422 === ... Axis scanning ... 117531 === Releasing joystick devices ... 117531 === Freeing macro memory 117531 === Removing any offset overrides 117531 === Clearing any displays left 117531 === Calling SimConnect_Close ... 118124 === SimConnect_Close done! 118124 === AI slots deleted! 118124 === Freeing button memory ... 118124 === Closing my Windows ... 118124 === Freeing FS libraries ... 119122 === Closing devices ... 119122 === Closing the Log ... Bye Bye! ... 119122 System time = 10/06/2017 11:12:29, Simulator time = 11:11:21 (16:11Z) 119122 *** FSUIPC log file being closed Minimum frame rate was 24.3 fps, Maximum was 31.4 fps Minimum available memory recorded was 32768Mb Average frame rate for running time of 47 secs = 28.2 fps Average weather filter write interval in that time = 831.2 msecs Maximum AI traffic for session was 9 aircraft Memory managed: 71 Allocs, 70 Freed ********* FSUIPC Log file closed *********** Note right at the end, we're got a mismatch between malloc() and free() counts. Do you think think this may be the cause, or shall I file a ticket with PMDG? This is FSUIPC 4.967, on Windows 7 x64. FWIW, I see the same mismatch in P3Dv4 with FSUIPC5 and the PMDG 777. Cheers! Luke FSUIPC4.log
  2. Hello, i´m use FSUIPC to control my Stick in the sim. (Axes and buttons) i want to set the "Main Button" and "Secondary Button" on my Stick with FSUIPC. but i can not find "Alternate Static sourece (on/off)" and "propeller sync (on/off)" in the list for Buttons in FSUIPC. im sure that they are in, but in other names? whats the correct names for this in "control send when button pressed"? Thank you!
  3. Hi there, I'm sorry if it has been previously answered somewhere else but only had time for a brief search. I have recently noticed that my Model MActhing on Vatsim through VPILOT is incorrect. For example I fly with a friend and when he was connected as a Lufthansa A321 it said he was a Condor A320. It happened again tonight so I thought I'd ask for a bit of advice. Hopefully there is a simple fix, Many Thanks,
  4. Hi all, I've tried just about everything I can think of and am coming up 100% empty. I purchased a license for FSUIPC under the understanding that it would run on Prepar3D v3. However, once I installed it, Prepar3D no longer starts at all - it just sits and hangs on the the initial loading screen, with nothing happening thereafter. I've tried completely wiping both things entirely from the system and reinstalling fresh, with no results. I have also tried installing the SP2 simconnect in the P3D redist directory, with no results. In all honesty, I'm entirely at wits end, and don't understand what is happening - the only way I can even get Prepar3D to start is by renaming the Modules/FSUIPC4.DLL file so it fails to locate, at which point Prepar3D starts as usual - just without FSUIPC. I am running Windows 10 Pro and Prepar3D v3.1. I have below included my FSUIPC4 Install log and the most recent FSUIPC4 log. Thanks in advance for your help! Install log: Installer for FSUIPC4.DLL version 4.949f Looking in registry for FSX install path: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0 Parameter"SetupPath" Not there, so looking in: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0 Parameter"AppPath" ... NOT found! ... Looking in registry for FSX-SE install path: HKEY_LOCAL_MACHINE\SOFTWARE\DovetailGames\FSX Parameter"Install_Path" Not there, so looking in: HKEY_CURRENT_USER\SOFTWARE\DovetailGames\FSX Parameter"AppPath" Not there, so looking in: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator - Steam Edition\10.0 Parameter"SetupPath" Not there, so looking in: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator - Steam Edition\10.0 Parameter"AppPath" ... NOT found! ... Looking in registry for Prepar3D v1 install path: HKEY_LOCAL_MACHINE\SOFTWARE\LockheedMartin\Prepar3D Parameter"SetupPath" Not there, so looking in: HKEY_CURRENT_USER\SOFTWARE\LockheedMartin\Prepar3D Parameter"AppPath" ... NOT found! ... Looking in registry for Prepar3D v2 install path: HKEY_LOCAL_MACHINE\SOFTWARE\Lockheed Martin\Prepar3D v2 Parameter"SetupPath" Not there, so looking in: HKEY_CURRENT_USER\SOFTWARE\Lockheed Martin\Prepar3D v2 Parameter"AppPath" ... NOT found! ... Looking in registry for Prepar3D v3 install path: HKEY_LOCAL_MACHINE\SOFTWARE\Lockheed Martin\Prepar3D v3 Parameter"SetupPath" ... >>> OK! FOUND Prepar3D v3! <<< ... SetupPath=C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\ =========================================================== INSTALLATION FOR Prepar3D v3: SetupPath="C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\" Checking version of the Prepar3D v3 EXE: ... Version 3.1.2.15831 (Need at least 1.0.677.0) Checking compatibility with installed SimConnect: Checking if there's already a version of FSUIPC4 installed in: C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\FSUIPC4.DLL ... Version 4.949f found. Prepar3D v3 Modules folder already exists. Okay -- installed FSUIPC4 into "C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\FSUIPC4.DLL" Looking for the current user's Application Data path: ... found as "C:\Users\jeremy\AppData\Roaming" Now finding \Lockheed Martin\Prepar3D v3\Prepar3D.CFG for all users, including this one Looking in "C:\Users\All Users\AppData\Roaming" ... No Prepar3D.CFG there Looking in "C:\Users\Default\AppData\Roaming" ... No Prepar3D.CFG there Looking in "C:\Users\Default User\AppData\Roaming" ... No Prepar3D.CFG there Looking in "C:\Users\Default.migrated\AppData\Roaming" ... No Prepar3D.CFG there Looking in "C:\Users\jeremy\AppData\Roaming" Found Prepar3D.CFG in "C:\Users\jeremy\AppData\Roaming\Lockheed Martin\Prepar3D v3\Prepar3D.CFG" Now checking DLL.XML ... ... There is a previous DLL.XML, checking for FSUIPC4 section. ... FSUIPC4 section already exists but will be replaced. (for FSUIPC4, without Loader) ... FSUIPC4 section of DLL.XML written okay Now checking for a SimConnect.XML file ... ... No SimConnect.XML file found. This is okay. Looking in "C:\Users\Public\AppData\Roaming" ... No Prepar3D.CFG there "Modules\FSUIPC Documents" folder already exists. Now installing the Prepar3D SimConnect interface for FSUIPC4 into the "Modules" folder: Installed "SimConnectP3D2.dll" okay Now installing additional files into the "Modules\FSUIPC Documents" folder: Installed "FSUIPC4 User Guide.pdf" okay Installed "FSUIPC4 for Advanced Users.pdf" okay Installed "FSUIPC4 History.pdf" okay Installed "List of FSX and P3D controls.pdf" okay Installed "FSUIPC Lua Library.pdf" okay Installed "FSUIPC Lua Plug-Ins.pdf" okay Installed "Lua License.pdf" okay Installed "Lua Plugins for VRInsight Devices.pdf" okay Installed "LuaFileSystem.pdf" okay Installed "Example LUA plugins.zip" okay Installed "ASN WX Radar facilities in FSUIPC4.pdf" okay Installed "Offset Mapping for PMDG 737NGX.pdf" okay Installed "Offset Mapping for PMDG 777X.pdf" okay Installed "FSUIPC4 Offsets Status.pdf" okay Installed "Profiles in Separate Files.pdf" okay =========================================================== All installer tasks completed. Registration dialog exit: selected FSUIPC REGISTER Providing FSUIPC registration dialogue ... Registration for FSUIPC4 was successful! (result code 00) *************** End of Install Log *************** FSUIPC4 log: ********* FSUIPC4, Version 4.949f by Pete Dowson ********* Prepar3D.exe version = 3.1.2.15831 Running inside Prepar3D v3 on Windows 8.0 Module base=63000000 User Name="Jeremy Holland" User Addr="jeremy@jeremypholland.com" FSUIPC4 Key is provided WIDEFS7 not user registered, or expired 62 System time = 02/03/2016 15:21:23 62 FLT path = "C:\Users\jeremy\Documents\Prepar3D v3 Files\" 62 ------ Module Version Check ------ 62 acontain.dll: 3.1.2.15831 62 api.dll: 3.1.2.15831 62 controls.dll: 3.1.2.15831 62 fs-traffic.dll: 3.1.2.15831 62 G3D.dll: 3.1.2.15831 62 language.dll: 3.1.2.15831 62 sim1.dll: 3.1.2.15831 62 visualfx.dll: 3.1.2.15831 62 weather.dll: 3.1.2.15831 62 window.dll: 3.1.2.15831 62 ---------------------------------- 62 Trying C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\SimConnectP3D2.dll 62 Found it: trying to connect 62 FS path = "C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\"
  5. Hey Pete, I have a little problem with FSUIPC and P3Dv3. Running 4.496, can bind key presses with no problem. Have my axis defined in P3D, working fine. When i try to tweak the axis within FSUIPC it doesn't pick the axis up. So for example i cannot set my throttle up within FSUIPC or yoke. Any ideas? Thanks for your help. Ian
×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.