Jump to content
The simFlight Network Forums

Widefs error on XP pro.


Guest novgui
 Share

Recommended Posts

Guest novgui

Hi Peter:

Greetings from Mexico City, please I need help. This is my problem; I was runing Widefs in my server Gateway windos XP HE, PIV 2.4 mhz, and the second PC a Compaq PIII windows 98 SE and all was runing wanderfull, but I had to update the Compaq to Windows XP pro. edition both in spanish, and now I got this error when i trie to start the wideclient on the Compaq of course:

********* WideClient.DLL Log [version 5.41] *********

Date (dmy): 15/03/03, Time 11:13:02.716: Client name is COMPAQ

330 Attempting to connect now

330 Client socket() failed [Error=10047] Address family not supported by protocol family

11817 Failed to start Client!

15362 Reception maximum achieved: 0 frames/sec, 0 bytes/sec

15372 Max receive buffer = 0, Max send depth = 0

15372 ********* Log file closed (Buffers: MaxUsed 0, Alloc 0 Freed 0 Refused 0) *********

I just check the tcp/ip addrs., and the TcpIP=yes option in both PC's without results. What can I do ?. Thank you in advance :(

Link to comment
Share on other sites

330 Client socket() failed [Error=10047] Address family not supported by protocol family

This is ALWAYS because the protocol you are asking WideFS to use is not installed. At least I've never yet seem such an error which wasn't because of this in the 6 years WideFS has been around!

I just check the tcp/ip addrs., and the TcpIP=yes option in both PC's without results.

May you should use the "UseTCPIP=Yes" parameter? There is no "TCPIP=Yes" parameter.

Regards,

Pete

Link to comment
Share on other sites

As Pete said, it looks like there is a typo with the UseTCPIP parameter, if that's it I believe that WideFS defaults to IPX so it will complain that it doesn't find the IPX protocol that is certainly not installed while in fact you want to use IP...

Correct the ini file, that should work again, if not post your wideserver.ini and wideclient.ini in there and we'll try to help further :wink:

Link to comment
Share on other sites

Guest novgui

Thank you for your help, here are the files:

Wideserver.ini

; PLEASE SEE the documentation for parameter details

; ==================================================

[Config]

UseTCPIP=Yes

Port=8002

; -----------------------------------------------

[user]

Log=Errors+

; ===============================================

Wideclient ini file:

; PLEASE SEE WideFS documentation for parameter details

; =====================================================

[Config]

UseTCPIP=Yes

ServerIPAddr=192.168.0.1

UseTCPIP=No

Port=8002

Window=43,44,886,589

Visible=Yes

; -----------------------------------------------

[user]

Log=Errors+

; ===============================================

I`ll wait your comments thank you again.

Link to comment
Share on other sites

Thank you for your help, here are the files:.

Okay. In the Server INI you have:

UseTCPIP=Yes

but in the Client INI you have:

UseTCPIP=Yes

ServerIPAddr=192.168.0.1

UseTCPIP=No

I expect the second copy of "UseTCPIP" will win over the first!

Rather than use an IPAddr you may find it easier to use the ServerName, unless it is hard to spell correctly!

Regards,

Pete

Link to comment
Share on other sites

Hi Pete:

As soon as I read your post ran to modify the file (very good observation), I don`t know how I didn`t see it. :oops: To my surprise I still having the same "failed to start client", next is the log file:

********* WideClient.DLL Log [version 5.41] *********

Date (dmy): 16/03/03, Time 12:50:15.212: Client name is COMPAQ

130 Attempting to connect now

130 Client socket() failed [Error=10047] Address family not supported by protocol family

5828 Failed to start Client!

7941 Reception maximum achieved: 0 frames/sec, 0 bytes/sec

7941 Max receive buffer = 0, Max send depth = 0

7941 ********* Log file closed (Buffers: MaxUsed 0, Alloc 0 Freed 0 Refused 0) *********

as you can see practically is the same. Here are the client .ini file:

; PLEASE SEE WideFS documentation for parameter details

; =====================================================

[Config]

UseTCPIP=Yes

ServerIPAddr=192.168.0.1

Port=8002

Window=43,44,886,589

Visible=Yes

; -----------------------------------------------

[user]

Log=Errors+

; ===============================================

even changing the server name (how is Gateway) still not working.

Anyway thank you for your kindless and worrys about this. If you have another idea I can trie it, just tell me about it. Greetings. :|

Link to comment
Share on other sites

130 Client socket() failed [Error=10047] Address family not supported by protocol family

This is 100% still going to be the fact that the UseTCPIP parameter is not set correctly. To start with, if you give the same of the Server, it will be logged and the IP address it finds will also be logged. It looks very much as if the copy of WideClient you are running is NOT reading the copy of the WideClient.ini file you are showing us --- there is simply no other explanation. Please be absolutely sure that the correct Wideclient.exe you are running and the WideClient.ini file you are editing, both reside in the same folder, and that you are running that EXE from that folder with it set as the current folder.

Best that you use Windows Explorer and search for all things "WideClient.*" as it does really sound like you have things very mixed up there. We are running clean out of alternative explanations.

A TCP/IP configured WideClient which has been given the Server name will have a log starting off like this (after the title):

Date (dmy): 16/03/03, Time 19:10:21.625: Client name is NEWLEFT

329 Attempting to connect now

375 Trying TCP/IP host "OFFCENTRE" ...

375Okay, IP Address = 192.168.0.8

Even if it didn't get as far as the "Okay" here it would still list the server name you gave.

Regards,

Pete

Link to comment
Share on other sites

Guest novgui

Great !!! Pete.

That was !!!!. You are totally right. I just run it again from the c:\Mis documentos\Widefs folder and that was. Is runing as well as before in Windows 98. Thank you for your great help and worries about my ex-problem. I`ll continue enjoying your program. Greetings from Mexico City. Anytime yours from Mexico "novgui@prodigy.net.mx" :lol:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.