Jump to content
The simFlight Network Forums

FSUIPC & Saitek Cyborg 3d - Problem


Recommended Posts

Using this joystick with FS2002 Pro I have assigned one button to Flaps Incr pulsed and no repeats. The problem is that on the first press the flaps increment to the first position but further presses result in random movement of the flaps sometimes up and sometimes down. In other words it seems to be unreliable. I would appreciate any suggestions for cure.

Link to comment
Share on other sites

Using this joystick with FS2002 Pro I have assigned one button to Flaps Incr pulsed and no repeats. The problem is that on the first press the flaps increment to the first position but further presses result in random movement of the flaps sometimes up and sometimes down. In other words it seems to be unreliable. I would appreciate any suggestions for cure.

Not sure why you are asking this here -- this is a support forum for my FS add-in Modules, not for FS generally or for joystick drivers -- but it sounds rather like something in the Saitek driver is changing the button behaviour. Try restoring FS defaults (Options-Controls-Assignments) and re-testing. Maybe FS has its assignments in a mess. Maybe you have somehow got multiple assignments

If you have FSUIPC installed you could try de-assigning the button in the FS Assignments and using FSUIPC's Button facilities instead. But try getting it sorted in FS first. After all, virtually all of the recognised joysticks have flap buttons already pre-assigned by FS and they should work fine. There's no need to use anything in FSUIPC really, it isn't accomplishing anything better or different for the standard assignable controls.

Regards,

Pete

Link to comment
Share on other sites

Sorry I should have said in the text body that I used FSUIPC to program the joystick and it was FSUIPC 'Flaps incr' command which was causing the problem.

Since FSUIPC is only sending the same Flaps Increment control that you can assign directly in the FS joystick Assignments dialogue, I don't see any point in doing that. Did you try to sort out the button assignments in FS first?

If you haven't actually DELETED the assignments there, before uing the FS facilities, your buttons will be interpreted by both FS and by FSUIPC, and you will very likely get just the sort of results you are seeing. That's what it sounds like to me.

Really there's no point in using the FSUIPC facilities for any of the straight-forward controls that are either assigned automatically by FS anyway, or that are easily assignable in its dialogues. The drop-down list in FSUIPC only includes them because they are part of the total list in FS, not just those selected for the dialogues. And if you do assign any buttons in FSUIPC you must certainly make sure they are NOT assigned in FS -- there is no way FSUIPC can stop FS looking at them too!

Regards,

Pete

Link to comment
Share on other sites

Many thanks Peter for speedy reply. I had not thought of the fact that FS was already programed that it might be causing the problem. I am sure now that is the answer. Anyhow thanks fro drwaing my attention to it and have a nice holiday !!!!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.