Jump to content
The simFlight Network Forums
Sign in to follow this  
S P Foster

Help required adding aircraft with MyTraffic Editor.

Recommended Posts

Hi,

I'm having some problems with the latest version of MyTraffic Editor. I have followed one of the tutorials through word for word for adding your own aircraft but it just wont work.

I have used the suggested aircraft in the tutorial, in this case the MelJet’s GMax B747-400 Singapore Airlines Tropical Megatop.

Can someone please tell me what i'm doing wrong, this is what i'm currently doing:

1) Start MyTraffic Editor

2) Open MyTrafficbase2.myt

3) Click on Aircraft > MyTypes

4) Click on Add New

5) Enter B747-400SIATROP in the "Type Key" box

6) In the Title in FS2002 field I copy and paste the aircraft title directly from the aircraft.cfg file.

7) Select B747-400 in the Series

8) Select Singapore from the Airlines list.

9) Make sure the box ‘Use in MyTraffic’ is ticked. Click OK.

10) Exit the MyTypes menu by clicking cancel.

11) Go to the Aircraft>MyPlanes

12) Click on ‘Add New’

13) Create the registration 9V-SPV (as it's not already being used), ensuring that "Use to Autoschedule MyPlanes" and "Use in preferred generated traffic" are both ticked.

14) Click Ok and then cancel to exit the menus.

15) Go to Schedule > MySchedule and Click on ‘Add Schedule’.

16) Enter the flight number as 328. Highlight the aircraft registration, in this case 9V-SPV, Select WSSS as the departure airport and EDDF as the destination. I then enter the departure time as 0720 and the click on Propose times so that it puts an arrival time in. I then click on OK.

17) I then go to Schedule > Autoschedule MyPlanes.

18) The progress bar then completes without any errors being shown.

19) Then I go to Create > Create all files and traffic.

20) It then compiles the following files:

My aircraft.dat

My Routes.dat

it then says Calling Traffic.bat and after says "Traffic Scenery Built"

Everything seems OK and I get no error messages up at anytime.

I assume that after this it should have modified or created a new MyTraffic.bgl file! Despite thorough searches the only MyTraffic.bgl file on my PC is the original one which is located in:

C:\Program Files\Microsoft Games\FS2002\SCENEDB\MyTrafficATC\Scenery

This file has a reported size of 47,025,124 bytes and the modification date is not the day on which I tried to modify it.

So I guess i'm doing something wrong which is why the file is not being modified.

I'm sorry this posting was so long but I thought it may be helpful if I included everything I was doing in the hope that someone could help me.

Many thanks in advance,

Steve.

Share this post


Link to post
Share on other sites

Hi Steve,

Just to verify, by latest version of the Editor, you are referring to 1.2, right?

It sounds like the MyTraffic2.bgl file is either not being created by the editor, or the file is not being copied from the [FS2002]\MyTraffic folder to the FS2002\SCENEDB\MyTrafficATC\Scenery folder

Could you check if the MyTraffic2.bgl file is in the [FS2002]\MyTraffic folder?

Share this post


Link to post
Share on other sites

If it is built, it must be somewhere, the copy goes from the MyTraffic directory one step up and then the scenedb\MyTrafficATC\scenery down...

Share this post


Link to post
Share on other sites

Hi Burkhard & Husain,

I have carried out a full search of my PC's hard drives and the only MyTraffic.bgl I have is the original one, there are no other files of that name or MyTraffic2.bgl or anything like it on my PC anywhere.

I am using Version 1.2 of the MyTraffic Editor.

Any other ideas? I would be extremely grateful.

Many thanks,

Steve.

Share this post


Link to post
Share on other sites

Do you compile and get no error message before the pause happens, than you press return for the pause, and nothing gets created?

Or o you get any other message before the pause?

Share this post


Link to post
Share on other sites

Burkhard,

What do you mean by "pause"? Once I click on the "Create all files and traffic" button it creates My aircraft.dat and My Routes.dat it then says Calling Traffic.bat and after shortly after says "Traffic Scenery Built".

At no time during any of this do I get any form of error message what so ever. It gives the impression that everything has worked fine. It just doesn't compile a new MyTraffic.bgl file or modify the existing one.

I hope this helps in finding out my problem.

Look forward to hearing from you.

Regards,

Steve.

Share this post


Link to post
Share on other sites

Yes, you must have a very old (1.0) version of the file. Didn't you update the editor?

MyTraffic\trafficbat.bat. I hope I remember the name right, but there are not so many .bat files in there.

Please open it with notepad, you will see it has two lines, one calling trafficdatabasebuilder, the other a simple copy.

Please include a line

Pause

between these two lines and save.

Next time you will have the command window pausing and you can see any compiler errors. If it tells you of a missing airport, you are using an old version of MyAirports.dat, replace it by the one from Addon\Mytrafficeditor.

Share this post


Link to post
Share on other sites

Burkhard,

My version of traffic editor is 1.2 it's all been updated and seems OK, when I click on Help > About My Traffic it comes up as "My Traffic Version 1.2"

I have checked the Trafficbat.bat file and it contains the text below.

TrafficDataBaseBuilder /airports=MyAirports.dat /AircraftTypes=MyAircraft.dat /Routes=MyRoutes.dat /autoroute=no /output=Mytraffic.bgl /StatsDir=MyTrafficStat

Pause

copy MyTraffic.bgl ..\scenedb\MyTrafficATC\scenery\MyTraffic2.bgl

As you can see the Pause line is in the batch file but it doesn't take any notice of it and neither does it create a file called MyTraffic2.bgl

If I go into Info>Departures and check to see if my added schedules are there I can see them, but when I go to the airport they aren't there. I guess that's because the bgl file is not being compiled.

Just to rule out a problem with the installation can you tell me if the following is right, this is how I have got to having Version 1.2 on my PC.

Installed My Traffic Editor 1.0 when it first came out.

Installed the Editor Update which brought it up to Version 1.1;

and then have installed Version 1.2 over the top of this.

Is this right or could this be causing a problem, should I try uninstalling the previous versions and just put Version 1.2 straight on or wont this work?

Back to you i'm afraid for any other ideas you may have.

Regards,

Steve.

Share this post


Link to post
Share on other sites

Do you see, when compiling, a DOS window flashing up?

Are the following files in the MyTraffic directory:

Trafficdatabasebuilder.exe

MyRoutes.dat

MyAircrafts.dat

MyAirports.dat

and the .myt database you currently work on?

What happens if you dobleclick Trafficbat.bat?

Share this post


Link to post
Share on other sites

Hi,

I had the same issue as Steve. I just purchased MyTraffic and the editor on March 29. I says it is version 1.2.

These files were in FS2002\Mytraffic\addon\MyTrafficEditor.

MyRoutes.dat

MyAircrafts.dat

MyAirports.dat

MyTraffic.myt

After copying them to FS2002\Mytraffic and then running trafficbat it compiled the MyTraffic2.bgl and copied it to the MyTrafficATC\Scenery directory.

Allen

Share this post


Link to post
Share on other sites

Burkhard & Asterbenz,

Hi, I have just copied the contents of the FS2002\Mytraffic\addon\MyTrafficEditor to the FS2002\MyTraffic directory and now when I click on "Create all files and traffic" I now see a DOS screen which goes through Increasing the route altitudes at all the airports (it looks like all of them, but its too fast to check).

It then says:

MyTraffic.bgl: Saving airport data

MyTraffic.bgl: Saving aircraft types

MyTraffic.bgl: Saving aircraft instances

MyTraffic.bgl: saving spatial cells

I then get the Pause that you previously mention Burkhard, there are no errors there at all. It then moves the MyTraffic.bgl file to the FS2002\SCENEDB\MyTrafficATC\Scenery and renames it MyTraffic2.bgl.

I then went to the FS2002\SCENEDB\MyTrafficATC\Scenery and move the original MyTraffic.bgl file to a seperate directory to keep it safe and then rename MyTraffic2.bgl to MyTraffic.bgl, I guess this is right.

So far so good, so thank you all for all the help you have given me on this.

However, when I go to the airport where I have scheduled the new traffic it is not there, I have checked the Info>Departures screen and my flight is there I just can't work out where i'm going wrong. I see the flights before and after mine but not my one. However, when I check on the Info>Arrivals screen at the destination airport for my flight by the time it is scheduled to arrive it is just blank, the time is there, but not the flight details.

Can someone please tell me what i'm doing wrong. Is this not the correct way of adding a new aircraft and adding it to the schedules:

1) Start MyTraffic Editor

2) Open MyTrafficbase2.myt

3) Click on Aircraft > MyTypes

4) Click on Add New

5) Enter B747-400SIATROP in the "Type Key" box

6) In the Title in FS2002 field I copy and paste the aircraft title directly from the aircraft.cfg file.

7) Select B747-400 in the Series

8) Select Singapore from the Airlines list.

9) Make sure the box ‘Use in MyTraffic’ is ticked. Click OK.

10) Exit the MyTypes menu by clicking cancel.

11) Go to the Aircraft>MyPlanes

12) Click on ‘Add New’

13) Create the registration 9V-SPV (as it's not already being used), ensuring that "Use to Autoschedule MyPlanes" and "Use in preferred generated traffic" are both ticked.

14) Click Ok and then cancel to exit the menus.

15) Go to Schedule > MySchedule and Click on ‘Add Schedule’.

16) Enter the flight number as 328. Highlight the aircraft registration, in this case 9V-SPV, Select WSSS as the departure airport and EDDF as the destination. I then enter the departure time as 0720 and the click on Propose times so that it puts an arrival time in. I then click on OK.

17) Then I go to Create > Create all files and traffic. (I get no error messages at all during this operation)

18) After that has completed I rename the MyTraffic2.bgl to MyTraffic.bgl (after moving the orignal to another directory so i don't loose it)

Someone please tell me where i'm going wrong, i've read the manual so many times and think I have followed it word for word but I just can't get it to work.

Thanks,

Steve.

Share this post


Link to post
Share on other sites

Hi Steve,

Test it this way.

Go to the MelJet aircraft.cfg and change the title= field temporarily to something else. Now go to a MyTraffic aircraft, such as the 737-200 and open the aircraft.cfg file and change the title of the United 737-200 to 'Boeing 747-400 Singapore Airlines "Tropical Megatop"' after making a note of what title currently is. (We are using United as we wouldn't expect a United 737-200 to otherwise visit Changi).

Now start FS2002. You should see a United 737-200 aircraft...if you do, it proves that the problem is with the MelJet 744 and not the MyTraffic2.bgl file. If it isn't there we can troubleshoot further. I will go back and change the tutorial as I realised the MelJet isn't a very good choice to use as an example for an AI aircraft.

No matter what the test result is, return the tiles of both the aircraft to the originals.

Share this post


Link to post
Share on other sites

Hi Husain,

Thanks for taking an interest in this, it looks like I need all the help I can get.

I tried exactly as you suggested, changing the MelJet aircraft.cfg title field and using that in the United 737-200 but that didn't work either, so I have now returned them back to their original state.

One thing that does confuse me and I do believe it could be something to do with it is this.

After I have created the new MyTraffic2.bgl file I go and look in the MyTraffic Editor Info > Departure screen, when I enter WSSS as the airport and look in the schedules I see the following which indeed looks like all the others:

0720 | 328 | Singapore B747-400 Dest: EDDF Frankfurt 1904

However, when I go to MyTraffic Editor Info > Arrivals for EDDF all I see for the scheduled arrival time is:

1904

There is no other information regarding the flight, the rest of the line is just blank. This isn't the case with all the other flights, their departures and arrivals match up.

Is this any help? Is it me not creating the flight properly or do you think the problem lies elsewhere?

Once again many thanks for everyones help on this I really do appreciate it.

Regards,

Steve.

Share this post


Link to post
Share on other sites

Hussain, Burkhard, anyone,

Could really do with your help on this guys if you have any ideas as to why I can't get MyTraffic Editor to work properly.

Thanks,

Steve.

Share this post


Link to post
Share on other sites

Hi Steve,

Sorry about the delay.

Although the arrival time is of no concequence to the AI traffic engine within FS, the fact that the Editor is not showing the arrival entry correctly could be a hint that there something wrong with the MySchedule you added.

Could you try adding another MySchedule, only this time using one of the aircraft includedi in MyTraffic. Try this:

Add a MySchedule for the aircraft with Registration VT-ESN (Air India 747-400) departing from EDDF for KEWR at 0700 GMT. Click on propose times and then click on ok.

Go to Info > Departures > EDDF and check if the flight is there. Now do the same with KJFK, only Arrivals this time. You should a scheduled arrival at 1403 GMT with all the other information such as aircraft, Airline, flight number. Let me know the results. If the information is shown, then compile the MyTraffic2.bgl and see if you get an Air India 747-400 at EDDF at 0700 GMT.

Fyi, I did get the same error as you with only the arrival time and no other information when scheduling this flight. What I did was changed the destination to KJFK and the information appeared on the arrivals screen this time. Switching back to KEWR, the information seemed to appear this time.

Share this post


Link to post
Share on other sites

:(

Hi, I just wanted to say that I have been following along. I am having alomost the same problem as Steve.

I am using a B1900 (PAI) on a flight. departure shows but no arrival at the destination in the editor. I do see the plane at departure and can follow it with CTL W but it disapears 1/2 way to dest. Is this because of the arrival not showing in the editor?

Later, John

Share this post


Link to post
Share on other sites

Hi John,

I am not sure what is causing the inconsistency with the arrivals menu but I have been able to fix it by going back to the MySchedule, changing the destination. Clicking ok and then going back editing the destination to what it was before. Can you check if this works for you?

Share this post


Link to post
Share on other sites

Hi Hussain,

Have spent the day testing and on only one occasion have I managed to get the flight to appear in the arrivals timetable correctly.

All the othertimes all I get is the arrival time with the rest of the line blank. I have written down exactly what I have been doing each time and when I did get it to work I tried to replicate it but couldn't.

Is it possible that my dat files are corrupted / wrong? I have hopefully uploaded a screenshot of the following folder from PC:

C:\Program Files\Microsoft Games\FS2002\MyTraffic

Does anything look wrong their, file size wise or dates?

I have to admit that this problem with MyTraffic Editor is now beginning to test my patience, but i'm not giving in yet.

Regards,

Steve.

post-1207-128688946798_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Husain,

I changed out the destination and then changed it back again and it worked. I may have some info to narrow down the problem.

The flight I scheduled was KCKB to KPIT in a B1900D (PAI) a real world flight that takes about 30 minutes.

In myschedule I put in a 1000 departure time and clicked propose times and it returned 1113 for the arrival (1hr 13 min) (longer flight time). Checked the depart. board and it showed 1000 correctly. Checked the arrival board for KPIT and it showed the arrival as 1000 also with no other flight info. After switching out the distinations it now shows the arrival as 1025 and all flight info and approx correct flight time.

I hope this may help find the prob. :D

Thanks much, John

P.S. Its still a great program.

Share this post


Link to post
Share on other sites

Thanks John,

I tested this yesterday myself and I know it works. The arrival time calculation isn't consistent though...its to do with the the dodgy cruise speeds.

Steve, did you try as I suggested with changing the destination?

Share this post


Link to post
Share on other sites

Husain,

I did as requested, changed the destination and then changed it back again. It only worked once. After that I could not get it to come up in the arrivals timetable again. As I said, I even wrote down exactly what I had done but it just wouldn't do it again.

I have just started my PC up again and have tried again using the original MyTrafficbase2.myt file and it still wont create the flight correctly in the arrivals timetable, same as usual, arrival time then the rest of the line is blank.

Can you just confirm that what i'm doing is correct.

1) Open MyTraffic Editor.

2) Open MyTrafficbase2.myt

3) Click on Schedule > My Schedule.

4) Click on Add Schedule.

5) Insert a flight number (i.e. 123).

6) Highlight an aircraft registration (i.e. VT-ESN).

7) Highlight an airport in the departing from field. (i.e. EDDF).

8) Highlight an airport in the destination field. (i.e. KJFK).

9) Enter 0700 in the Departure time field.

10) Ensure daily is clicked.

11) Click on Propose Times.

12) Click on OK.

13) Click on Create > Create all files and traffic.

Once i've done that I go to Info > Arrivals to check and all I see at time 1402 is the time then the rest of the line is blank.

I then go to Schedule > My Schedule, highlight the flight I created and click Edit. I then change the destination to KEWR and click on OK. I then go back to Schedule > My Schedule and repeat the process this time changing the destination back to KJFK and then click OK.

Then I go back to check in the arrivals timetable for KJFK and at 1402 I have the time, and the rest of the line is just blank.

I have got no idea why this wont work, any other help / ideas that you may have will be more than welcome.

Regards,

Steve.

Share this post


Link to post
Share on other sites

Hey,

Thanks much, I will make a couple more schedules after work today and see if the switch works for me consistantly.

Take care,

John :P

Share this post


Link to post
Share on other sites

Hi Steve,

After you add the MySchedule, you don't need to compile all files and traffic. Add it, go to the Arrivals time table and check if it appears. If not then switch the destination, click ok. Switch it back and then check the arrival time. It should be there.

It sounds like an error in the code. I'll ask Burkhard to check it once he's back.

Share this post


Link to post
Share on other sites

Hi Husain,

Thanks for all the help you have been giving me on this, I really do appreciate it.

You are quite correct in saying that I don't need to "Create all files and traffic" when adding a new schedule just to look at it.

I was being paranoid and thinking I was doing something wrong and just needed to clear that up in case all the problems where a stupid mistake on my behalf. That was why I listed all of my actions from start to finish. Although I will be the first to admit I no nothing about programming I must admit I would have thought that an error may have been produced in the circumstances I have been experiencing when the MyTraffic2.bgl file was being created if the timetable didn't match up.

I understand Burkhard is away for a few days from what I have read in other posts. I would be grateful if you could please bring the issue up with him when he's back and I will look forward to hearing from you soon. Hopefully with a fix so I can start using the programme.

Warmest regards,

Steve.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.