Jump to content
The simFlight Network Forums
drskyking

Rudder neutral value shifts from 0 to values 50-1200

Recommended Posts

even after calibrating my CH USB rudder pedals. I have had this problem since I installed FS9 on my Dell Dimension. I just reformatted my hard drive, reinstalled FS2004, recalibrated my rudder pedals, reset the settings in my registered FSUIPC 3.5 and still within minutes of calibrating and resetting the neutral value of my pedals to 0 they drift. This makes aircraft very unsteady to taxi and keep straight in flight without AP. Is there a setting I can change somewhere?

This is my current FSUIPC config file:

[General]

GenerateCirrus=No

WindShearSharp=No

AutoTaxiWind=No

UpperWindGusts=Yes

GraduatedVisibility=No

LowerVisAltitude=0

UpperVisAltitude=25000

ExtendMetarMaxVis=No

PatchSimApAlt=Yes

AutoClearWeather=Yes

ExtendTopWind=No

WindSmoothness=5

SmoothPressure=No

PressureSmoothness=5

SmoothVisibility=Yes

VisibilitySmoothness=2

MaxSurfaceWind=9

WindLimitLevel=200

WindDiscardLevel=400

WindAjustAltitude=No

WindAjustAltitudeBy=2000

MinimumVisibility=0

MaximumVisibility=0

MaximumVisibilityFewClouds=0

MaximumVisibilityOvercast=0

UpperVisibility=6000

OneCloudLayer=No

ThinClouds=No

ThinThunderClouds=No

CloudThinness=1000

ThunderCloudThinness=10000

CloudTurbulence=No

CloudIcing=No

WindTurbulence=No

SuppressAllGusts=No

ExternalOptionControl=Yes

AutoTuneADF=No

MagicBattery=Yes

AxisCalibration=No

TCASid=Tail

TCASrange=40

KeepFS98CloudCover=No

RudderSpikeRemoval=No

ElevatorSpikeRemoval=No

AileronSpikeRemoval=No

SuppressCloudTurbulence=No

SuppressWindTurbulence=No

FixWindows=No

MainMenu=&Modules

SubMenu=&FSUIPC ...

TrapUserInterrupt=Yes

NavFreq50KHz=No

ClockSync=No

SmoothIAS=No

FixControlAccel=Yes

MaximumVisibilityRainy=0

ShowPMcontrols=No

TrafficScanPerFrame=10

History=O6TGV5MYJT57858RYTM6R

WhiteMessages=No

ThrottleSyncAll=No

DisconnTrimForAP=No

ReversedElevatorTrim=No

SpoilerIncrement=512

ShortAircraftNameOk=No

ZeroElevForAPAlt=No

WindSmoothing=Yes

PropTaxiWind=No

TimeSetMode=Partial

SetVisUpperAlt=No

VisUpperAltLimit=6000

MaxIce=-4

WindSmoothingDelay=0

WindSmoothAirborneOnly=No

VisSmoothingDelay=0

VisSmoothAirborneOnly=No

CentredDialogue=No

ClearWeatherDynamics=Yes

OwnWeatherChanges=No

WeatherReadInterval=4

MoveBGLvariables=Yes

TimeForSelect=4

WeatherReadsFast=No

[JoystickCalibration]

FlapsSetControl=0

Aileron=-16380,0,0,16380

Rudder=-16380,0,0,16380

Mixture=-16193,16192

RightBrake=-13970,13970

Elevator=-16380,0,0,16380

LeftBrake=-13970,13970

MapProp12to34=Yes

MapMix12to34=Yes

ReverserControl=66292

MaxThrottleForReverser=1

AileronTrimControl=1

RudderTrimControl=1

MapProp=Yes

MapThr12to34=Yes

PropPitch1=-16193,0,512,16192

Throttle1=-16193,-15425,-15425,16192

CowlFlaps1Control=0

CowlFlaps2Control=0

CowlFlaps3Control=0

CowlFlaps4Control=0

PanHeading=-16380,-512,512,16380

PanPitch=-16380,-512,512,16380

PanTilt=-16380,-512,512,16380

ExclThrottleSet=No

SepRevsJetsOnly=No

Reverser1Control=66422

Reverser2Control=66425

Reverser3Control=66428

Reverser4Control=66431

MapThrottle=Yes

[buttons]

0=H1,11,K35,8

1=H1,2,K45,10

2=H1,3,K135,10

3=R1,8,C1006,1

4=H1,9,K192,8

5=P1,34,C66416,0

6=P1,32,C65735,0

7=P1,33,C66416,0

8=P1,35,C66416,0

9=P1,37,C66416,0

10=P1,38,C66416,0

11=P1,39,C66416,0

12=U1,8,C1006,2

13=P1,9,C1006,1

14=U1,9,C1006,2

[Keys]

1=191,8,65589,0

Thank you.. Robert

Share this post


Link to post
Share on other sites

Hi Robert,

I assume the hardware is OK and the controls are properly calibrated in windows game controller? Then go into FS menu and set sensitivity to max and null zone to min. Only then try to finetune the calibration in FSUIPC. From your ini file I see that the centre dead zones for all controls are set to zero, that means no dead zone at all. This way a slight noise or jitter on the joystick input will already give control movements and thus make the plane unstable.

Calibrate again and make sure you set up a proper dead zone at each controls centre. The rudder entry for instance should then read something like

Rudder=-16380,-512,512,16380.

Regards,

Frank

Share this post


Link to post
Share on other sites

It also would not hurt to try turning on spike filtering for all your USB controls especially if these problems came about with a computer change. USB controls are subject to this kind of noise that can vary among computer types.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.