Jump to content
The simFlight Network Forums

FStarRC v1.82


Guest Crazzzy Canuuuk

Recommended Posts

Guest Crazzzy Canuuuk

I've just downloaded and tried to install unsuccessfully FStarRc v 1.82 to my copy of Flitestar 8.51. I'm not sure what I'm doing wrong. I've copied all of the files from FStarRc v 1.82 into the main folder of Flitestar and have run the program using the FstarRC icon. The program runs and a FstarRC.ini file is generated as expected. However, when I print the Navigation Log an .apl file is not created anywhere. I have, of course, amended the FstarRC.ini file as directed, but no .apl file is ever created.

The instructions indicate that FstarRC makes some subtle changes to the printed log, changing the title to RC Navigation Log and the name Flitestar has the FstarRC name appended. I have not witnessed these sort of changes.

Any suggestions would be most greatfully appreciated. I am most looking forward to utilizing Flitestar for FS2002, Radar Contact and multiplayer flight plans.

Link to post
Share on other sites
Guest Crazzzy Canuuuk

I've just downloaded and tried to install unsuccessfully FStarRc v 1.82 to my copy of Flitestar 8.51. I'm not sure what I'm doing wrong. I've copied all of the files from FStarRc v 1.82 into the main folder of Flitestar and have run the program using the FstarRC icon. The program runs and a FstarRC.ini file is generated as expected. However, when I print the Navigation Log an .apl file is not created anywhere. I have, of course, amended the FstarRC.ini file as directed, but no .apl file is ever created.

The instructions indicate that FstarRC makes some subtle changes to the printed log, changing the title to RC Navigation Log and the name Flitestar has the FstarRC name appended. I have not witnessed these sort of changes.

Any suggestions would be most greatfully appreciated. I am most looking forward to utilizing Flitestar for FS2002, Radar Contact and multiplayer flight plans.

Link to post
Share on other sites
I've copied all of the files from FStarRc v 1.82 into the main folder of Flitestar and have run the program using the FstarRC icon. The program runs and a FstarRC.ini file is generated as expected.

Okay, so far so good.

However, when I print the Navigation Log an .apl file is not created anywhere.

Hmmm --- this IS the Navigation Log selected by the "Reports" isn't it? Can you make a note of what report options you've got set -- with the Navigation Log displayed on screen, right click. In the menu which items are ticked? Then click on 'Optional Blocks'. Which items are ticked there?

There may be some dependency on the formatting. I've not heard from anyone else with a problem, but just in case, try setting the same options as I have -- select "Expanded Log" and "Medium" in the first right-click menu, and the ALL of the optional blocks (not "Hide All").

If still no joy please send me your FStarRC ini file. In the worst case I shall ask you to edit it to turn on a Logging facility.

Pete

Link to post
Share on other sites
I've copied all of the files from FStarRc v 1.82 into the main folder of Flitestar and have run the program using the FstarRC icon. The program runs and a FstarRC.ini file is generated as expected.

Okay, so far so good.

However, when I print the Navigation Log an .apl file is not created anywhere.

Hmmm --- this IS the Navigation Log selected by the "Reports" isn't it? Can you make a note of what report options you've got set -- with the Navigation Log displayed on screen, right click. In the menu which items are ticked? Then click on 'Optional Blocks'. Which items are ticked there?

There may be some dependency on the formatting. I've not heard from anyone else with a problem, but just in case, try setting the same options as I have -- select "Expanded Log" and "Medium" in the first right-click menu, and the ALL of the optional blocks (not "Hide All").

If still no joy please send me your FStarRC ini file. In the worst case I shall ask you to edit it to turn on a Logging facility.

Pete

Link to post
Share on other sites
Guest hsors

Exactly the same problem on my side and I suspected it could be (?) a problem specific to version 8.51 of FliteStar. The FStar 1.82 documentation indicates Pete tested the program with FliteStar versions 8.1 up to 8.5. Of course I don't know what significative changes have been implemented in 8.51 but further testing could help. Let me know if I can be of further help

Hervé

Link to post
Share on other sites
Guest hsors

Exactly the same problem on my side and I suspected it could be (?) a problem specific to version 8.51 of FliteStar. The FStar 1.82 documentation indicates Pete tested the program with FliteStar versions 8.1 up to 8.5. Of course I don't know what significative changes have been implemented in 8.51 but further testing could help. Let me know if I can be of further help

Hervé

Link to post
Share on other sites
Exactly the same problem on my side and I suspected it could be (?) a problem specific to version 8.51 of FliteStar. The FStar 1.82 documentation indicates Pete tested the program with FliteStar versions 8.1 up to 8.5. Of course I don't know what significative changes have been implemented in 8.51 but further testing could help. Let me know if I can be of further help

The version of FliteStar (actually FliteMap) I have was purported to be 8.51 (the update was received only a few weeks ago), but the Help-About details say it is "Version 8.5 (Build 5204)". FStarRC 1.82 is working fine with it both under Win98SE and (for the first time) in Windows XP.

Please check your Help-About details and let me know.

I know of at least two other users who are using 8.51 + FStarRC 1.82 with no problems -- the only problem previously reported turned out to be due to wrong/different options chosen for the Nav Log. Unfortunately, FStarRC is very fussy about this -- the only way I could get at the data was to intercept the printing commands to Windows and recognise data according to context, page position, and also bycounting fields to some extent. There's some flexibility in format allowed, but not a lot.

Check my previous reply here and see if the Nav Log options are set like mine. If still no joy, set "Log=Debug" in the INI file and do a short FliteStar session (print the Nav Log of an existing plan). Zip up the resulting Log file (it will be quite big), along with your INI file, and send it to me. Also please FAX the resulting printed Nav Log to +44 1782 379017. Please don't scan it and send it as an image. I'm only on dial-up and such files are far too big!

Regards,

Pete

Link to post
Share on other sites
Exactly the same problem on my side and I suspected it could be (?) a problem specific to version 8.51 of FliteStar. The FStar 1.82 documentation indicates Pete tested the program with FliteStar versions 8.1 up to 8.5. Of course I don't know what significative changes have been implemented in 8.51 but further testing could help. Let me know if I can be of further help

The version of FliteStar (actually FliteMap) I have was purported to be 8.51 (the update was received only a few weeks ago), but the Help-About details say it is "Version 8.5 (Build 5204)". FStarRC 1.82 is working fine with it both under Win98SE and (for the first time) in Windows XP.

Please check your Help-About details and let me know.

I know of at least two other users who are using 8.51 + FStarRC 1.82 with no problems -- the only problem previously reported turned out to be due to wrong/different options chosen for the Nav Log. Unfortunately, FStarRC is very fussy about this -- the only way I could get at the data was to intercept the printing commands to Windows and recognise data according to context, page position, and also bycounting fields to some extent. There's some flexibility in format allowed, but not a lot.

Check my previous reply here and see if the Nav Log options are set like mine. If still no joy, set "Log=Debug" in the INI file and do a short FliteStar session (print the Nav Log of an existing plan). Zip up the resulting Log file (it will be quite big), along with your INI file, and send it to me. Also please FAX the resulting printed Nav Log to +44 1782 379017. Please don't scan it and send it as an image. I'm only on dial-up and such files are far too big!

Regards,

Pete

Link to post
Share on other sites
Guest Crazzzy Canuuuk

Thanks for your prompt replies. I've set the Navigation Log functions exactly as you have suggested, including "Expanded Log", "Medium", "Show All Option Blocks", but still no joy.

I've attached my .ini file and Log file. Please note that the Log file indicates an Error and an access violation with particulars. Perhaps it is of assistance.

I will fax you the printed Navigation Log tomorrow. For your information, the printed log file looks exactly like the usual Flitestar printed Navigation Log I would receive without installing FStarRC v1.82.

Thank you once again.

FstarRC.zip

Link to post
Share on other sites
Guest Crazzzy Canuuuk

Thanks for your prompt replies. I've set the Navigation Log functions exactly as you have suggested, including "Expanded Log", "Medium", "Show All Option Blocks", but still no joy.

I've attached my .ini file and Log file. Please note that the Log file indicates an Error and an access violation with particulars. Perhaps it is of assistance.

I will fax you the printed Navigation Log tomorrow. For your information, the printed log file looks exactly like the usual Flitestar printed Navigation Log I would receive without installing FStarRC v1.82.

Thank you once again.

Link to post
Share on other sites
Please note that the Log file indicates an Error and an access violation with particulars. Perhaps it is of assistance.

Yes, it shows that FStarRC is not able to hook into the printing routines on your system. Are you using Win2000 or NT? I don't think it will work on those. I only just narrowly managed to make it work on XP -- but maybe you have to be the Administrator. The techniques it uses are probably not allowed otherwise. They are the same techniques used for debugging programs and hacking into others, so I think an ordinary XP user might be prevented from doing this.

I will fax you the printed Navigation Log tomorrow.

No don't bother. It is not getting anywhere close to even looking at that. If it cannot hook the routines it can do nothing.

For your information, the printed log file looks exactly like the usual Flitestar printed Navigation Log I would receive without installing FStarRC v1.82.

Of course, because it is not able to hook into it. The only reason I would have wanted to look at the output was if the format of the printing had changed between the version of FliteStar I am using and the one you have. As I said, the method is very sensitive in this regard.

If you can get it working by running on Win98/Me or by using XP as administrator, let me know how please. I've never actually logged into XP as anything but me, so I'm not aware of what's involved. Maybe I need to adjust the FStarRC documentation.

Pete

Link to post
Share on other sites
Please note that the Log file indicates an Error and an access violation with particulars. Perhaps it is of assistance.

Yes, it shows that FStarRC is not able to hook into the printing routines on your system. Are you using Win2000 or NT? I don't think it will work on those. I only just narrowly managed to make it work on XP -- but maybe you have to be the Administrator. The techniques it uses are probably not allowed otherwise. They are the same techniques used for debugging programs and hacking into others, so I think an ordinary XP user might be prevented from doing this.

I will fax you the printed Navigation Log tomorrow.

No don't bother. It is not getting anywhere close to even looking at that. If it cannot hook the routines it can do nothing.

For your information, the printed log file looks exactly like the usual Flitestar printed Navigation Log I would receive without installing FStarRC v1.82.

Of course, because it is not able to hook into it. The only reason I would have wanted to look at the output was if the format of the printing had changed between the version of FliteStar I am using and the one you have. As I said, the method is very sensitive in this regard.

If you can get it working by running on Win98/Me or by using XP as administrator, let me know how please. I've never actually logged into XP as anything but me, so I'm not aware of what's involved. Maybe I need to adjust the FStarRC documentation.

Pete

Link to post
Share on other sites
Guest Crazzzy Canuuuk

My OS is Windows XP Home and I'm logged on as an Administrator. Perhaps this is an XP compatibility problem. You indicated that you had difficulty getting FStarRC to work with your XP. How did you solve it?

Link to post
Share on other sites
Guest Crazzzy Canuuuk

My OS is Windows XP Home and I'm logged on as an Administrator. Perhaps this is an XP compatibility problem. You indicated that you had difficulty getting FStarRC to work with your XP. How did you solve it?

Link to post
Share on other sites
My OS is Windows XP Home and I'm logged on as an Administrator. Perhaps this is an XP compatibility problem. You indicated that you had difficulty getting FStarRC to work with your XP. How did you solve it?

Ah .. I owe you, and Herve, an apology. I was getting mixed up. As I stated in the documentation, in the History part describing the change to 1.82, I got it working on Windows 2000, and said there that I hoped it would be fine in WinXP (XP being basically Windows NT 5.1 whereas 2000 was NT 5.0, right? How much difference could there be?).

Well, since doing that and testing it on Windows 2000, I updated that PC to Windows XP. And guess what? FStarRC 1.82 doesn't work on XP. :-(

Sorry. I'll try and look for a solution to this when I can, but it's going to have to wait a few months. I simply must concentrate on getting my stuff sorted out for FS9. Please remind me again in September or so. Apologies for getting your hopes up. If you can dual boot with Win98 then I'd suggest doing that. I actually have this PC with both WinXP Pro and Win2000 Pro on it, and another PC with just Win98.

Regards,

Pete

Link to post
Share on other sites
My OS is Windows XP Home and I'm logged on as an Administrator. Perhaps this is an XP compatibility problem. You indicated that you had difficulty getting FStarRC to work with your XP. How did you solve it?

Ah .. I owe you, and Herve, an apology. I was getting mixed up. As I stated in the documentation, in the History part describing the change to 1.82, I got it working on Windows 2000, and said there that I hoped it would be fine in WinXP (XP being basically Windows NT 5.1 whereas 2000 was NT 5.0, right? How much difference could there be?).

Well, since doing that and testing it on Windows 2000, I updated that PC to Windows XP. And guess what? FStarRC 1.82 doesn't work on XP. :-(

Sorry. I'll try and look for a solution to this when I can, but it's going to have to wait a few months. I simply must concentrate on getting my stuff sorted out for FS9. Please remind me again in September or so. Apologies for getting your hopes up. If you can dual boot with Win98 then I'd suggest doing that. I actually have this PC with both WinXP Pro and Win2000 Pro on it, and another PC with just Win98.

Regards,

Pete

Link to post
Share on other sites
Thanks Pete..we are not in a hurry.

Being naturally curious, I had a quick look this morning to see why FStarRC didn't work on XP. I found and fixed the problem. It was relatively trivial after all. Please look out for FStarRC version 1.83, being released as I type this. Should be on the Schiratti site withon hours, with luck!

Regards,

Pete

Link to post
Share on other sites
Thanks Pete..we are not in a hurry.

Being naturally curious, I had a quick look this morning to see why FStarRC didn't work on XP. I found and fixed the problem. It was relatively trivial after all. Please look out for FStarRC version 1.83, being released as I type this. Should be on the Schiratti site withon hours, with luck!

Regards,

Pete

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.