Jump to content
The simFlight Network Forums

Display problem with AdvDisp


Recommended Posts

When I start AdvDisp (latest version), my FS9 display gets cutoff and "frozen" from the top of the AdvDisp box to the bottom of the screen. This happens whether docked or undocked. The attached screenshot (partial) shows what I mean. This was taken by moving from the cockpit to the spot view. I was in the cockpit of the LDS-767 and then moved to spot view. Sometimes, the cutoff portion is completely black.

I am using FS9.1 and a eVGA GeForce 6800U card (81.95 WHQL driver). I have FS AA off, and card AA at 8X and AF at 16X. I only see this with AdvDisp.

Any suggestions? Thanks.

post-5745-12868928493_thumb.jpg

Link to comment
Share on other sites

When I start AdvDisp (latest version), my FS9 display gets cutoff and "frozen" from the top of the AdvDisp box to the bottom of the screen. This happens whether docked or undocked. The attached screenshot (partial) shows what I mean.

Sorry, I don't seem to see anything odd. What am I supposed to see there?

Any suggestions? Thanks.

I'm really not understanding what you mean by "frozen". Certainly, the AdvDisplay winow is a separate window from anything in FS, and its operation and presence should never have any effect whatsoever on anything else in FS. If it does, then there is likely a video driver bug -- the video driver is rendering things wrongly.

Perhaps I could be more specific if I knew what you meant by "frozen".

BTW, although you say "latest version", there's really been no significant change in Advdisplay for many years. The last major change was to allow "locking", several years ago, which locks the window to a particular video position regardless of FS's displays.

The window is actually not part of FS at all, it isn't a "child window" of FS and has no actual relationship with FS's displays. Even in "docked" mode it is only the position on screen which is computed based on the position of the panel part to which it is docked -- just like "locked" but with a programmed relation. In its initial window more, with the title bar, as per your illustration, it is just another Windows window.

I'm afraid, if there is a problem with the display rendering, you will need to look at the video driver or FS's own video settings. Maybe one of the options in FS itself will help, like "render to texture" -- try switching that off if on or vice versa.

Sorry, I know I'm not being very helpful, but (a) I don't understand what you are reporting, and (b) it sounds like something to do with video rendition on screen, which I'm afraid is totally out of my hands.

Regards,

Pete

Link to comment
Share on other sites

What you are seeing is that although I had switched to full screen "spot view", the cockpit view was still visible from the top of the AdvDisp box to the bottom of the screen -- that is what I meant by freezing.

After some more experimenting, it seems that running my video card on AA 8xS is the culprit -- the AF does not seem to matter.

As far as "latest version" goes, I was just indicating that I was using AdvDisp 2.14 -- I have backed up versions all the way from 1.97 to 2.14 -- I guess your comment that it has not changed is a little confusing -- why we have new version numbers available every few months?

Thanks for your help.

Best regards.

Link to comment
Share on other sites

After some more experimenting, it seems that running my video card on AA 8xS is the culprit -- the AF does not seem to matter.

Ah .. glad you found the solution. Thanks for telling me.

As far as "latest version" goes, I was just indicating that I was using AdvDisp 2.14

Yes, and thank you for confirming that it was that version. If I were to have to investigate a problem I would certainly need that information, so it is always best to state it up front.

I guess your comment that it has not changed is a little confusing -- why we have new version numbers available every few months?

Ah sorry, I see. I didn't mean to confuse or denigrate your confirmation of the version.

The last change was a minor alteration to make it parameter-compatible with a new facility in FSUIPC 3.51 -- a one-line change in the FSUIPC interface AdvDisplay provides. Pretty much all the changes for a long time have been of that ilk.

As I say, I didn't mean to confuse, only illustrate that anything seriously affecting windows would have been evident before now over the years. Even if it was only with FS2004, that's getting on for two and a half years already. With this in mind it seemed much more than likely to be related to video cards, drivers or settings.

Regards,

Pete

Link to comment
Share on other sites

I have also discovered that when my AA is set to 8xS, the "checklist" box in FS9 (pressing F10) also blackens the screen completely from the top of the box to the bottom of the screen. So, it not just something I see with AdvDisp.

It definitely sounds like a faulty video driver. Check it again when an update is available.

Regards,

Pete

Link to comment
Share on other sites

I think it is the driver also, but it shows the same effect with the last few nVidia WHQL drivers. I don't think FS9 is a major concern of nVidia although their release notes do mention it once in a while. Do you have any contacts there?

Not I, sorry. I tend to go backards and find older drivers if I have any nVidia driver problems here. Or, just stick to ones which seem to work well and never upgrade. I only start looking at new drivers when I upgrade PCs or video cards, which is about as often as new FS versions.

Regards,

Pete

Link to comment
Share on other sites

Hi all,

it may be related to the driver but it also may be related to FS. I think - at least on some systems - FS does not like forced anti aliasing. I have problems with anti aliasing as soon as I set it to "on" in the video driver settings and "off" in FS's menu which is what is recommended almost everywhere. The Kneeboard won't work (scrolling) and also some dialogues. But when I set AA to "application dependant" in the driver and to "on" in FS all works as it should.

Regards,

Frank

Link to comment
Share on other sites

Hi,

What monitor resolution do you use, and how would you rate the quality of the "picture" in FS9 with FS9 AA turned on?

I use a Geforce FX 5900 ultra and a Samsung 191T flat screen at 1280x1024. Same resolution in Windows and FS. The picture quality is fine for me but I must admit I'm not so much into stunning screenshots but more into flying :wink: . From a grafical point of view - yes the AA could be improved.

Regards,

Frank

Link to comment
Share on other sites

After reading everyone's comments and links, I went back to nVidia driver 71.89 WHQL. There may be later ones that perform well but I had good experience with this one when it was new. I now have no problems using AA 8xS with AdvDisp and FS9 performs well, also.

I will stick with 71.89 but continue to test any new drivers that appear -- the latest is 81.95 WHQL.

Thanks to all.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.