Jump to content
The simFlight Network Forums
Sign in to follow this  
Burkhard

Texture_MAX_LOAD

Recommended Posts

Dear friends, now that I could reproduce your effect:

Try the following:

Edit FS9.cfg, typically in your user profiles.

You will find a line.

Texture_bandwidth_mult=xx, with xx=40-60. Increase this, I used 120.

Second, you will find a line

Texture_max_load=1024, increase again, I used 2048.

On this system, any stuttering was wiped away, as smooth as my home systems.

Share this post


Link to post
Share on other sites

Makes a lot of sense after reading this again, from:

http://www.steve-lacey.com/blogarchivesters.shtml

John - By default, the texture manager will upload a maximum number of texture's per frame. This is measured in bytes, and the default is the equivalent of three 256x256 textures with mips.

The 'three' comes from a configuration variable you may not be familar with. This is TextureMaxLoad in the DISPLAY section. The default is three.

This value is multiplied by the TEXTURE_BANDWIDTH_MULT configuration variable and divided by the target framerate only in the case where you have a target framerate set. With 'unlimited', the variable will have no effect. So, you can see that the value is a multiplier, rather than having any specific units.

This means:

Assume, you have texture_bandwidth_mult at 40, and the fps delimiter at 20. Than you can load per frame 2x what texture max load allows. Increasing both values allows for more textures to load, and you have to find the best balance for your system.

Share this post


Link to post
Share on other sites

Further reading, behind the

TEXTURE_BANDWIDTH_MULT=120

you can add another line

TextureMaxLoad=8

3 is the default value, do not change to meaningless values, but 6 or 8 should still be safe.

TEXTURE_BANDWIDTH_MULT is said not to exceed 400.

Share this post


Link to post
Share on other sites

Went back to normal MT2006 with the above settings. Much better than before, slight delays, but the are the knobs to turn we were searching all the time.

Share this post


Link to post
Share on other sites

Interesting that on my home systems texture_bandwidth_mult is 120 resp 200 after stock FS9 install. Is FS9 just not aware of the new grafics adapter series and puts this and maybe other parameters completely stupid?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.