Jump to content
The simFlight Network Forums

Hard drive access stutters


bunchy
 Share

Recommended Posts

Burkhard,

I have MyTraffic 2006 update 2 beta and all seems to be ok.

Much better frame rates, especially at Heathrow with PMDG 747, I'm averaging 13-16fps with 50% traffic. This is ok for my Sys. specs. (Detailed at bottom).

One thing I've noticed though is when I approach airports I get 1 to 3 second stutters as my hard drive bursts into life, I presume because of loading AI aircraft?

This has always happened to me with all versions of MT2006.

I defrag with Diskeeper 9 regularly (No automated defragging in background though!).

I get this problem running FS9 with no other add-ons but yours, and I wonder if there is a fix or work around for it.

My page file is set to 1500MB for max and min and PCI latency set to 032 for my graphics card.

Your help and suggestions are greatly appreciated

Stu.

Sys. Specs:

AMD 3200 32bit

Abit NF7-S Mother board

1GB Corsair 3200 DDR ram

On board sound

120 GIG Sata HD 7200rpm

9800 Pro Graphics 128MB.

Link to comment
Share on other sites

Did you use the first beta, or the one I distributed yesterday? If the first beta, please just overwrite it with the second, that makes a lot of changes concerning registry writes during flight as tested in the New York area, but London isn't so different.

If it remains,

What we can do is try to isolate if this is just a property of FS9 that you get too many aircrafts to load, or if this can be associated with specific aircraft models.

For this test, please do the following:

Temporarily move the folders of all B737,Dash8 and MD80/90 from MyTraffic out of the aircraft folder (maybe to aircraftmods) and repeat the flight. If the sudden disk acces got away than, I would know what to do.

The specific with these aircrafts is that they are still mostly based on the MS aircrafts which I have no sources off, so I have to (am) remaking them completely from scratch, which is a many thousand hour task, but well underway, but not in time for the 40b.

Link to comment
Share on other sites

Thank's for your quick reply, Burkhard.

Just to update you, I am using the 2nd beta and the DXT 1 conversions have all been done.

The performance overall is much, much better than the original release, so I have to say WELL DONE on that. I know you'll cure these stutters in time!

I will follow your advice and report back up in a short while. (Maybe Sunday)

Thank's again,

Stu.

Link to comment
Share on other sites

Burkhard,

I carried out your test, moving the appropriate aircraft folders into aircraft mods. Unfortunately the problem with HD access stutters is still there.

I noticed as I approached RW27L at Heathrow, maybe 2 miles out on final, that the stutters occur when the AI aircraft textures are drawn. I get this also to a lesser extent when aircraft appear in proximity when airborne.

I forgot to mention also that I use GE Pro but I don't think this connected.

Back to you, Burkhard.

Thank's again,

Stu.

Link to comment
Share on other sites

Jaap,

My test flights in and around Heathrow are approx 12:00 Local.

I have coldfronts as a weather theme, clouds are Flight Environment DXT reduced quality for performance.

I have used different aircraft for this test but I suffer the stuttering regardless of which aircraft I use. PMDG 747/737, LevelD 767, Aeroworx B200, default Baron and Cessna, Eaglesoft CitationX.

As a point, it is not just Heathrow that this problem occurs, it is any airport, any time, any aircraft. Obviously, the busier the airport, the longer the stutters.

I've tried KTEB, KFXE, KOPF, MKJS, EGBB, EGKK, EDDF ..... and so on.

I have tried clear skys as well, just to rule out FE textures.

I don't see a long list of users with this problem, so it's probably something unique to my set up.

Good luck in finding the source!

Much appreciated,

Stu.

Sys. Specs:

AMD 3200 32bit

Abit NF7-S Mother board

1GB Corsair 3200 DDR ram

On board sound

120 GIG Sata HD 7200rpm

9800 Pro Graphics 128MB.

Link to comment
Share on other sites

Thanks, Stu, appreciated. Am I to presume you're using today's date?

More questions :-) ; what's your screen's resolution? In FS' display settings, what's your 'Global max texture size' (GMTS) slider set to?

You mentioned the DXT1 conversion helped. Did you run all 3 batchfiles?

Depending on your resolution, setting the GTMS to one notch from the top, should solve the remainder of HD-access 'inconveniencies.' If you have GTMS maxxed-out now and this does it, there might be an aircraft or two which haven't been converted yet. With your help, we might be able to discover which one(s). As you can probably guess, I'm trying to reproduce your scenario(s) as precisely as possible. :-)

Thanks and kind regards

Jaap

Link to comment
Share on other sites

Thank's for your reply, Jaap.

Yes, I'm sorry, you presume right..... todays date is set.

My GMTS was maxed but I'm currently flying the PMDG747 from DNMM to EGLL and I've knocked it back to 'High' setting instead of 'Massive'

Screen res is 1280x1024x32. Boeing, Airbus and Rest batch files have been run to convert to DX1 with no reported errors.

I'm due to arrive at EGLL at 21:00 UTC tonight. So if I have time I'll report findings........ Have to be up early tomorrow, big wedding event to attend!

I'm interested to see if Global max setting fixes the stutters.

Thanks for your continuing help.

Stu.

Link to comment
Share on other sites

No worries, Stu. Looking forward to your results. The only disadvantage with GMTS @ high; it looks slightly less neat once you've landed... :-)

If heavy metal is your main interest (and case you haven't done so already), perhaps uncheck the GA option in FS' AI settings. This could reduce the CPU's workload by another bit.

As far as I would dare to judge and in general, it's also pretty useful to reduce the visibility and cloud draw distances. I don't have any weather programs so I use FS' weather menu for this. FWIW, over here cloud draw is @ 30 and visibility is @ 20 miles max.

128MB cards @ 1280x resolutions plus a lot of FS-goodies can bring 'da thing' to its limits, specially at fairly high AA/AF levels.

Wish you heaps of fun at the wedding. Kind regards

Jaap

Link to comment
Share on other sites

Jaap,

Same old stutters when approaching Heathrow. This time a nice long 3 second stutter just before touchdown on 27R.

As a matter of interest I've tried disabling GA aircraft but it makes no difference.

My cloud draw and visibility is set at 60 miles for both, but as I've mentioned in an earlier post, I still get stutters with clear skies.

I've even terminated NOD32 anti virus out of desperation, still no luck though.

I used to have all of PAI's packages installed but I found they were all or nothing. Say a 30% traffic setting would swamp Heathrow but if you moved to EGBB for instance, maybe just 3 or 4 aircraft depending on time of day.

So although Heathrow dragged my frame rate to its knees, I had no stutters.

MyTraffic 2006 is much better as far as frame rates but these annoying stutters spoil an otherwise pleasant experience.

FYI I disabled traffic and the stutters went away? Maybe someones swapped my HD for a tape drive...... no, they couldn't have, could they?

Am I the only one with the problem?

Thanks for your continued support,

Stu

Link to comment
Share on other sites

Thanks for the infos and feedback, Stu. Hmmm.... A bit puzzled now. Specially because of that 3s stutter.

Now, if you save a situation which guides you onto RW27, are you able to repeatedly reproduce the same happening? If you can reproduce it, does it always happen at exactly the same spot? If it does, please describe that point as well as possible? I.e. distance from airport/RW, heading, AC altitude, etc, etc? Aaaanything which might provide a clue. :-)

Also, presuming you used a 3rd party aircraft, does it also occur with default AC? Last question :-), what's your operating system?

I'll try a couple of approaches into RW27R and see what happens. Have a good time tomorrow and see you on Sunday. Cheers and kind regards

Jaap

Link to comment
Share on other sites

Jaap,

Just a quick reply before the wedding!

OS is XP SP2 with all critical and optional updates to date. This is a clean install, just a month ago.

These stutters are not exclusive to Heathrow. They happen at any airport at any time regardless of aircraft type I am in.

The stutters are more severe at busy airports. I have my traffic slider at 50% but I have tried with it lower at 20%, doing this increases my frame rate but stutters remain. The stutters don't happen consistantly at an exact place.

The stutters are more severe and frequent when flying complex aircraft such as the PMDG737/747 but who flies the default aircraft? No fun there with their fair ground ride pitch sensitivity!

The stutters don't just happen on approach and finals, they happen when I'm in close proximity to the airport as its scenery starts to draw.

Also I get stutters when aircraft appear in my ND TCAS display, although these are only momentary and I can live with those.

Perhaps there is an OS setting that's up to something in the background?

I used to use FSAutostart to strip down services but to be honest, I never saw a dramatic, if a noticeable difference at all in performance.

Thanks for your patience an help, Jaap

Stu

Link to comment
Share on other sites

One thing that comes to my mind is the position of the frame rate delimiter, and the famous entries of parameters to FS9.cfg.

What it looks like is that either due to the aircrafts + AI aircrafts + maybe more the memory of the grafics card is overloaded, or more serious the amount of textures allowed to flow into there is too small, what only can be avoided by a fine tuning of parameters, most important a low setting of the frame rate delimiter.

Link to comment
Share on other sites

Good you mentioned the framerate limiter, Burkhard. Forgot that one! :-)

And thanks for additional infos, Stu. Hope you had a nice wedding. Assuming you're from the UK, is it a custom to marry THAT early!? :-)

Anyway, last night, I tried a couple of approaches into 27R starting from ca 24 miles away (with the stock 737). 'Unfortunately,' no probs.

Currently, I'm a bit puzzled whether we're facing a particular AI-AC @ Heathrow problem, or something hardware/OS or FS-settings related?

Therefore, my next suggestion is as follows to perhaps be able to establish a pattern: Save an approach situation into 27R with the default 737 and fly it (leaving GA off and preferably from at least 20 miles away). When you get that (or multiple) stutter(s), immediately hit the pause button and make notes of the coordinates, altitude etc etc. Then, repeat this a couple of times. Of course, please post your results here.

Plus some more questions! Please excuse me if some of them seem banal, Stu :-)

- If I properly understood, you re-installed the OS about a month ago. May I ask why?

- Can you exclude IRQ sharing? As you probably know, GPUs and sound interfaces shouldn't share IRQs.

- Is your HD partitioned into various partitions? Case it is, please tell us more?

- Are the chipset drivers etc installed?

- Apart from the latency modifications, any other tweaks worth mentioning?

- Could you please post or attach the first portion of your fs9.cfg? Upto the 'Display' section is of interest.

- With regard the computer/case itself, do you have adequate cooling? Do things change when it's slightly cooler outside?

Looking forward to your results and comments. Good luck and kind regards

Jaap

Link to comment
Share on other sites

Hi Guys,

I just wanted to let you know that I'm experiencing the same stutters as Stu. I also have a clean install of XP Pro on my 3.0mhz. I'm using the Nvidia Geforce 7800 gs AGP card with 2 gig of ram. When I'm approaching any airport my sim slows down to a slide show effect. If I turn off traffic, it's 100% better. I'm flying PMDG 737 most of the time. I haven't tested it against the stock aircraft yet.

Ron

Link to comment
Share on other sites

Jaap,

The wedding was brilliant. I drank too much chardonnay and now my head is broken and my liver is the size of a small Pacific Island...... Should my skin be this yellow......?

On to todays business. You've given me a nice project!

Firstly, my frame rate is locked at 22.

I've turned down autogen density to 'Dense'

This appeared to help but I want to make another flight or two with real weather just to see and carry out your required flights also.

In the mean time, in answer to your questions:

- If I properly understood, you re-installed the OS about a month ago. May I ask why?

No real reason, it's something I do every year or so to get rid of accumulated rubbish.

- Can you exclude IRQ sharing? As you probably know, GPUs and sound interfaces shouldn't share IRQs.

Not too clear how to find this info but in the device manager the entries under graphics and sound aren't showing any conflicts.

- Is your HD partitioned into various partitions? Case it is, please tell us more?

No. Just one 120 gig partition.

- Are the chipset drivers etc installed?

Latest Nvidia chipset drivers for my rather old Abit NF7-S MB

ATi 6.5 graphics drivers.

- Apart from the latency modifications, any other tweaks worth mentioning?

Only the infamous cfg tweaks, (see attached)

- Could you please post or attach the first portion of your fs9.cfg? Upto the 'Display' section is of interest.

Tis done!

- With regard the computer/case itself, do you have adequate cooling? Do things change when it's slightly cooler outside?

I have a solid copper and aluminium heat sink with a 12cm fan. CPU temp is generally between 48C and 55C. The room ambient temperature ranges from 22C to 29C dependant on time of day/season.

Thanks for your continuing and brilliant tech support.

Stu

Link to comment
Share on other sites

I don't think my config file was attached:

Here it is.

[PANELS]

IMAGE_QUALITY=1

UNITS_OF_MEASURE=0

QUICKTIPS=1

PANEL_MASKING=1

PANEL_STRETCHING=1

[Weather]

WindshieldPrecipitationEffects=1

MinGustTime=10

MaxGustTime=500

MinGustRampSpeed=1

MaxGustRampSpeed=200

MinVarTime=5

MaxVarTime=50

MinVarRampSpeed=10

MaxVarRampSpeed=75

TurbulenceScale=1.000000

DefaultVisibility=0

DynWx_MedianDewPointSpread=10.000000

DynWx_ProbCloudFormForMedianDewPoint=0.000500

DynWx_MaxDewPointSpread=50.000000

DynWx_ProbCloudFormForMaxDewPoint=0.000125

DynWx_ProbCloudFormForMinDewPoint=0.100000

DynWx_DryTempLapsePer1000Meters=9.000000

DynWx_ProbCloudFormForDryTempLapse=0.000500

DynWx_MoistTempLapsePer1000Meters=3.300000

DynWx_ProbCloudFormForMoistTempLapse=0.040000

DynWx_MaxProbCloudChangePerMinute=0.040000

DynWx_MultiplierForDynamicWeatherLevelMild=0.500000

DynWx_MultiplierForDynamicWeatherLevelNormal=1.000000

DynWx_MultiplierForDynamicWeatherLevelHigh=3.000000

DynWx_MultiplierForDynamicWeatherLevelExtreme=10.000000

DynWx_TempChangePercentageForOvercastClouds=0.750000

DynWx_TempChangePercentageForMinDewPoint=0.700000

DynWx_MaxTempChangePerMinute=0.060000

WeatherServerAddress=fs2k.zone.com

WeatherServerPort=80

WeatherGraphDataInDialog=0

DynamicWeather=0

LOADWEATHER=1

MAX_UNLIMITED_VIS=96560

CLOUD_DRAW_DISTANCE=6

3D_CLOUD_PERCENT=100

DETAILED_CLOUDS=1

CLOUD_COVERAGE_DENSITY=8

DownloadWindsAloft=0

DisableTurbulence=0

CloudsImpostorRingRadius=96000.000000

[iNTERNATIONAL]

ASLAT=2

ASLON=1

MEASURE=0

[MISC]

COM_RATE=7

LOG_TIME=0

FOREIGN_TRANSLATOR=0

LOG_FILE=

[sTARTUP]

DEMO=0

LOADSIM=1

LOADWINDOW=1

SHOW_OPENING_SCREEN=1

STARTUP_DEMO=

[GRAPHICS]

FULL_SCREEN=0

PERFORMANCE_MODE=0

DEF_PERF_MODE=6

TEXT_SCROLL=1

AUTO_LOD=0

DETAIL_TEXTURE=1

WATER_EFFECTS=2

TERRAIN_USE_VECTOR_MAP=1

TERRAIN_USE_VECTOR_OBJECTS=1

EFFECTS_QUALITY=2

GROUND_SHADOWS=1

SMOOTH_VIEW=1

IMAGE_SMOOTHING=1

TEXTURE_MAX_LOAD=1024

COCKPIT_HIGH_LOD=1

AIRCRAFT_SHADOWS=1

LANDING_LIGHTS=1

IMAGE_QUALITY=0

TEXTURE_BLDG=1

TEXTURE_GND=1

TEXTURE_WATER=1

AIRCRAFT_TEXTURE=2

SEE_SELF=1

TEXTURE_QUALITY=3

LOD_TARGET_FPS=14

NUM_LIGHTS=8

[REALISM]

INDASPD=0

PFactor=1.000000

Torque=1.000000

GyroEffect=1.000000

CrashTolerance=1.000000

General=1.000000

UnlimitedFuel=False

TrueAirspeed=False

AutoCoord=False

RealMixture=False

StressDamage=False

GEffect=False

ManualLights=False

GyroDrift=False

CrashWithDyn=False

CrashDetection=0

[CONTROLS]

KBDAIL=64

KBDELEV=64

KBDRUD=64

PAN_RATE=600

[uSERINTERFACE]

MAP_ORIENTATION=2

PAUSE_ON_LOST_FOCUS=0

PROMPT_ON_EXIT=1

SelectFlightLevel=0

SelectFlightTitle=0

PageID=3

OpenATCOnCreate=0

SITUATION=

[sOUND]

SOUND=1

SOUND_FADER1=0.200000

SOUND_FADER2=0.100000

SOUND_FADER3=0.100000

SOUND_FADER4=0.600000

SOUND_FADER5=0.300000

SOUND_FADER6=0.000000

SOUND_QUALITY=2

[DISPLAY.Device.RADEON 9800 SERIES.0]

Mode=1280x1024x32

[DISPLAY]

UPPER_FRAMERATE_LIMIT=21

TEXTURE_BANDWIDTH_MULT=250

[TERRAIN]

TERRAIN_ERROR_FACTOR=96.000000

TERRAIN_MIN_DEM_AREA=10.000000

TERRAIN_MAX_DEM_AREA=100.000000

TERRAIN_MAX_VERTEX_LEVEL=21

TERRAIN_TEXTURE_SIZE_EXP=8

TERRAIN_AUTOGEN_DENSITY=3

TERRAIN_USE_GRADIENT_MAP=1

TERRAIN_EXTENDED_TEXTURES=1

TERRAIN_DEFAULT_RADIUS=9.500000

TERRAIN_EXTENDED_RADIUS=4.500000

TERRAIN_EXTENDED_LEVELS=4

[sCENERY]

IMAGE_COMPLEXITY=5

DYNAMIC_SCENERY=0

DYN_SCN_DENSITY=0

DAWN_DUSK_SMOOTHING=1

SUNGLARE=1

LENSFLARE=0

[AIRtoCONTAINER]

SIM1=Cessna Skylane 182R RG

SIM2=Learjet 45

SIM3=Schweizer 2-32 Sailplane

SIM4=Sopwith Camel

SIM5=Extra 300S

SIM6=Boeing 737-400

[APL]

CACHE_WAV_FILES=1

[TrafficManager]

TrafficDensity=50

IFROnly=0

EnableAirline=1

EnableGeneralAviation=1

[AContain]

ShowLabels=0

ShowUserLabel=0

ShowLabelManufacturer=1

ShowLabelModel=1

ShowLabelTailNumber=0

ShowLabelDistance=1

ShowLabelAltitude=1

ShowLabelAirline=0

ShowLabelAirlineAndFlightNumber=0

ShowLabelFlightPlan=0

ShowLabelContainerId=0

ShowLabelAirspeed=0

ShowLabelHeading=0

LabelDelay=1000

LabelColor=FFFF0000

[sLEW]

MaxLateralRate=40000.000000

MaxVerticalRate=1000.000000

MaxPitchRate=360.000000

MaxBankRate=360.000000

MaxHeadingRate=360.000000

[VirtualCopilot]

VirtualCopilotActive=0

[MAIN]

Location=76,33,724,567

HideMenuNormal=0

HideMenuFullscreen=1

Maximized=0

[MULTIPLAYER]

ALWAYS_SHOW_INITIAL_DIALOG=1

SESSION_NAME=My Session

PLAYER_NAME=Unnamed Pilot

GUARANTEED_MESSAGES=0

MAX_PLAYERS=8

MAX_OBSERVERS=0

TICKS_PER_SYNC=90

PACKETS_PER_SEC=4

COLLISION_SECS=2

FOLLOWING_MULTIPLIER=5

ALLOW_PLANE_MODEL_SEND=0

ALLOW_PLANE_MODEL_RECEIVE=0

ALLOW_TEXTURE_SEND=0

ALLOW_TEXTURE_RECEIVE=0

MAX_SEGMENT_SIZE=100

MAX_SEGMENTS_PER_SEC=1

CONNECTION_TYPE=0

PROTOCOL_SELECTION=0

ALLOW_DESCRIPTIVE_SEND=1

ALLOW_DESCRIPTIVE_RECEIVE=1

AUTOPILOT_LOCK=0

DISTANCE_DISPLAY=0

ADF_TRACK=0

ALLOW_NAME_TAG_DISPLAY=1

CLIENT_CONNECT_USE_CUSTOM_PORT=0

CLIENT_CONNECT_PORT=23456

CLIENT_HOST_USE_CUSTOM_PORT=0

CLIENT_HOST_PORT=23456

HOST_CONNECT_USE_CUSTOM_PORT=0

HOST_CONNECT_PORT=23456

[sIM]

SYSCLOCK=1

[ATC]

AutoOpenAirTrafficWindow=0

UsePilotVoice=0

ShowATCText=0

PilotVoice=1

[FACILITIES]

COUNTRY=

STATE=

CITY=

GTL_BUTTON=6225

[JOYSTICK_MAIN {6631B2A0-0D1C-11DB-8002-444553540000}]

AXIS_EVENT_00=AXIS_AILERONS_SET

AXIS_SCALE_00=64

AXIS_NULL_00=36

AXIS_EVENT_01=AXIS_ELEVATOR_SET

AXIS_SCALE_01=64

AXIS_NULL_01=36

AXIS_EVENT_02=AXIS_THROTTLE_SET

AXIS_SCALE_02=127

AXIS_NULL_02=1

AXIS_EVENT_03=AXIS_MIXTURE_SET

AXIS_SCALE_03=127

AXIS_NULL_03=1

AXIS_EVENT_04=AXIS_PROPELLER_SET

AXIS_SCALE_04=127

AXIS_NULL_04=1

BUTTON_DOWN_EVENT_00=THROTTLE_DECR

BUTTON_DOWN_REPEAT_00=1

BUTTON_DOWN_EVENT_01=SPOILERS_TOGGLE

BUTTON_DOWN_EVENT_02=RUDDER_TRIM_LEFT

BUTTON_DOWN_REPEAT_02=2

BUTTON_DOWN_EVENT_03=RUDDER_TRIM_RIGHT

BUTTON_DOWN_REPEAT_03=2

BUTTON_DOWN_EVENT_04=GEAR_UP

BUTTON_DOWN_EVENT_05=GEAR_DOWN

BUTTON_DOWN_EVENT_06=FLAPS_DECR

BUTTON_DOWN_EVENT_07=FLAPS_INCR

BUTTON_DOWN_EVENT_08=VIEW_MODE

BUTTON_DOWN_EVENT_09=VIEW_MODE_REV

BUTTON_DOWN_EVENT_10=ELEV_TRIM_DN

BUTTON_DOWN_REPEAT_10=2

BUTTON_DOWN_EVENT_11=ELEV_TRIM_UP

BUTTON_DOWN_REPEAT_11=2

POV_MOVE_EVENT_00=PAN_VIEW

POV_MOVE_REPEAT_00=1

[KEYBOARD_MAIN]

SELECT_1=49,8

SELECT_2=50,8

SELECT_3=51,8

SELECT_4=52,8

MINUS=189,8

PLUS=187,8

ZOOM_1X=8,8

SOUND_TOGGLE=81,8

ENGINE=69,8

SIM_RATE=82,8

XPNDR=84,8

SLEW_TOGGLE=89,8

EGT=85,8

SMOKE_TOGGLE=73,8

STROBES_TOGGLE=79,8

PAUSE_TOGGLE=80,8

ATC=192,8

ADF=65,8

VIEW_MODE=83,8

HEADING_GYRO_SET=68,8

DME=70,8

GEAR_TOGGLE=71,8

ANTI_ICE_TOGGLE=72,8

JET_STARTER=74,8

JOYSTICK_CALIBRATE=75,10

ALL_LIGHTS_TOGGLE=76,8

SITUATION_SAVE=186,8

VIEW_WINDOW_TO_FRONT=222,8

AP_MASTER=90,8

FREQUENCY_SWAP=88,8

COM_RADIO=67,8

VOR_OBS=86,8

BAROMETRIC=66,8

NAV_RADIO=78,8

MAGNETO=77,8

BRAKES=190,8

SPOILERS_TOGGLE=191,8

SITUATION_RESET=186,10

FLAPS_UP=116,8

THROTTLE_FULL=115,8

THROTTLE_INCR_SMALL=114,8

THROTTLE_DECR=113,8

FLAPS_DOWN=119,8

THROTTLE_CUT=112,8

VIEW=111,8

ELEV_TRIM_DN=36,8

ELEV_DOWN=38,8

INCREASE_THROTTLE=33,8

AILERONS_LEFT=37,8

CENTER_AILER_RUDDER=12,8

AILERONS_RIGHT=39,8

ELEV_TRIM_UP=35,8

ELEV_UP=40,8

DECREASE_THROTTLE=34,8

VIEW_FORWARD=38,41

VIEW_FORWARD_RIGHT=33,41

VIEW_RIGHT=39,41

VIEW_REAR_RIGHT=34,41

VIEW_REAR=40,41

VIEW_REAR_LEFT=35,41

VIEW_LEFT=37,41

VIEW_FORWARD_LEFT=36,41

VIEW_DOWN=12,41

RUDDER_LEFT=45,8

RUDDER_RIGHT=135,8

BRAKES_LEFT=122,8

BRAKES_RIGHT=123,8

AP_ATT_HOLD=84,10

AP_LOC_HOLD=79,10

AP_APR_HOLD=65,10

AP_HDG_HOLD=72,10

AP_ALT_HOLD=90,10

AP_WING_LEVELER=86,10

AP_BC_HOLD=66,10

AP_NAV1_HOLD=78,10

EXIT=67,10

ABORT=3,10

READOUTS_FLIGHT=90,9

PANEL_TOGGLE=219,9

VIEW_MODE_REV=83,9

PANEL_LIGHTS_TOGGLE=76,9

LANDING_LIGHTS_TOGGLE=76,10

PARKING_BRAKES=190,10

MINUS_SHIFT=189,9

PLUS_SHIFT=187,9

FLAPS_INCR=118,8

FLAPS_DECR=117,8

PROP_PITCH_LO=115,10

PROP_PITCH_INCR_SMALL=114,10

PROP_PITCH_DECR=113,10

PROP_PITCH_HI=112,10

MIXTURE_RICH=115,11

MIXTURE_INCR_SMALL=114,11

MIXTURE_DECR=113,11

MIXTURE_LEAN=112,11

SCRIPT_EVENT_1=219,10

SCRIPT_EVENT_2=221,10

YAW_DAMPER_TOGGLE=68,10

CENTER_NT361_CHECK=57,11

CLOSE_VIEW=221,8

NEW_VIEW=219,8

NEW_MAP=221,9

NEXT_VIEW=9,10

PREV_VIEW=9,11

VIEW_TYPE=83,10

VIEW_TYPE_REV=83,11

RADIO_VOR1_IDENT_TOGGLE=49,10

RADIO_VOR2_IDENT_TOGGLE=50,10

RADIO_DME1_IDENT_TOGGLE=52,10

RADIO_ADF_IDENT_TOGGLE=53,10

GEAR_PUMP=71,10

SPOILERS_ARM_TOGGLE=191,9

PITOT_HEAT_TOGGLE=72,9

AP_AIRSPEED_HOLD=82,10

AUTO_THROTTLE_ARM=82,9

AUTO_THROTTLE_TO_GA=71,11

LANDING_LIGHT_UP=38,11

LANDING_LIGHT_DOWN=40,11

LANDING_LIGHT_LEFT=37,11

LANDING_LIGHT_RIGHT=39,11

LANDING_LIGHT_HOME=12,11

PAN_RESET=46,9

KNEEBOARD_VIEW=121,8

MP_PLAYER_CYCLE=84,11

MP_PLAYER_SNAP=70,11

MP_GO_OBSERVER=79,11

MP_CHAT=221,11

MP_ACTIVATE_CHAT=13,8

PANEL_1=49,9

PANEL_2=50,9

PANEL_3=51,9

PANEL_4=52,9

PANEL_5=53,9

PANEL_6=54,9

PANEL_7=55,9

PANEL_8=56,9

PANEL_9=57,9

AP_MACH_HOLD=77,10

VIEW_FORWARD_UP=38,42

VIEW_FORWARD_RIGHT_UP=33,42

VIEW_REAR_RIGHT_UP=34,42

VIEW_REAR_UP=40,42

VIEW_REAR_LEFT_UP=35,42

VIEW_FORWARD_LEFT_UP=36,42

VIEW_UP=12,42

INVOKE_HELP=191,10

TOGGLE_AIRCRAFT_LABELS=76,11

ENGINE_AUTO_START=69,10

INC_COWL_FLAPS=86,11

DEC_COWL_FLAPS=67,11

USER_INTERRUPT=27,8

AILERON_TRIM_LEFT=37,10

AILERON_TRIM_RIGHT=39,10

RUDDER_TRIM_LEFT=45,10

RUDDER_TRIM_RIGHT=135,10

TOGGLE_FLIGHT_DIRECTOR=70,10

TOGGLE_AFTERBURNER=115,9

TOGGLE_MASTER_BATTERY_ALTERNATOR=77,9

TOGGLE_AIRCRAFT_EXIT=69,9

PANEL_HUD_TOGGLE=87,8

SNAP_TO_PANEL=45,41

MARKER_SOUND_TOGGLE=51,10

TOGGLE_WATER_RUDDER=87,9

TOGGLE_PUSHBACK=80,9

KEY_CHASE_VIEW_NEXT=87,10

KEY_CHASE_VIEW_PREV=87,11

HEADING_BUG_SELECT=72,11

ALTITUDE_BUG_SELECT=90,11

CHASE_VIEW_TOGGLE=81,10

EYEPOINT_UP=13,9

EYEPOINT_DOWN=8,9

EYEPOINT_RIGHT=13,11

EYEPOINT_LEFT=8,11

EYEPOINT_FORWARD=8,10

EYEPOINT_BACK=13,10

EYEPOINT_RESET=32,8

AIRSPEED_BUG_SELECT=82,11

TOGGLE_TAILWHEEL_LOCK=71,9

ROTOR_BRAKE=66,9

ROTOR_CLUTCH_SWITCH_TOGGLE=190,9

ROTOR_GOV_SWITCH_TOGGLE=188,9

VIRTUAL_COPILOT_TOGGLE=88,11

VIRTUAL_COPILOT_ACTION=88,10

[KEYBOARD_SLEW]

SLEW_TOGGLE=89,8

SLEW_ALTIT_UP_FAST=115,8

SLEW_ALTIT_UP_SLOW=114,8

SLEW_ALTIT_FREEZE=113,8

SLEW_ALTIT_DN_FAST=112,8

SLEW_ALTIT_PLUS=81,8

SLEW_ALTIT_MINUS=65,8

SLEW_PITCH_DN_FAST=119,8

SLEW_PITCH_DN_SLOW=118,8

SLEW_PITCH_FREEZE=117,8

SLEW_PITCH_UP_FAST=116,8

SLEW_PITCH_PLUS=57,8

SLEW_PITCH_MINUS=48,8

READOUTS_SLEW=90,9

SLEW_BANK_MINUS=36,8

SLEW_AHEAD_PLUS=38,8

SLEW_BANK_PLUS=33,8

SLEW_LEFT=37,8

SLEW_FREEZE=12,8

SLEW_RIGHT=39,8

SLEW_HEADING_MINUS=35,8

SLEW_AHEAD_MINUS=40,8

SLEW_HEADING_PLUS=34,8

SLEW_RESET=32,8

TOGGLE_AIRCRAFT_LABELS=76,11

EYEPOINT_UP=13,9

EYEPOINT_DOWN=8,9

EYEPOINT_RIGHT=13,11

EYEPOINT_LEFT=8,11

EYEPOINT_FORWARD=8,10

EYEPOINT_BACK=13,10

Stu.

Link to comment
Share on other sites

You might vary the Texture_bandwidth_mult parameter to 50,100,150,200

According to a blog by Mike Gilbert from MS, a value of this that is too low or too high can introduce stutters - this depends highly on graphics adapter and driver version.

I have a GeForce 6600GT on an Athlon64 3200+, and with 100% traffic at EGLL with 40bbeta2 and textures converted to DXT1 never get framerates below 22, so I have my delimter set to 19 and things are really smooth. With a delimiter at 25, I get stutters, but I ordered that. By the way, without any AI traffic I get 23 fps.

Link to comment
Share on other sites

Burkhard,

Good advice.

I think I have an answer to my probs. In an earlier post, Jaap advised me to carry out an experiment with a default B737 into EGLL RW27 (left in my case) with GA traffic turned off.

This I did but leaving AI slider to 50%, clear skies and autogen at dense setting. There were no stutters! Hooray!

I did the same test with the PMDG 747.... No stutters again. Brilliant!

Then the same test again with ActiveSky 6 real weather. Still no stutters!

When I re-introduced the GA traffic the stutters came back. So why would GA have such an impact on performance?

I can live without GA for a bit, so no worries.

I hope this helps point you to a possible fix?

If there's any other tests/checks you need me to do, I'm happy to do them.

Thank's again for all your help and attention.

Stu.

Link to comment
Share on other sites

Well, my liver and head are probably a bit like yours today!

And first of all, Stu, please allow me to thank you for your endurance and patience as well. Looks like we're starting to see some results. :-)

>>When I re-introduced the GA traffic the stutters came back. So why would GA have such an impact on performance?<<

Good question! Could be anything from certain AC themselves or the added system load when both IFR and GA are active.

We've found there's a critical limit/level of ca 4-500 AI-movements at which our FlyTendos become more prone to produce certain anomalies. As you probably know, AI-movements can be looked at with Traffic Explorer(TE) by keying Alt+T+T+E. Please note, TE itself can induce stutters when the table gets updated with many movements.

Right now, it would be interesting to learn, whether an inversion of the situation brings back those infamous stutters or not? So, what happens if you de-activate IFR, only have GA traffic and repeat your approach onto RW27?

Some comments on your hardware/software/fs9.cfg feedback:

- HD partioned or not? Your choice to have everything in one large partition is the best one (IMO). This question was to assure we can exclude HD-head thrashing issues (which occur when the HD-heads read/write data in different physical locations on the same drive).

- System temps? IMHO, it's highly important to have constant temps in our boxes. How high or low doesn't really matter, as long as they're constant. HDs i.e., go into auto-recalibration mode when temps fluctuate. The temps themselves 'only' have an influence on the lifetime of a component.

- If you haven't experimented with your GPU's 'Sideband Addressing' setting, it might be worth a try? The following mention is personal; I'm not a big fan of reducing the GPU's latency. If, I wouldn't go under 50% of the default value. AFAI would dare to judge, the GPU needs enough cycles to display 'da thing.' Perhaps also try variations of the Bandwidth_Multi according to Burkhard's comments?

- Case you don't use 19m mesh, it might worth a try to set the TERRAIN_MAX_VERTEX_LEVEL=21 to 20?

- If memory isn't failing - could well be the case today! :-) - adding Panel_As_Texture=0 in your [Display] section can help.

@ Ron, welcome aboard! Perhaps some ideas in this thread can help localize the troubles on your end too? Unfortunately, 'I'm facing troubles' is a bit too broad to obtain clues. Please feel free to provide more details: I.e the location of those troubles plus as many system details as possible. Since your system is comparable to Stu's, it would be interesting to learn whether you can produce similar results? Thanks for chiming in.

Good luck and kind regards, everybody

Jaap

Link to comment
Share on other sites

Please, if you could confirm the problems are associated with GA traffic arround you, I would know were to work in the next months... I could even go as first instance to produce a list of GA aircrafts that are of comparable technical standard to the new generation of airliners, and some that might be candidates for a complete rebuild with 10 times the effort of the first generation. EGLL hasn't many GA aircrafts, but there will be places around.

Link to comment
Share on other sites

Thanks for the good advise Jaap :) I'm going to busy trying out several things now. I'm going to start with the conversion tools and go from there.

I will be posting my results as I will be using all the tools to compare performance. Hopefully it will be of some value for future releases.

Cheers, Ron

Link to comment
Share on other sites

Burkhard,

I'm hoping to carry out Jaap's experiment proposals tonight.

At work at the moment.... looking forward to my 3 hour drive back to the Welsh Borders!

If I get them completed in time, I'll report back later... maybe tomorrow though.

Thanks again,

Stu.

Link to comment
Share on other sites

Ok Jaap, here's my findings.

Aircraft: PMDG747. No 3d cockpit.

Route: EGLL 27L - CPT - WCO - BNN - LAM - 27L EGLL

Altitude: 10000

Real Weather Metar: EGLL 311820Z 220/14KT 9999 VCSH FEW039 20/12 Q1008.

The weather is a little heavier on my system this test and I'm allowing for the small stutter I get if weather updates during my flight.

Texture_Bandwidth_Multi=100

Panel_As_Texture=0 (Line added)

Autogen put back to 'very dense'

FPS locked at 20

AI at 50%, No GA test result:

Flight was smooth, average FPS 14-16. One stutter noticed leaving WCO for BNN but small enough not to worry me.

Approach and landing also OK, with a lower FPS on final (11 FPS) this is due, I know, to EGLL being a more detailed airport anyway plus the weather. FYI, I notice a FPS drop on final with zero traffic, so it is normal.

AI at 50% Just GA no Airlines test result:

FPS was higher during take off (18 FPS) but no visible GA at EGLL anyway.

Once airborne everything still ok, FPS at 19.9.

Heading to BNN, noticed a more severe stutter, maybe 1.5 secs long. This is quite close to Stapleford Airfield.

Again turning from LAM on to final intercept course, another very long stutter. I do appreciate, however, that London City's autogen is also being drawn at this point..... ( Not noticeable in first test, though?)

Final and landing were stutter free.

I hope this is of use and interest to you both, Jaap and Burkhard.

May the force be with you and THANK'S,

Stu

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.