Jump to content
The simFlight Network Forums

4.04 Install failure


RickY
 Share

Recommended Posts

Installation fails with the following in the on-screen log:

Looking in registry for FSX install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0

Parameter"SetupPath"

SetupPath="C:\Games\FSX"

Checking version of FSX.EXE:

Couldn't obtain Version Info! Asking user to find FSX.EXE ...

User identified path:

"C:\Games\FSX"

Checking version of FSX.EXE:

... Version 10.0.60905.0 (Need 10.0.60905.0)

Checking compatibility with installed SimConnect:

... Okay, Probe Manifest matches an installed SimConnect module

Checking if there's already a version of FSUIPC4 installed in:

C:\Games\Modules\FSUIPC4.DLL

... No previous valid version found.

Error 3 reported creating Modules folder: "The system cannot find the path specified. "

Failed to place FSUIPC4.DLL into folder as "C:\Games\Modules\FSU\PC4.DLL"

Error 3 reported ("The system cannot find the path specified. ")

All paths are accurate but perhaps the installer is confused by the \FSX folder name (C:\Games\FSX\FSX.exe is not being located)? When I put a copy of FSX.exe in the C:\Games folder, the install goes to completion error free and the files are in C:\Games\Modules as might be expected. Odd one....

Rick

Link to comment
Share on other sites

Couldn't obtain Version Info! Asking user to find FSX.EXE ...

User identified path:

"C:\Games\FSX"

Checking version of FSX.EXE:

... Version 10.0.60905.0 (Need 10.0.60905.0)

Have you moved FSX after installing it, or re-installed Windows, or rolled back the Registry at all? Otherwise I don't understand why your Registry doesn't have the "SetupPath" entry for FSX, pointing to any folder at all.

Checking if there's already a version of FSUIPC4 installed in:

C:\Games\Modules\FSUIPC4.DLL

Hmm. Yes, that's odd -- it seems to have lost the FSX path from the constructed final path. I'll check that here. It was certainly doing it correctly on an earlier version. It is difficult to re-test all the combinations, especially when many of them do require an incorrect FSX installation.

All paths are accurate but perhaps the installer is confused by the \FSX folder name (C:\Games\FSX\FSX.exe is not being located)?

The main problem is that the SetupPath isn't in your Registry, or it isn't where it might be expected. The installer uses that to locate FSX correctly. If you are familiar with RegEdit for looking at and editing the Registry I can tell you where to look and maybe you can tell me what's in your Registry relating to FSX so I can understand why it is wrong.

Meanwhile, I'll look at the Installer itself to see what it dropped the FSX part of the path. But it'll be tomorrow (Wednesday) now.

You should be able to simply move that Modules folder into the main FSX folder (drag and drop in Explorer) to get you going for now, but please let me know about the Registry and how you may have got FSX into this state, please.

Regards

Pete

Link to comment
Share on other sites

The Registry path to FSX is indeed as indicated in the log and as it has been without any changes since first installed: SetupPath C:\Games\FSX. Unlike earlier versions of your installer, this one seems to be dropping one of the "FSX" along the way and is looking in C:\Games for FSX.exe instead. I suppose I could have chosen a more unique path when I first installed but I am reluctant to "break" things now.

I do not regard this as a serious issue now that I have discovered (from your informative install log) what to do to work around it. Yes, I had done as you suggest and merely moved the installed files into the correct \Games\FSX\Modules folder and all is well again. The entry in DLL.xml remains correct regardless. I just thought I would report it in case anyone else stumbled across the anomaly.

Rick

Link to comment
Share on other sites

The Registry path to FSX is indeed as indicated in the log and as it has been without any changes since first installed: SetupPath C:\Games\FSX. Unlike earlier versions of your installer, this one seems to be dropping one of the "FSX" along the way and is looking in C:\Games for FSX.exe instead.

Yes, thanks. I see what it is doing, but I don't know why yet -- it isn't consistent. That is what is so puzzling. I do see what it is doing, but I need to understand why it is behaving differently here.

I suppose I could have chosen a more unique path when I first installed but I am reluctant to "break" things now.

No, I don't want you to change anything, only confirm that the Installer was reading the SetupPath correctly, which you've done.

I'm going to temporarily change my SetupPath to match and trace through the code path. I'm sure I'll have it fixed in the morning.

Thanks!

Pete

Link to comment
Share on other sites

I just thought I would report it in case anyone else stumbled across the anomaly.

Thanks very much to you, I found it and fixed it. I'll work on releasing 4.05 tomorrow, as I feel this is serious enough to warrant an update. The cause appears to be simple, but quite tricky to identify. In all my FSX installations (and I've actually tried one again to cross-check), the path which gets put into the Registry is

SetupPath="......"

i.e. the correct path, but ending in a '\' character. In your case:

C:\Games\FSX\

would have worked okay. The omission of the expected final '\' causes the derivation of the other pathnames from this root to go wrong. I've now changed the code so that it works happily with or without that final '\' character. There are some other changes I've been making, in FSUIPC4.DLL itself, which I need to test, then I'll release 4.05. It may be Thursday or Friday by then.

Thanks again for reporting this.

Regards

Pete

Link to comment
Share on other sites

Thanks for your quick solution, Pete. The absent trailing backslash got me wondering why mine was different. I can only suspect that my Registry path entry was modified by some other installer not long before 4.04 was released (earlier installs completed without incident). I shall attempt to determine which one and pass that on to its author.

Regards,

Rick

Link to comment
Share on other sites

Thanks for your quick solution, Pete. The absent trailing backslash got me wondering why mine was different. I can only suspect that my Registry path entry was modified by some other installer not long before 4.04 was released (earlier installs completed without incident). I shall attempt to determine which one and pass that on to its author.

I wouldn't spend too much time on that. It may simply depend upon how you edit the path when you are telling FSX where to install. I've not really experimented with that part. In any case, it is a valid enough path with or without the trailing '\' character, so it isn't a bug anywhere else, only in my installer.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.