Jump to content

java.exe not accredited


Recommended Posts

Pete,

I developed an app using the Java SDK and it run beautifully using FSUIPC ver. 3.7.4. However, I need to install it on a target platform that is using ver. 3.6.5. When I run my application using this older version of FSUIPC, I get the following log file. I suppose the easy answer it to get the latest version. I am not sure if the owner of the target platform will be ok with that. They are using WideFS and Project Magenta. Are there any issues that I would or could encounter with a more current version of FSUIPC? Is there anything I can do to get my app running with this older version of FSUIPC?

********* FSUIPC, Version 3.65 by Pete Dowson *********

Running inside FS2004 (FS9.1 CONTROLS.DLL, FS9.1 WEATHER.DLL)

User Name=""

User Addr=""

FSUIPC not user registered

WIDEFS not user registered, or expired

Module base=61000000

ClassOptions: UIPCMAIN=FF7F, FS98MAIN=FF7F, FS2KMAIN=FF5E

WeatherOptions(Orig)=0000B027[0000B027]

InitDelay: 0 seconds

WeatherReadInterval=4

LogOptions=00000001

DebugStatus=0

328 System time = 13:33:18

343 C:\Program Files\Microsoft Games\Flight Simulator 9\

343 System time = 13:33:18, FS2004 time = 12:00:00 (00:00Z)

734 FLIGHTS\OTHER\FLTSIM.flt

734 AIRCRAFT\c172\Cessna172SP.air

1281 Client Application: "java" (Id=4000)

1281 C:\fsdis\Java\jdk1.5.0_11\bin\java.exe

1297 Product="Java 2 Platform Standard Edition 5.0 U11"

1297 Company="Sun Microsystems, Inc."

1390 Illegal read attempt: offset 0560, size 8 [P4000]

1390Program or module not accredited for use with this unregistered FSUIPC

Link to comment
Share on other sites

I developed an app using the Java SDK and it run beautifully using FSUIPC ver. 3.7.4. However, I need to install it on a target platform that is using ver. 3.6.5.

Sorry. Just replace 3.65 with 3.74. I cannot and will not support old versions.

Are there any issues that I would or could encounter with a more current version of FSUIPC?

Yes, terrible things like bugs being fixed, things working better, support available!

ALWAYS use the latest versions!

Is there anything I can do to get my app running with this older version of FSUIPC?

Yes. Tell your user to put his hand in his pocket and pay for an FSUIPC user registration. ;-)

Pete

Link to comment
Share on other sites

Pete,

If I update to 3.7.4 will I also need to update the version of WideFS? The target

currently has WideServer 6.65 and WideClient 6.65. I agree with the ALWAYS

use the latest version philosophy, I just don't want to force my customer down

a path that they don't need to follow.

I don't know much about WideFS and Project Magenta. The app I wrote for this

customer just sniffs the state data of the FlightSim aircraft and turns that into a

DIS PDU so that FlightSim can play in a distributed simulation environment.

So, I don't want to force my customer to do anything that could have negative

effects. I am just trying to understand the issues that may exist if I go down this

road. For instance......

If they upgrade to a newer version of WideFS, will that necessitate the need to

make some change in Project Magenta?

Keith Holt

Link to comment
Share on other sites

If I update to 3.7.4 will I also need to update the version of WideFS? The target currently has WideServer 6.65 and WideClient 6.65.

It isn't mandatory, but a good idea if they want better performance, fewer bugs, and any support.

If they upgrade to a newer version of WideFS, will that necessitate the need to make some change in Project Magenta?

No. My game is compatibility. That's what started all this stuff off in the first place.

I suppose he's using ages old versions of Project Magenta modules too! :-(

Pete

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.