Jump to content
The simFlight Network Forums
Ropipo

FSX.exe version with FSUIPC installation

Recommended Posts

Pete,

I installed FSX Deluxe. I installed FSX-SP1-ENU. I downloaded FSUIPC4 4.16 which creates a Zip file FSUIPC4-4062.

When I try to execute the extract Install FSUIPC4.exe this file it gives these messages:

>>

Your installation is not suitable for this version of FSUIPC. You may need to install an update from Microsoft.

Checking version of FSX.exe:

...Version 10.0.61355.0 (Need 10.0.60905.0)

<<

I don't understand. Looking at the version numbers it seems that my version is higher than the one needed.

What must I do ? :?: :?: :?:

Share this post


Link to post
Share on other sites

I installed FSX Deluxe. I installed FSX-SP1-ENU. I downloaded FSUIPC4 4.16 which creates a Zip file FSUIPC4-4062.

Sorry, I don't understand. Nothing of mine ever creates a ZIP file. What is this "FSUIPC4-4062"?

Inside the FSUIPC4.ZIP you will find an Installer ("Install FSUIPC4.exe"). Just run that, and it will install FSUIPC4. If there are any problems in that process, all the information I need will be found in athe Log, which will be installed in the FSX Modules folder if it gets that far, or which you can save using the Menu option on the Window actually displayed.

When I try to execute the extract Install FSUIPC4.exe this file it gives these messages:

Your installation is not suitable for this version of FSUIPC. You may need to install an update from Microsoft.

Show me the Install log please. That contains the information I need. That is what it is for, as explained in the documentation.

Pete

Share this post


Link to post
Share on other sites

Pete,

I deleted my FSUIPC entries and started all over again (download, install) and now it worked.

I am TRYING to pay the combo FSUIPC and WideFS but that is confusing on the Simmarket site. I need to look into that with less stress on me.

Tanks :D

Share this post


Link to post
Share on other sites

I am TRYING to pay the combo FSUIPC and WideFS but that is confusing on the Simmarket site.

I thought it was just an option on EITHER the FSUIPC4 page, OR the WideFS7 page. You should only use one of the pages to pay, and select the bundle option. I've not heard of anyone else getting confused?

Regards

Pete

Share this post


Link to post
Share on other sites

Pete,

After having a cocktail and supper I went back to the site. Then I understood the system.

100 % clear it is not but surely less confusing than before taking a break.

I am getting a bit saturated with my PC and problems that I brought on myself.

Now I need to send my NVIDIA 8800GTS to the supplier for repair. Well that will give me a week to take some rest ! :roll:

Share this post


Link to post
Share on other sites

I am getting that error trying to install FSUIPC4 in to FSX as well

Here is my log

Installer for FSUIPC4.DLL version 4.16

Looking in registry for FSX install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0

Parameter"SetupPath"

SetupPath="C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\"

Checking version of FSX.EXE:

... Version 10.0.61355.0 (Need at least 10.0.60905.0)

Checking compatibility with installed SimConnect:

... Probe Manifest fails to match base SimConnect needed to load FSUIPC4!

Found later build SimConnect 61234 (SP1 May07)

Regards

Mark

Share this post


Link to post
Share on other sites
I am getting that error trying to install FSUIPC4 in to FSX as well

... Probe Manifest fails to match base SimConnect needed to load FSUIPC4!

Found later build SimConnect 61234 (SP1 May07)

As it says, the version of SimConnect needed to load FSUIPC4, which should have been installed from the original FSX DVDs, is either not there at all or not installed correctly. Please see the FSX Help announcement at the top of this Forum for instructions on repairing it.

Regards

Pete

Share this post


Link to post
Share on other sites

Hi i'm having a problem with the FSUIPC installation the error is this one:

Version 10.0.61355.0 (Need at least 10.0.60905.0)

Checking compatibility with installed SimConnect:

... Probe Manifest fails to match a valid base SimConnect needed to load FSUIPC4!

Found later build SimConnect 61242 (SP1 May07)

And i saw the similar one to mine but i couldnt find the FSX Help Announcement

I don't know what to do so if somebody could help me i would be grathfull

Thanks

Share this post


Link to post
Share on other sites
Hi i'm having a problem with the FSUIPC installation the error is this one:

Version 10.0.61355.0 (Need at least 10.0.60905.0)

Checking compatibility with installed SimConnect:

... Probe Manifest fails to match a valid base SimConnect needed to load FSUIPC4!

Found later build SimConnect 61242 (SP1 May07)

The error is only the line I've shown in Red, not the others. Your message title is wrong, there is nothing wrong with the FSX.EXE version, as it clearly says! (61355 is greater than 60905, so it is okay -- it does say "Need at least", and you do have more!)

The error you have (which would also have been shown clearly in an Error Message box, something you missed somehow?) means exactly what it says: the version of SimConnect which is needed to load FSUIPC4 (and most, though not all, other SimConnect applications) is either not installed or is corrupted, as Windows fails to match it to the Installer's checking. It uses a set of "manifests" -- data declaring versions -- to determine what "side-by-side" versions of SimConnect are installed and working. It does this so that it can configure FSUIPC4's run-time capabilities -- more can be done with SP2/Acceleration, less with SP1, and less still with only the original base version. However, the last is always needed and expected, as it is responsible for loading the DLL in order for it to run.

You have SP1 installed and its version of SimConnect is okay, but that is insufficient. You must always have the full SimConnect version which was installed when you installed FSX from the DVD.

So, you have a corrupted installation of FSX. You can either try uninstalling SP1 then FSX itself and re-installing them, or read the "FSX Help" Announcement above which tells you how to repair just the SimConnect installation. However, this is apparently not so easy on Vista (if you are running XP it should be easy enough). You may also first wish to visit Microsoft's own support website and read the FAQs they provide.

And i saw the similar one to mine but i couldnt find the FSX Help Announcement

It is still there, at the top of the Forum, clearly entitled "FSX HELP: Logging or Re-installing SimConnect"

Regards

Pete

Share this post


Link to post
Share on other sites

I find the folders of the simconect and in one of them there is a icon and to open it there isn't anything.

Why do you want to "open" anything? Don't!

What i have to do??

Refer to the FSX Help announcement, above. Follow the instructions provided there for repairing SimConnect.

Pete

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.