Jump to content
The simFlight Network Forums
Burkhard

MyTraffic X Version 5.1b fix requests

Recommended Posts

Hi Jaap: answer's:

- Did you install FSX multiple times? Perhaps different locations?: I first transfered from an ols to a new laptop. Then I unistalled this, and installed directly from the original MSX De Luxe CD's,transfering the old Log and Rewards.

- Where is FSX currently installed? C:\.... : FSX is tnstalled in C: path is: Program Files\Microsoft Games\FSX

- Are you using Vista as administrator? Are you sure you're using the right OS-profile? I am running Vista Ultimate, amd I am the Administrator; Administrator has full controls.

- Does your computer/operating system have different user profiles? How many? 2 users

-Securities for users and trustedinstaller are also in full control.

I'll send you a couple of commands to extract the files we're looking for, but please answer the above questions first.

How about my idea of unistalling MyTraffic form the control panel and do another installation from the MTXV5.1b installer that I have on my desktop?

Thanks for all your efforts and I am sorry to be such a pain in the--------------

Manuco

You did not tell me where are you from and what is your location

Share this post


Link to post
Share on other sites

Hi Manuco,

That all sounds just fine.

Here's what I would suggest assuming you 'unsecurtized' the entire FSX folder:

- Rename or delete the current MyTraffic folder

- Create a copy of the installer in your FSX folder and launch it from there

- Afterwards, add the whole MyTraffic folder as such as a scenery - not the scenery subfolder

If the pointer in the FSX.cfg is correct and there aren't any other traffic.bgls interfering, there should be traffic.

MTX installation verification: The ability to choose a (military) parking spot in ETAR (Rammstein)

If this doesn't work, please tell us the size of your v.5.1b installer in Bytes.

Hope this helps and good luck, Manuco

Jaap

Share this post


Link to post
Share on other sites

Hi Jaap about had it, but something when grong, and had to start all over.Let me tell you what I did:

- Rename or delete the current MyTraffic folder: RENAMED IT.

- Create a copy of the installer in your FSX folder and launch it from there: WORKED FINE AND A COPY OF MYTRAFFIC WAS CREATED ON MY FSX FOLDER. LAUNCHED IT FROM THERE AND THE INSTALLATION RUNNED SMOOTHY.

- Afterwards, add the whole MyTraffic folder as such as a scenery - not the scenery subfolder: THINK THAT HERE I MUST HAVE DONE SOMETHING WRONG BECAUSE IN SPITE THAT I DID ADD MYTRAFFIC TO THE FSX SCENERY,(IT APPEARED ON THE LIST), I THOUGHT THAT THIS WAS DONE TO QUICLY,IT ONLY TOOK ABOUT 5 SECONDS! . ANYHOW WENT TO FSX MAIN SCREEN TO CHOOSE FOR ETAR, AND IT WORKED,I HAD THE F15 PARKED THERE. SO I THOUGHT GREAT!!!!!! THEN WENT TO FREE FLIGHT AND CLICKED ON CHANGE PLANES HOPING THAT I WOULD SEE THE HOLE BUNCH OR AIRPLANES THAT MYTRAFFIC LOADS, AND THERE WHERE NONE. SAME DEFAULT FSX PLANES. PLAID THE GAME AND VISTA FREEZED, FSX WENT CRAZY AND HAD TO UNISTALL THE GAME AND DO ANOTHER INSTALLATION. NOW YOU SAY TO ADD THE MYTRAFFIC FOLDER BUT NOT THE SUBFOLDERS,AND THIS I COULD NOT DO.THERE IS NO WAY TO CHOSSE BECAUSE ONCE YOU CLICK ON ADD AREA FOR MYTRAFFIC,THE HOLE FOLDER IS SELECTED. HOW DO YOU DO THIS,MAYBE THIS WAS THE CAUSE OF THE PROBLEM?

SO JAAP I STARTED ALL OVER, FSX IS WORKING FINE, HAVE MYTRAFFIC IN FSX FOLDER ONCE AGAIN, DOING EXACTLY THE SAME AS YOU RECOMENDED, BUT THIS TIME IT JUST WONT ADD TO THE SCENERY. THIS IS CRAZY MY FRIEND!!!!!!!!!!!!!!!!!!!

The size of MY v.5.1b installer iS 707.325 BYTES AND MYTRAFFIC FOLDER ON FSX IS 5.01GB

APPRECIATE YOUR COMENTS MY FRIEND. GOING TO THE BEACH TODAY HOPING TO SEE YOUR POST ON MY WAY BACK.

REGARDS

MANUCO

Share this post


Link to post
Share on other sites

Hi Manuco,

Thanks, I think there is a little misunderstanding, MyTraffic X doesn't add aircraft to the aircraft menu. It 'only' replaces the default/FSX AI. They're not recommended to fly and do all kinds of funny things.

So, what you described was a successful install. Traffic in ETAR is what we want! ;-)

So, please do what you did again and don't look for aircraft in the aircraft menu.

Please don't forget to set the Vista security settings right.

Kind regards

Jaap

Share this post


Link to post
Share on other sites

Hi Jaap: have MyTraffic once again on FSX scenery. Also have an F/S-18 parcked at ETAR. Does'nt look like a military ramp, but it,s there. Great,finally.

Now tell me a little more and please clarify my misunderstanding. If MyTraffic doesn't add aircraft to the aircraft menu, what do you mean by "It 'only' replaces the default/FSX AI", what is espected to be seen and when, at the airports,during the flight? because what I do see on the JPEGS of the folder,ia a whole bunch of comercial airliners parcked at the gates.

Appreciate your reply

Manuco

Please don't forget to set the Vista security settings right.

Share this post


Link to post
Share on other sites

Hi Manuco,

The idea behind MyTraffic is to replace FS' Landmarks, Soars and Pacificas by Aerolinhas Argentinas, LAN, Varig, etc. Depending on your AI settings (FSX --> Options --> Display --> Traffic), it should be buzzing a little while after you started FSX.

Since FSX simulates the pre-flight phase, the AI aircraft don't start moving immediately.

The recommended 'Ground Vehicle' setting is 'Minimal'. Turning the airport vehicles off makes them depart much quicker as the pre-flight phase is no longer simulated.

Incoming aircraft also take a little while to show in greater numbers as they start further out compared to previous FS versions.

AI aircraft are terrible to fly. ;-) They do all kinds of crazy things when you take the controls. If you feel like a giggle, add the panel folder (from another aircraft folder) to an MTX aircraft folder and go for a spin. :-) Adding a panel makes the aircraft selectable in the aircraft menu.

Hope this answers your questions, kind regards

Jaap

Share this post


Link to post
Share on other sites

You shouldn't have only one F18 at ETAR - there should be around 40 or so militray aircraft parked there, C130s as example, etc... . If not, with AI traffic at 100%, we can be sure you have some FS8 format ( ttool based ) flight plans somewhere in your FSX setup that prevent FSX from displaying most of the FSX traffic.

Look for files call traffic.bgl or traffic1.bgl or similar.

Share this post


Link to post
Share on other sites

Hi Jaap: definetly must have something wrong: there are no military planes at ETAR and there is no replacement of FS Landmarks,Soars,Pacificas,by Aerolineas Argentinas,LAN,Varig etc.

Searched for Traffic.bgl found: runonce,restore_default_traffic,and disable_default_trafic, under MyTraffic. Does this mean something?

Question: if I click on MYTraffic at the added scenery list, it opens to show aircraft and FSLive: aircraft shows whole bunch of airplanes, FSLives,nothing. Is that all that needs to be added?

Sorry my friend for all the problems but I really would like to see MyTraffic running.

Regards

Manuco

Share this post


Link to post
Share on other sites

jaap: by the way, it isn't that I don't see any AI trafic at the airports; FSX AI's are showing very well. The fact is that they are not being replaced by the comercial airlines from MyTraffic.

Question: what do you mean that I must have some FS8 flight plans on FSX

Manuco

Share this post


Link to post
Share on other sites

Jaap I finally have MyTraffic working. Have planes on the military parcking ramp at ETAR together with the F18; at the airports and during the flight I was able to see the different comercial airlines flying and moving. You know what was missing? the addition of the line SimObjectPaths.6=MyTraffic\aircraft on the FSX.cnfg did that and whow it worked.

I really appreciate what you did for me to get the program running and you have a friend in Lima who is very greatfull.

I now have to learn how to use the MyTRaffic Board. Any tips would be appreciated.

Best regards

Manuco

Share this post


Link to post
Share on other sites

Hoi Manuco, great to hear you got it working. :-)

The last couple of pages (partially) described what happens if somebody who isn't familiar with advanced Windows settings will often face. That is, if using FSX & Vista and wanting to add a 'multi-discipline' addon like MyTraffic X.

So, to whom it may concern, if you for example shy (seriously*) modifying OS security settings, Vista will not be your thing. ;-) Adding FSX addons is more complicated in Vista than XP.

* 'seriously' as opposed to unseriously: Advising to de-activate Vista's UAC - the worst possible advise IMHO

Whilst at it, the second most commonly given advise when troubleshooting Vista: With single harddrives, stick to default paths. ;-)

Have fun and best wishes to Lima! . :-)

Kind regards

Jaap

Share this post


Link to post
Share on other sites
Jaap I finally have MyTraffic working. Have planes on the military parcking ramp at ETAR together with the F18; at the airports and during the flight I was able to see the different comercial airlines flying and moving. You know what was missing? the addition of the line SimObjectPaths.6=MyTraffic\aircraft on the FSX.cnfg did that and whow it worked.

I really appreciate what you did for me to get the program running and you have a friend in Lima who is very greatfull.

I now have to learn how to use the MyTRaffic Board. Any tips would be appreciated.

Best regards

Manuco

I would say just take your time. Sometimes problems occur in MyTrafficBoard, sometimes they occur in FSX. Either way, we'll be glad here to help you fix them. I have a lot of time to help people that understand things don't always go smoothly on computers.

Share this post


Link to post
Share on other sites

hi,

another one:

the flag on the (right) tail fin on US Airways aircraft should be the other way around.

the screenshot is actually from 5.1a but the 'problem' still exists (on the entire US fleet).

thank you!

post-1092-128689609771_thumb.jpg

Share this post


Link to post
Share on other sites

There you are right. Strange they have the flag opposed to the wind direction, and opposed to the small colored one...

Share this post


Link to post
Share on other sites

Err, yes. :oops: I painted all the 320s with the NC scheme and the flag is backwards on the starboard tail. Oops. I should really fix this sometime as it's simple to do.

Share this post


Link to post
Share on other sites

I know I probably should not ask this but here goes..... would it be possible to include Jet2 aircraft in a future issue. This is a popular regional UK airline based in Leeds. Thanks for considering.

Share this post


Link to post
Share on other sites

Noticed that AI tfc at LEPA for rwy 24R never actually lands. They make the approach, but they're about 1000 ft too high and will abort and turn around for a second approach. AI is set at 20% so there's plenty of parking space. Looked at the afcad file and it looks ok ??

Pierre

Share this post


Link to post
Share on other sites

Hi PPO,

They indeed sometimes come in high on 24R (mainly right after starting FSX), but all of them eventually landed on my end. After a while however, they come in at normal altitudes. Which FSX SP are you using?

Cheers and kind regards

Jaap

Share this post


Link to post
Share on other sites

I use FSX SP1. Would SP2 make any difference in AI behaviour ? Tried SP2 twice and dumped it twice.

Pierre

Share this post


Link to post
Share on other sites

The main difference with SP2 is that it properly displays FS9 aircraft. The AI behaviour is unchanged.

I do not expect this behaviour of LEPA to be changed. It had never been reported as a bug. The way points used are hard coded in FSX, we cannot change them. There are some problems with airports below sea level known that aircraft cannot get down fast enough, and LEPA isn't far above that. MS didn't fix this to my knowledge.

Is the problem that you see specific to a certain aircraft type, or does it affect most types? What we could try is to slightly reduce the full flaps stall speed and increase the maximal decent rate, but there I have to rely on somebody who sees the effect. I by fortune had looked a LEPA for a while a few weeks ago and they all came in properly.

Share this post


Link to post
Share on other sites

Tks for the info. Did further observations at LEPA: 2-3 hours of AI watching...

Most flights will land correctly at 06L or 24R. Tried it with different wind settings. However, when I tried to expedite things (AI increase to 70%), strange things happened: on a normal landing AI for 24R (normal would mean here right descent and right altitude) I would get AI on top of the normal landing path (about 1000ft higher). That AI would never land because it is too high. The other normal landing AI will land correctly. Now as to the frequency of that behaviour, I don't have numbers but I would venture to say that it is random and infrequent. It only happened once during my 2 hour check.

Conclusion: (if there is one) MYTraffic bgl's are working ok, this odd behaviour of landing AI above the normal approach path can only be attributed to MS ATC artificial quirks...

note: I would like to do further analysis, but the next few weeks will be too busy for me.

Thnks anyway for the help

Pierre

Share this post


Link to post
Share on other sites

Sometimes the approaching AI comes in too high and usually it's a bug/problem within FSX, as you said. It happens on many more airports and on different payware with their own AFCADs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.