Jump to content
The simFlight Network Forums
Mafiastewe

... out of memory

Recommended Posts

check your computer by going to my computer, and right clicking any of your cd drives and going to properties, and see how much memory you have left. also did you download something that used a lot of mb? except my traffic.

thank you

Share this post


Link to post
Share on other sites

Memory is not the same thing as disk space. If you were out of disk space, and freed up some, as it sounds like you've done, that's one thing but it doesn't really address the memory issue.

What operating system (Windows variant) and system memory do you have? If you are running Windows XP with less than 1 meg of memory, or Vista with less than 2 meg, buying more will almost definitely help.

If you right-click the task bar, and select the task manager, then Processes you will see a list of things running in the background. That will include things like your mouse driver, AV and firewall software and a lot of basic Windows components. It may take some detective work to figure out what's running and what you can do without. That's way beyond what I can help with, but that should be a starting point.

Glenn

Share this post


Link to post
Share on other sites

Hi there,

It's most likely a operating system/FSX issue, google for 'FSX out of memory error'. Alternatively, you could make a screenshot of the error message or indicate the exact text?

Kind regards, Jaap

Share this post


Link to post
Share on other sites

The first link diddnt help (not shure if i did it correctly for vista) and i cant view the second one so a transcript of what it says would be nice... any other ways i can fix this?

Share this post


Link to post
Share on other sites

it could be that the UT is taking up to much space. like other files that didnt get deleted are taking up too much space. Burkhard will be on tomorrow so ill leave him to fix this.

thank you

Share this post


Link to post
Share on other sites

TRY THIS FIRST: http://blogs.msdn.com/ptaylor/archive/2-ship.aspx

IF THIS DOESN'T HELP THEN READ BELOW.

You receive the "Your computer has run out of available memory" error message when you start Flight Simulator

View products that this article applies to.

Article ID : 892610

Last Review : November 14, 2007

Revision : 2.3

On This Page

SYMPTOMS

CAUSE

RESOLUTION

Method 1: Available hard disk drive space

Method 2: Rebuild the Windows paging file

Additional information

SYMPTOMS

When you start Microsoft Flight Simulator, you receive the following error message:

Your computer has run out of available memory. Flight simulator will now exit. You may not have enough free space on your hard disk drive. Run disk cleanup to free up space, and then try running Flight Simulator again.

Back to the top

CAUSE

This issue may occur if one of the following conditions is true: • Your hard disk drive does not have sufficient space available to play Flight Simulator.

• The Microsoft Windows paging file is corrupted.

Back to the top

RESOLUTION

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

To resolve this issue, use one or both of the following methods depending on your situation.

Back to the top

Method 1: Available hard disk drive space

1. Click Start, and then click My Computer.

2. Right-click the hard disk where Flight Simulator is installed, and then click Properties.

Note Flight Simulator is typically installed on drive C.

3. Make sure that the amount of Free space is more than 500 megabytes (MB).

Note 500 MB of available hard disk space is required to play Flight Simulator. 1 gigabyte (GB) of available hard disk drive space is recommended. If you do not have at least 500 MB of available hard disk space, you must remove or delete some of the files or programs on the hard disk drive.

Back to the top

Method 2: Rebuild the Windows paging file

1. Log on to the computer by using a user account that has Administrator permissions.

2. Click Start, click Control Panel, click Performance and Maintenance, click Administrative Tools, and then double-click Computer Management.

3. In the console tree, right-click Computer Management (Local), and then click Properties.

4. On the Advanced tab, under Performance, click Settings.

5. In the Performance Options dialog box, under Virtual memory, click Change.

6. In the Drive list, select the drive that contains the paging file that you want to rebuild.

7. Under Paging file size for selected drive, type 0 (zero) for Initial size (MB) and for Maximum size (MB), and then click Set.

8. Restart your computer.

9. Repeat steps 1 through 6.

10. In the Virtual Memory dialog box, under Paging file size for selected drive, click System managed size, and then click Set.

11. If you are prompted to restart your computer, click Yes.

Back to the top

Additional information

If you have sufficient hard disk drive space and rebuilding the Windows paging file does not resolve this issue, some of the Windows files on your computer may be damaged. For more help with this issue, contact the computer manufacturer (OEM) or contact Microsoft Windows Product Support Services.

For information about how to contact your computer manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 (http://support.microsoft.com/kb/65416/) Hardware and software vendor contact information, A-K

60781 (http://support.microsoft.com/kb/60781/) Hardware and software vendor contact information, L-P

60782 (http://support.microsoft.com/kb/60782/) Hardware and software vendor contact information, Q-Z

For more information about how to contact Microsoft Windows Product Support Services, visit the following Microsoft Web site:

http://support.microsoft.com/ (http://support.microsoft.com/)

Share this post


Link to post
Share on other sites

@ OP,

If you would bother to tell us your OS for example... :-( Why don't you at least post your specs? Are we supposed to guess?

Have you tried to do what the error message told you to do, move sliders to the left?

And great effort, Kambiz.

Cheers and kind regards

Jaap

Share this post


Link to post
Share on other sites
@ OP,

If you would bother to tell us your OS for example... :-( Why don't you at least post your specs? Are we supposed to guess?

Have you tried to do what the error message told you to do, move sliders to the left?

And great effort, Kambiz.

Cheers and kind regards

Jaap

Specs:

OS: Windos Vista Home Edition 32-bit

Hard drive 24 remaining gbs

Ram: 2.014

Microprocessor: Intel Core 2 duo 6400 2@ 2.13ghz

and thats all i know :)

Share this post


Link to post
Share on other sites

Could you please give a bit of information about your system specifications?

MyTraffic X under FSX has been reported to work with 768 MB, and to work well with 1 GB of RAM under XP. These settings require a lot of virtual memory to be available. So in the control pabel "System" you should make sure that the available virtual memory is 2 GB at least, and I always propose to set minumal and maximal value as big as possibe, so to 2GB or 2.5 GB.

This gain only will work if the system partion of the disk has enough free space, and is defragmented. So as a rule of thumb, a system partition should never become more than 80% full - so assuming your C: drive has 80GB, 16GB should always remain free as a never to touch safety margin like the last 45minutes of gaz for any pilot - NTFS requires this to work properly, the defragmenters need it.

Now, Vista itself requires a lot of main memory, so to run FSX under VISTA 2 GB are strongly recommended minimum. The memory usage of MyTraffic isn't big, about 200 MB only, but this may of course be just above what you give.

Next info we would need are: what version of FSX are you using. A lot of FSX memory errors have been fixed in the service packs.

Share this post


Link to post
Share on other sites
Could you please give a bit of information about your system specifications?

MyTraffic X under FSX has been reported to work with 768 MB, and to work well with 1 GB of RAM under XP. These settings require a lot of virtual memory to be available. So in the control pabel "System" you should make sure that the available virtual memory is 2 GB at least, and I always propose to set minumal and maximal value as big as possibe, so to 2GB or 2.5 GB.

This gain only will work if the system partion of the disk has enough free space, and is defragmented. So as a rule of thumb, a system partition should never become more than 80% full - so assuming your C: drive has 80GB, 16GB should always remain free as a never to touch safety margin like the last 45minutes of gaz for any pilot - NTFS requires this to work properly, the defragmenters need it.

Now, Vista itself requires a lot of main memory, so to run FSX under VISTA 2 GB are strongly recommended minimum. The memory usage of MyTraffic isn't big, about 200 MB only, but this may of course be just above what you give.

Next info we would need are: what version of FSX are you using. A lot of FSX memory errors have been fixed in the service packs.

, btw if u need ant info just lemme know.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.