Jump to content
The simFlight Network Forums

Peter: Getting "TCP/IP needs..." using IPX?


Recommended Posts

Peter:

I'm having Wideserver setup problems.

I've registered, gone through the install procedures, re-installed IPX, copied over the wideserver.log 'Servernode' numbers to the client.ini, with no luck.

I do NOT have TCP enabled on the Wideserver.ini because I'm behind a router and need to obtain DNS automatically over the LAN.

I've noticed that the second I punch Wideclient I get: 'TCP/IP needs ServerName or IP address!" with apparently no effort to FIND the server?

Any ideas?

Link to comment
Share on other sites

I'm having Wideserver setup problems.

Sounds more like WideClient problems?

I do NOT have TCP enabled on the Wideserver.ini because I'm behind a router and need to obtain DNS automatically over the LAN.

So, have you told the Server ot use IPX/SPX instead? It defaults to TCP/IP.

I've noticed that the second I punch Wideclient I get: 'TCP/IP needs ServerName or IP address!" with apparently no effort to FIND the server?

In that case you most definitely have not edited the Client's INI file to tell it to use IPX/SPX either.

Please check the doumentation.

Regards,

Pete

Link to comment
Share on other sites

That's what it was, a problem in the Client setup INI. I never had to add "useTCPIP=No" in my previous setup, but that along with checking the server node addressing seemed to clear up the network problems and the Client loaded using IPX very nicely.

Thanks for the help, I'm a happy camper. :lol:

Link to comment
Share on other sites

That's what it was, a problem in the Client setup INI. I never had to add "useTCPIP=No" in my previous setup

WideFS default was changed to TCP/IP a while back, because that's what most folks use. But I forgot to take the UseTCPIP=No parameter out of the default INI files until someone mentioned it was still defaulting to IPX/SPX.

Really, when updating versions you are usually better off keeping your old INI files.

Glad it's all working now anyway.

Regards,

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.