Jump to content
The simFlight Network Forums
Sign in to follow this  
isaac

FLAPS NOT WORKING IN FS2004

Recommended Posts

THE MODULE DO NOT RECOGNICE THE NEW FLAPS CONTROL IN FS2004

WHY ARE YOU SHOUTING?

What "new" flaps control. What would which module be doing recognising any control in any case? Can you explain what it is your saying a little clearer please. Identify (a) what module you are talking about, and (b) what new control you are talking abnout, and © what you are doing and what you expect. Okay?

Regards,

Pete

Share this post


Link to post
Share on other sites

The module is FSUIPC 3.1 and im taking about the new flaps axis located in "control-assignments-joystick-axes" of fs2004. FSUIPC 3.1 the joystick section in page 6 have the option for calibrating the flaps and is not recognise my flaps axes. they are intruction for configurations change in the manual but work only with fs2002.

Share this post


Link to post
Share on other sites
The module is FSUIPC 3.1 and im taking about the new flaps axis located in "control-assignments-joystick-axes" of fs2004. FSUIPC 3.1 the joystick section in page 6 have the option for calibrating the flaps and is not recognise my flaps axes. they are intruction for configurations change in the manual but work only with fs2002.

The Flaps calibration in FSUIPC was added because there was no facility in FS for this to be done. I didn't even know that MS had now added the facility to FS2004. In that case, you do not need the FSUIPC facilities, or if you do, you can surely still use the same method as in FS2002, i.e. assign the original FLAPS_SET control to your axis. Please see the FSUIPC User Guide and Advanced User Guide for details.

I've just checked the list of controls in FS2004 and I do see the "AXIS_FLAPS_SET" control, which is certainly new. I will add this to the list recognised by FSUIPC in the next update. Thank you for pointing it out.

Regards,

Pete

Share this post


Link to post
Share on other sites

I have added the recognition of the AXIS_FLAPS_SET control to FSUIPC version 3.03, being released at present. But it was not just a matter of recognising the new control. It seems that the range of vlues changed from FS2002 as well.

In FS2002 and before, the FLAPS_SET control provided a value from 0 to 16384 to set flaps from zero to full. In FS2004 both the old FLAPS_SET control and the new AXIS_FLAPS_SET run from -16384 to +16384.

I've dealt with this by secondary scaling within FSUIPC, so it does work well now, but it wasn't as straight-forward as I thought!

Regards,

Pete

Share this post


Link to post
Share on other sites

What can I said; Outstanding, The best support ever. Thanks for take time to answer to my question. By the way without FSUIPC is not the same. This program really makes a different.

Share this post


Link to post
Share on other sites
Just to be sure. In FS2004 the flaps range changed? FSUIPC 3.03 will continue to provide in 0x0BDC 0-16384?

The values in 0BDC, 0BE0 and 0BE4 all continue to act in the range 0-16384 as they used to, so I don't think there's any problem.

However, I have just noticed that the 65536 bit is set in the 32-bit 0BDC field (i.e. as if it is another field, which it may well be -- perhaps what we thought of as a 32-bit value was in fact two 16 bit values all along?).

I don't know whether that is significant of anything. I'll make a note to check it out when I'm updating the SDK. I've not reached that bit of the table yet . If you discover anything before me, please let me know!

Regards,

Pete

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.