Jump to content
The simFlight Network Forums

WideFS & XP Firewall


Recommended Posts

All,,,

I have been having issues getting WideFS 6. 78 to connect/communicate under Windows XP. I know it is related to the client-side XP default firewall, as all is fine when the firewall has been turned off.

I have a firewall exception in place on the client side for the WideClient program, but that doesn't seem to work. Additionally, I have tried setting exceptions opening port 8002 for both TCP & UDP, pointing to the IP address of the server. Sadly, things just don't seem to connect.

I'd prefer to avoid having to shut down the firewall, and then hope I remember to turn it back on. If so, I'm back running with the firewall off, and then who knows which of the many bad things can happen at that point.

Any help would surely be appreciated. Thanks !

Mike

Link to comment
Share on other sites

I have been having issues getting WideFS 6. 78 to connect/communicate under Windows XP. I know it is related to the client-side XP default firewall, as all is fine when the firewall has been turned off.

I have a firewall exception in place on the client side for the WideClient program, but that doesn't seem to work. Additionally, I have tried setting exceptions opening port 8002 for both TCP & UDP, pointing to the IP address of the server. Sadly, things just don't seem to connect.

Does WideClient see the Server broadcasts, on port 9002? If not you either need to enable that too, or specify the ServerName and Protocol in the WideClient INI file so that WideClient is not dependent upon the broadcasts.

It surprises me that it is not the Server firewall with the problem. Does the WideServer log show the client connecting?

I'd prefer to avoid having to shut down the firewall, and then hope I remember to turn it back on. If so, I'm back running with the firewall off, and then who knows which of the many bad things can happen at that point.

I rely on the firewall capabilities of my router. I hate my own computers in my own house stopping me having full access al of the time. Do I have something to be worried about?

Regards

Pete

Link to comment
Share on other sites

Hi Pete,,

Ahah!! Issue resolved, as I placed the Servername & protocol entries in the WideClient.INI file. Once that was done, all worked wonderfully. Not quite sure why it was needed, as the doc indicated it wasn't truly a requirement, but that's OK. All is well and working fine.

Now if I can only find all the other apps that use WIDEFS !!

Thanks Much for your help !!

Have a Happy Holiday Season !

Mike

Link to comment
Share on other sites

Ahah!! Issue resolved, as I placed the Servername & protocol entries in the WideClient.INI file. Once that was done, all worked wonderfully. Not quite sure why it was needed, as the doc indicated it wasn't truly a requirement, but that's OK. All is well and working fine.

It isn't normally needed as usually FS users with Networks only have one Workgroup. The broadcasts needed to tell the Clients where the Server is only work within a defined workgroup. It sounds like you have two differently named ones, maybe because you never bothered to rename the default, which i think is different in XP and Vista.

Regards

Pete

Link to comment
Share on other sites

Hi Pete,,,

Just checked the workgroup name for both units, and they are the same for each. BTW, both PC's are running XP, although the server is running XP Home, while the client is running XP Professional.

But now you have me thinking about the server broadcasts. I am wondering if the server's firewall (NIS 2009) is actually blocking broadcasts?? Any thoughts on how I might be able to check this?

Now we're getting down to the how of the matter, although WideFS continues to run along quite happily right now.

Thx again,

Mike

Link to comment
Share on other sites

I am wondering if the server's firewall (NIS 2009) is actually blocking broadcasts?? Any thoughts on how I might be able to check this?

No idea. The broadcasts are on port 9002. But they will be outwards from the Server to all Clients. Not sure whether or why firewalls stop outgoing messages, but maybe they do.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.