Jump to content
The simFlight Network Forums

Maximizing Input Readings in FSX


Recommended Posts

Hi Pete!

Just a quick question for something I could not find using the Forum search.

I build a two engine Throttle quadrant using Lea Bodnars card

http://www.leobodnar.com/forum/index.php

It works almost perfect.

I calibrated using FSUIPC mode (bypassing FSX controls altogether.

When calibrating it reads the full range of the pot Throttle,Prop and Mixture) on both engines

I.e

Throttle one reads -16030 to 16320

but in the sim, the first quarter of the throttle movement is ignored (it starts reading from -2090) ? Once it starts reading the inputs it is very smooth and precise though?

Is there a way of forcing FSX to recognize the whole range of inputs?

I hope this makes sense to you!

Many thanks for FSUIPC (registered version) once again

Alfred

Link to comment
Share on other sites

When calibrating it reads the full range of the pot Throttle,Prop and Mixture) on both engines

I.e Throttle one reads -16030 to 16320

These are the INput values? The OUTput should be from -16383 to + 16383. Are you not seeing that? Have you not calibrated, leaving a small "dead" zone at each extreme to ensure you can reach the minimum and maximum values?

but in the sim, the first quarter of the throttle movement is ignored (it starts reading from -2090) ? Once it starts reading the inputs it is very smooth and precise though? Is there a way of forcing FSX to recognize the whole range of inputs?

It will if that is what it sees. When you assigned the axes in FSUIPC's Axis assignments, did you assign "direct to FSUIPC" or to the normal FS axis controls? Try assigning them direct, THEN calibrate in FSUIPC. It sounds as if you've not done this.

If you still have problems, please show me the [Axes] and [JoystickCalibration] sections from the FSUIPC4.INI file (in the FSX Modules folder).

Regards

Pete

Link to comment
Share on other sites

When calibrating it reads the full range of the pot Throttle,Prop and Mixture) on both engines

I.e Throttle one reads -16030 to 16320

These are the INput values? The OUTput should be from -16383 to + 16383. Are you not seeing that? Have you not calibrated, leaving a small "dead" zone at each extreme to ensure you can reach the minimum and maximum values?

but in the sim, the first quarter of the throttle movement is ignored (it starts reading from -2090) ? Once it starts reading the inputs it is very smooth and precise though? Is there a way of forcing FSX to recognize the whole range of inputs?

It will if that is what it sees. When you assigned the axes in FSUIPC's Axis assignments, did you assign "direct to FSUIPC" or to the normal FS axis controls? Try assigning them direct, THEN calibrate in FSUIPC. It sounds as if you've not done this.

If you still have problems, please show me the [Axes] and [JoystickCalibration] sections from the FSUIPC4.INI file (in the FSX Modules folder).

Regards

Pete

Hi Pete!

Thanks for your quick response!

Here is the section of the ini file you have requested!

[Axes]

0=0X,256,D,1,0,0,0

1=0Y,256,D,2,0,0,0

2=0Z,256,D,4,0,0,0

3=0R,256,D,3,0,0,0

4=0U,256,D,6,0,0,0

5=0V,256,D,7,0,0,0

6=0S,256,D,5,0,0,0

7=0T,256,D,8,0,0,0

8=1X,256,D,1,0,0,0

9=1Y,256,D,2,0,0,0

10=2X,256,D,10,0,0,0

11=2Y,256,D,9,0,0,0

12=2Z,256,D,21,0,0,0

13=2R,256,D,17,0,0,0

14=2U,256,D,28,0,0,0

15=2V,256,D,18,0,0,0

16=2S,256,D,14,0,0,0

17=2T,256,D,13,0,0,0

18=17T,512,D,14,0,0,0

[JoystickCalibration]

ExcludeThrottleSet=Yes

ExcludeMixtureSet=Yes

ExcludePropPitchSet=Yes

SepRevsJetsOnly=No

ApplyHeloTrim=No

FlapsSetControl=0

FlapDetents=No

ReverserControl=66292

Reverser1Control=66422

Reverser2Control=66425

Reverser3Control=66428

Reverser4Control=66431

MaxThrottleForReverser=256

AileronTrimControl=66731

RudderTrimControl=66732

CowlFlaps1Control=66162

CowlFlaps2Control=66163

CowlFlaps3Control=66164

CowlFlaps4Control=66165

SteeringTillerControl=0

MaxSteerSpeed=60

Aileron=-16253,-2210,-650,15744

Elevator=-14823,-2210,-1690,16256

SlopeRudder=4

Throttle=-16384,16383

LeftBrake=-16384,16128

RightBrake=-16384,16383

Rudder=-16384,0,256,15488

PropPitch=-16384,16383

Mixture=-16384,16383

CowlFlaps1=1920,16256

CowlFlaps2=1920,16256

CowlFlaps3=1920,16256

CowlFlaps4=1920,16256

Throttle1=-15773,-512,512,15168

Throttle2=-16319,-512,512,14592

Mixture1=-16351,8192,8192,15200

Mixture2=-16287,8192,8192,16352

PropPitch1=-16351,0,512,16352

PropPitch2=-16351,0,512,16352

ElevatorTrim=-16223,-512,512,16320

Rudder Trim=-16255,-512,512,16383

What I find interesting that FSUIPC during the calibration routine "sees" the wholr throttle range i.e the value changes during the whole travel of the throttle input but in the simulater it reaches "Zero throttle when I still have 1/4 throttle travel left even after repeated calibration. It may be a FSX limitation though (or the pods I used??)

I use direct to FSUIPC mode.

I used 100 K pods when constructing the throttle. I used a reduction that uses about 250 degrees (Pretty much the full range of the pod)

I really apreciate your advise!

Kind regards

Alfred

Link to comment
Share on other sites

Throttle=-16384,16383

Throttle1=-15773,-512,512,15168

Throttle2=-16319,-512,512,14592

Mixture1=-16351,8192,8192,15200

Mixture2=-16287,8192,8192,16352

PropPitch1=-16351,0,512,16352

PropPitch2=-16351,0,512,16352

What I find interesting that FSUIPC during the calibration routine "sees" the wholr throttle range i.e the value changes during the whole travel of the throttle input but in the simulater it reaches "Zero throttle when I still have 1/4 throttle travel left even after repeated calibration. It may be a FSX limitation though

Two important points here:

1. You have a generic all-engine throttle calibrated on Page 1 as well as two independent throttles on Page 3 of FSUIPC's calibrations. You shouldn't do that. Either use one throttle or separate throttles.

2. You seem to be missing the point of the separate engine calibration facilities. When you look at the calibration page, don't you see "Reverse" on the left and "Idle" in the centre? There are reverse, centre and forward zones for throttles, mixture settings and prop pitch. The part of the lever movement you are "missing" is that which, with an appropriate equipped aircraft, you get reverse thrust, conditioning or pitch settings.

You appear to have rather ignored the instructions, the steps to successful calibration, provided in the FSUIPC user guide, as you most certainly have not calibrated a centre IDLE zone at all -- the two centre values appear to be defaulting! The whole point of providing a method of setting the centre/idle values is so that you can put that where you like! You've just left it where it happened to fall -- 1/4 of the way on your lever movement, apparently.

Please please please do look at what the screen shows and make use of the documented facilities to achieve EXACTLY whatever it is you want to do! If you want no reverse zones on the axes, just check that option. If you don't see the option to do this, you have an old version of FSUIPC and need to update.

Regards

Pete

Link to comment
Share on other sites

Hi Pete!

Thank you very much for your patient!

After re reading the manual and your explanation I got it working!

My problem was the "assumption" that if you do not set a "center dead-zone you simply do not have a center dead-zone which was not needed in my case....now that I have finally figured out that you must set a center dead-zone i got it working!!!!

It must be difficult conveying your fast knowledge and experience to ignorant people like myself (I did read the manual but only began to comprehend it after your second post, sorry about that)

Once again, Thank you for a great program and great support!!!

Alfred

Link to comment
Share on other sites

My problem was the "assumption" that if you do not set a "center dead-zone you simply do not have a center dead-zone which was not needed in my case....now that I have finally figured out that you must set a center dead-zone i got it working!!!!

Good. I take it you still want the reverse zone? If not you would find it easier to simply check the option for no reverse zone, and then there would be no centre zone to set, just a max and min.

The option for 'no reverse' are on each of the 4 throttle / 4 mixture / 4 prop pitch pages, and are independent for each of the three controls.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.