Jump to content
The simFlight Network Forums

FSUIPC v4.40 FS X and AnywhereMap


Recommended Posts

Recently (i.e Today) I purchased FSUIPC with the intentions of linking FSX to my AnywhereMap so I could practice using it prior to using it for actual flying. (Much better to figure things out on the ground than in the air).

In any case, I had quite a hard time getting things to work and would like some guidance on what I may have done wrong.

My setup is as follows

FS X SP 1 running on WinXP pro (Core 2 duo 2.2 GHz, 2 GB RAM and ATI Radeon HD 2400 Video card)

AnywhereMap (v1.93 build 136) is running on an IPAQ 210. Connection between the PC and the IPAQ is via Bluetooth

I downloaded v4.40 of FSUIPC and installed per the instructions.

As advertised, there was an "Add-On" section and I Selected the AutoSave/GPSout tab to configure GPSOut

Settings were

- Check here to enable GPSout (selected)

- Select a serial port (COMn) ( COM 8 ) selected

- RMA, GGA, GSA selected

I click OK, the application pauses a minute, then nothing...no NMEA data. I see that I do have a connection

Now here are the odd 'bits'

If I look at the FSUIPC.ini file. the GPSout Section looks like this (Yes I see its COM10, but keep reading)

[GPSout]

Port=COM10

Speed=4800

Interval=500

PosTo6Decimal=Yes

Sentences=RMA,GGA,GSA

If I open the AutoSave/GPSout tab again, I see that "random" COM ports are selected. It may be COM10, it maybe COM4...It just doesn't make any sense.

So I got curious and watched what was going on with filemon and portmon. Seems FSX opens COM8, then shuts it right back down and no data flows. There are no access denied errors show in filemon (I'm an admin so no issues there). FSX did "crash" a time or two when exiting.

I tried various combinations of starting FSX first then connecting the IPAQ. Connecting the IPAQ, then starting FSX, etc. None of that worked.

After retracing my steps, and trying other trouble shooting steps, I kept ending up with the same result. I tried another GPS emulator outside of FSX/FSUIPC and I was able to get the NMEA data flowing just fine between the PC and AnywhereMap.

At this point I found a version of FSUIPC 4.30 and "downgraded" to that version. Wouldn't you know THAT WORKED!

So I guess my question(s) are

1.) Is there a known issue in v4.40 that could cause such behavior

2.) Is there a patch if there is an issue (I saw some beta versions posted in the forum, but the links are broken)

3.) Did you see something in my description that would lead you to believe I missed something in the installation perhaps

Otherwise I applaud your efforts in producing this product. It will allow me to improve my proficiency in the cockpit, making for safer and more pleasant flights

Thanks

-Lane Ohlemeier

lane@ohlemeier.com

Link to comment
Share on other sites

I guess my question(s) are

1.) Is there a known issue in v4.40 that could cause such behavior

I'm not aware of one fitting your description, but there have been changes, and it would be best to try the latest update from the Updates Announcement, please. Let me know. There have been a lot of changes recently. Most of those affecting user facility enhancement are documented there as well, but not all the small improvements and bug fixes which would not affect many folks.

2.) Is there a patch if there is an issue (I saw some beta versions posted in the forum, but the links are broken)

When did you try the links? I took the previous update off-line for a couple of hours (between 0200 and 0400 am here in the UK) whilst fixing a serious bug with the INI file being corrupted. Try again please.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.