Jump to content
The simFlight Network Forums

[solved] STB local vs networked


Recommended Posts

Hi,

STB 2.11 works fine when loaded on a laptop and connected to FSX on a desktop through my network with this simconnect.xml in the FSX Appdata folder :

<?xml version="1.0" encoding="Windows-1252" ?>

SimConnect
SimConnect.xml
False

False
IPv4
global
192.168.0.5
2024
10
4096
False


False
IPv4
local
127.0.0.1

10
4096
False

but in this case, no program on the local desktop can connect to FSX with simconnect

When I remove this simconnect.xml 1. STB 2.11 works fine when loaded on the same desktop computer as FSX sp1, as well as other software connecting to FSX through simconnect

simconnect

10.0.60905.0

10.0.61355.0

10.0.61637.0

FSX

10.0.61355.0

Thanks for ideas and any help

chris

Link to post
Share on other sites

Hello Chris,

FSX SP1 uses the TCP/IP protocol for SimConnect. This means your simconnect.xml on FSX must have definitions for both local and remote clients. It looks like your definition just contains the remote client definition ("global"). SP2/Acceleration does better, you automatically get the local (a named pipe, much better) no matter what, and then you add the remote one if you wish it through the configuration file.

So a slightly different simconnect.xml may help you, please see STB User Guide, page 72. It will tell you where to find a sample with both entries, and you just change your IP address and port values.

Regards,

Simon

Link to post
Share on other sites

Hi Simon,

thanks for your response

here is the simconnect.xml in the sample folder

<?xml version="1.0" encoding="Windows-1252" ?>

SimConnect
SimConnect.xml
False

False
IPv4
global
192.168.1.2
2024
10
4096
False


False
IPv4
local
127.0.0.1

10
4096
False

it looks very similar to mine which has both entries ???

Link to post
Share on other sites

1. this is the error message when loading the STB server

Error HRESULT E_FAIL has been returned from a call to a COM component

more infos here

http://blogs.msdn.com/jaredpar/archive/2005/03/25/402386.aspx

http://msdn.microsoft.com/en-us/library/system.runtime.interopservices.comexception(vs.71).aspx

http://www.add-in-express.com/forum/read.php?FID=5&TID=1572

2. do I need a simconnect.cfg also on the local computer?

Link to post
Share on other sites

Sorry, I had not noticed the scroll bar on your file so I had not read all of it.

"Error HRESULT E_FAIL has been returned from a call to a COM component"

Are you certain that comes from STBServer? It's not a .net application, but rather c++. Just to clarify, STBServer is a term used to describe an FSX "plug-in" module that provides some functions to STB.

You need a SimConnect.cfg on your client only, when FSX is running on another PC.

Regards

Simon

Link to post
Share on other sites

Hi Simon,

Are you certain that comes from STBServer?

I remember reading that on a message but I am old and memory not so good :)

below a part of trace.log may be interesting

02/04/2009 21:32:26.630: FS Open Connection Exception Error HRESULT E_FAIL has been returned from a call to a COM component., Stack Trace    at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
   at Microsoft.FlightSimulator.SimConnect.SimConnect..ctor(String szName, IntPtr hWnd, UInt32 UserEventWin32, WaitHandle hEventHandle, UInt32 ConfigIndex)
   at SimConnect_Wrapper.SimConnectWrapper10SP1.MakeFSConnection() in C:\Documents and Settings\gb044846\My Documents\FSX Traffic Board\SuperTrafficBoard V2.1 Gold\SimConnect Wrapper 10 SP1\SimConnectWrapper10SP1.cs:line 112

and I don't understand why all works well localy when I remove this simconnect.xml file???

best regards

Link to post
Share on other sites

Hi Chris,

When the simconnect.xml is removed, I guess we are falling to some internal defaults known only to FSX. This applies on both the server and client side. The most significant "internal default" would be the port number.

I would suggest trying a SimConnect.cfg file on the same computer as your FSX. In both the SimConnect.cfg and SimConnect.xml, make sure the port number is the same. If some application cannot connect after that, we'll have to look into this part of FSX some more.

You may have good reasons for not wanting to go to FSX SP2, but I'm pretty sure you would not have this problem in SP2. You only need configure the global option for that, the local option is always assumed.

Regards

Simon

Link to post
Share on other sites

Thanks Simon,

Helas I installed SP2 and now all is working fine on local but I can no more have STB to connect from the laptop :(

(of course I installed simconnect for sp2 on the laptop) and changed both simconnect.cfg and simconnect.xml as set in samples folder)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.