Jump to content
The simFlight Network Forums

Error after 5.2a update


Dicko
 Share

Recommended Posts

Burkhard,

After installing MyTrafficX 5.2a update, when opening My Traffic Superboard 2.2 i get this message :

" A traffic scheduling error occurred. No traffic schedule source files matching filter *dat were found in folder C\Program files (x86)\Microsoft Games\Microsoft Flightsim X\MyTraffic\scenery. As aresult of this error, the default airport database will be used. The default database does not contain flight schedule, 3rd party airport data or airport names you may have customized. This may result in incorrect flight numbers being displayed, incorrect departure schedule for aircraft moved to stand by approach control, and 3rd party airports may not be able to use approach control and flight distance data."

Any ideas how to rectify this, the program seemed to work fine before the 5.2a MTX update.

I have also posted this on the Flying-W support page.

Thanks in advance

Andrew

Link to comment
Share on other sites

  • Replies 50
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Burkhard, just to confirm, which or both files do I copy over - MTPlans\2009_DX9 resp or MTPlans\2009_DX9 and what is the difference? How do I know which one I use?

I think Burkhard meant MTPlans\2009_DX9 or MTPlans\2009_DX10 depending on which Direct X you use.

I have only one MyCommercialRoutes.dat file in each of those folders.

Mike

Link to comment
Share on other sites

Burkhard

I have a My Trafficcommerrcial.bgl file but no dat files in My Traffic\scenery

In the MT Plans folder I have four separate folders named

1. 2008_DX9 - contains file MyCommercialroutes.dat

2.2008_DX10- contains file MyCommercialroutes.dat

3.2009_DX9 - contains no dat file of any type only bgl files

4.2009_DX10 - contains no dat file of any type only bgl files

Also in the MT_Plans folder I have a variety of dat files two of them being MyCommercialRoutes2009_DX9.dat and MyCommercialRoutes2009_DX10.dat.

Why are the 2 2008 files still there as the traffic communicator Select Schedules only lists 2009 and not 2008?

thanks

Andrew :?:

Link to comment
Share on other sites

That I have to check.

If you arer using the default schedules, these are those for DX9, so you need to copy the file for DX9. If you switched to DX10 schedules, it should be the DX10 one. But maybe the fact that they go into an 2008 instead of 2009 folder explains the reason of the problem already.

Link to comment
Share on other sites

I ran the installer again same issue. The update doesn't seem to install the dat files in the correct spot. I am missing dat files where they should be and as a result the scheduled flights are obviously not loading. As a said previously, version 5.2 worked flawlessly and this issue only has arisen since the update. How do I fix this Burkhard? The update was via the Traffic Communicator and it obviously hasn't installed properly.

Thanks

Andrew

Link to comment
Share on other sites

That are indded the files from version 5.2. For the moment I have zipped and uploaded the DX9 file to MyCommercialRoutesDX9.zip - please put the content of the archive into the MyTraffic\scenery folder and your problem should be fixed.

Link to comment
Share on other sites

Burkhard, please excuse my ignorance, but how do I download this file and from where? Also why have I the two 2008 folders. I also have the two 2009 folders but these contain no dat files. I am definately not a computer genius, but the traffic communicator in the schedules has 2009 not 2008 so I would assume the 2008 folders should have been deleted the two 2009 folders should both contain a commercial route dat file and another commercialroute dat file should have been placed in the scenery folder. None of this happened.

Thanks

Andrew

Link to comment
Share on other sites

Hi Burkhard, when you say to "put the content of the archive (MyCommercialRoutesDX9.zip) into the MyTraffic\scenery folder and the problem should be fixed" means that everybody need do this or is just a fix to Andrew in order to correct the message error in My Traffic Superboard 2.2

Because what I don't understand here is that when I open My Trafficboard 1.0 I don't get any error message ..... maybe because this version of my trafficboard is different from Andrew.....

thanks.....

Ricardo

Link to comment
Share on other sites

Burkhard, at this stage I have restored my computer back to Version 5.2. When the problem with the installer is addressed I will redownload the update via the traffic communicator. Can you please e-mail me back when you debug the installer.

Those with MTX installed would never pick this up unless they had MyTraffic Superboard installed and use flight data schedules.

Thanks for your efforts

Andrew

Link to comment
Share on other sites

If it ain't broken, don't fix.

This file should cure the concrete problem one user has. If another user has exactly the same problem, it could help him. Further than that, I have to analyse what might have caused this. This may take quite some time, and I have to find and reserve a slot of continous time to do so first.

Link to comment
Share on other sites

Burkhard, at this stage I have restored my computer back to Version 5.2. When the problem with the installer is addressed I will redownload the update via the traffic communicator. Can you please e-mail me back when you debug the installer.

Those with MTX installed would never pick this up unless they had MyTraffic Superboard installed and use flight data schedules.

Thanks for your efforts

Andrew

Link to comment
Share on other sites

ok Burkhard, for the moment I will not change nothing in my system but one question, the file "MyCommercialRoutes.dat" is really necessary in MyTraffic\scenery folder???

Because I can tell you that file is not located in that folder.....

thanks

Ricardo

Link to comment
Share on other sites

If you are using Super traffic board and if you have opted in STB to take some information to display that isn't given by the Simconnect interface ( to be precise: not given in all cases, different between sleep and active ), than you need it.

Link to comment
Share on other sites

No Burkhard, I don't have Super traffic board, in my system I only have the MyTraffic board 1.0 wich is installed by mytrafficX...

So, this means that I don't need take any action for the moment and everything is fine with my current traffic isn't it???

thanks for help

Ricardo

Link to comment
Share on other sites

Burkhard,

Eagerly awaiting.

Thanks

Andrew

Hm, Eagerly awaiting and publication of well tested software don't share the same planet. If this weren't a trivial change fortunately, this would need to go to a couple of testers and wait if they have time over the next weekends. Making software is a slow process, with many time constants in it, that may take 5 minutes or 5 weeks. If you don't give it time, things come out like Windows Vista, the 787 rollout with plastic fasteners, or the A380 with two halves not fitting to each other.

But to fulfill your dream, and since it really needed one more simple line in the updater, I uploaded a new update now, and declare you the official tester of it. That saves me a week :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.