Jump to content
The simFlight Network Forums

UTFSX - default exclusions?


Recommended Posts

I do apologize if this has been covered elsewhere. Running version 7.0.6-04

Running: FSX SP2 with UTUSA,CAN,and EUR. Vista 64 bit system. FSX runs with full admin rights. (Also runs in XP compatability mode so the WILCO add-ons work).

All ultimate terrain files are lowest priority addon. VICplus folders are at the top in the correct order.

For some reason, all of the waters of Puget Sound, Juan de Fuca, and Georgia Strait vanish under a sea of woodland. It only goes away if I disable "UT Exclusions for Default Scenery." Not sure how important this is.

The "repair" option was tried first. Then all add-ons were disabled until the offending folder was found.

CYYJ 2009 is also installed and was reinstalled after "repair" was run.

The only difference between having CYYJ installed is that the water textures around Vancouver were partially restored. But all the rest was still woodland.

Brian

Link to comment
Share on other sites

Brian, has this ever worked? If you're 100% sure you've got the scenery order correct (see Vic+ manual), have run repair, etc., the most likely cause is that during installation the installer could not update the terrain.cfg file in the FSX program folder. Can you post that so I can take a look?

Jon

Link to comment
Share on other sites

Yes - it did work before. However, I haven't flown in that area recently so I don't know whether something got updated or what that could cause this.

I cannot attach the file - it says that the extension is not allowed - even if I rename the file to just plain config. Is there any other way to send it other than posting the entire text to the board?

Brian

Link to comment
Share on other sites

The Terrain.cfg is fine, if you're flying in FTX mode and have had the UTX entries "copied out". Someone forgot to turn FTX Mode OFF prior to installing, so the Vic+ data goes into the Aussie file. There sits the active UTX folders, including the one that excludes all the default water, but since the 90+ entries that UTX needs to redraw the landscape are not in the Terrain.Cfg file for FTX you end up with land everywhere.

FTX Mode OFF, reinstall Vic+ and see if things go back to normal.

Link to comment
Share on other sites

I haven't forgotten about this - there just hasn't been time to do a good round of testing. There are still problems but I want to post some screen shots.

I still like the scenery and I plan on using it regardless - little details like this don't wreck it for me. Keep up the good work!

Brian

Link to comment
Share on other sites

Well - AU was turned off and the results are the same. Uninstalled and reinstalled.

The first screen shot (1) shows what it looks like with the default terrain exclusions turned on. (Oddly enough, if the extra "CYYJ 2009" is installed, it blocks out the last remaining bit of water).

The second (2) shows it with the exclusions turned off.

Pictures.rar

Link to comment
Share on other sites

No, FTX was not turned off prior to installing Vic+. The fact that the Vic+ Terrain.cfg entries were written into the FTX version of the Terrain.cfg file indicates this. So now you've got a mess on your hands and don't appear to comprehend what the UTX setup is or needs to be.

When you install UTX, be it US, Canada or Europe, it does a couple of things. First it adds tons of files, then it modifies the Terrain.Cfg file for FSX so that certain new features will be recognized. Some of the files that UTX installs go in and exclude out the default scenery, so that it can replace it with it's own more detailed stuff. When you turn off the scenery layer for the default exclusions all you are doing is restoring the default scenery. There goes your $$ spent on THREE UTX packages. Isn't default scenery boring???

You need all the UTX scenery layers to be active. But you also need all the Terrain.cfg data that UTX adds in. That's where FTX and their ON/OFF garbage messes things up. Somewhere on your system, hidden away in the FTX folder, should be another copy or two of the Terrain.Cfg file that was present before FTX was first installed. You'll need to do a search or look for it from within Windows Explorer. LMK if you find it. You can tell if the file has the Necessary UTX entries as they'll be at the bottom of the file, which you can open with Notepad and there will be about 93 entries for UTX that start after all the default Autogen entries.

Link to comment
Share on other sites

Wow - you weren't kidding. I had to go back to a backup copy of terrain.cfg and start from there. The entire file was corrupted - probably because I installed some scenery WITHOUT "disabling" FTX before I actually read that warning. *sound of head smack*

It works just fine now. Of course.

I take it that the "ON/OFF" feature for FTX is useless. Is there a better way to disable the FTX scenery when installing something new?

Thanks for pointing out the way - I figured it was a user error I just wasn't sure where to start.

Brian

Link to comment
Share on other sites

iI believe FTX in bringing out an update to their software that will do away with the ON/OFF problem. You should check in their forums for any news.

Glad to know UTX is working again. You should be able to install Vic+ into the now "correct" Terrain.cfg file without too many problems.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.