Jump to content
The simFlight Network Forums
Sign in to follow this  
dave_paige

3.9.3.5 Breaks FS9

Recommended Posts

Hi Pete;

Just updated to 3.9.3.5 and Flight Simulator 9.1 now crashes during launch. I get the splash screen for a while, then that dissapears, and several seconds later I get the "Flight Simulator as encountered a problem and needs to close" message. I had not recently installed anything else. I reverted back to 3.9.3.4 and FS9 launches fine. Just thought you should know.

Share this post


Link to post
Share on other sites

Just updated to 3.9.3.5 and Flight Simulator 9.1 now crashes during launch. I get the splash screen for a while, then that dissapears, and several seconds later I get the "Flight Simulator as encountered a problem and needs to close" message. I had not recently installed anything else. I reverted back to 3.9.3.4 and FS9 launches fine. Just thought you should know.

It works fine here. I need more information please. The change between 3.934 and 3.935 is only an additional Lua plug-in facility, and even that isn't active until FS is fully loaded and ready to fly.

When Windows comes up with the error message, please select the option for more details. I need the Module name and the address provided -- it'll be a 4 or 8 digit hexadecimal number, like 0x......

What add-ons are installed which will be active during FS9's loading sequence? What aircraft is loaded by the default flight you've set? Is it an FSUIPC client aircraft? Any other add-in modules installed in the Modules folder?

Pete

Share this post


Link to post
Share on other sites

Hi Pete;

Here's the info from the "more information" link...

AppName: fs9.exe AppVer: 9.1.0.40901 ModName: ntdll.dll

ModVer: 5.1.2600.5755 Offset: 0001b21a

My default flight is the original one, C172 at KSEA. The other modules that I know of are bglman.dll v1.0.0.60, FSSound.dll v1.5.0.1, LegacyHUD.dll v1.2.0.1 from Feelthere, PMDGOptions.dll v1.0.2.0, sb3guagebridge.dll 2.0.0.1, and the squawkbox 4.0 dlls.

Share this post


Link to post
Share on other sites

AppName: fs9.exe AppVer: 9.1.0.40901 ModName: ntdll.dll

ModVer: 5.1.2600.5755 Offset: 0001b21a

Hmm. Not much help, that's in Windows.

Is there an FSUIPC.LOG file produced (albeit pretty short I should think)? If so, could you please add

LogReads=Yes

LogWrites=Yes

to the [General] section of the INI file and try again. I cannot see how anything in FSUIPC can crash FS so early, but it is worth a try. As I said, the changes between 3.934 and 3.935 are not only small, but only come into play when you run a Lua plug0in in any case.

Ah, that does raise another question. Do you have an Ipcinit.lua in your modules folder? If so can I see what is in it, please?

My default flight is the original one, C172 at KSEA. The other modules that I know of are bglman.dll v1.0.0.60, FSSound.dll v1.5.0.1, LegacyHUD.dll v1.2.0.1 from Feelthere, PMDGOptions.dll v1.0.2.0, sb3guagebridge.dll 2.0.0.1, and the squawkbox 4.0 dlls.

Hmm. Not sure which of those use FSUIPC. Definitely the PMDG and the SB3 modules, maybe the LegacyHUD one. If you have time do you think you could try without them, then add them back one at a time?

Sorry to ask all this -- it is difficult when I cannot reproduce the error, though i will try adding the PMDGoptions one and the SB3 ones later today.

Thanks,

Pete

Share this post


Link to post
Share on other sites
Sorry to ask all this -- it is difficult when I cannot reproduce the error, though i will try adding the PMDGoptions one and the SB3 ones later today.

I couldn't find SB3 so i installed SB4, and I've managed to reproduce the error. It is a timing problem -- one of the SB components is calling FSUIPC very early, before it has initialised a critical path semaphore. It is easy to fix, so look out for 3.936 later today.

Thanks for the detailed information. It was very useful.

Regards

Pete

Share this post


Link to post
Share on other sites

Hi Pete;

As always, thankyou so much for your attention to this. And for such a fantastic, and usefull module. I will look for the newer interim release right now. I'm also using SB4 at this point. If you need the SB3 package let me know and I can send it to you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.