Jump to content
The simFlight Network Forums

Some calibration issues - help please!


Recommended Posts

Hi, I am a complete new user, and got FSUIPC after experiencing problems getting my cougar hotas set up in FSX. I managed to allocate axis and calibrate my hotas and also assign the buttons and functions I wanted. I was immediately amazed at how different and responsive my hotas was. I was actually able to start landing my F-18 sucessfully on the carrier, something that requires intense finessse on the throttle and joysytick.

Howver, having not changed anything that I am aware of , I suddenly find that my silky smooth hotas has become jerky and snatchy. I cant figure out what has changed and how to sort it out.

Can anyone help?

thank you, mark

Link to comment
Share on other sites

Howver, having not changed anything that I am aware of , I suddenly find that my silky smooth hotas has become jerky and snatchy. I cant figure out what has changed and how to sort it out.

If you've not changed anything, or installed anything, then the only possibility I can think of is that you are assigning the axes in FSUIPC but haven't successfully disabled them in FS. For example, If you disconnect a joystick and then reconnect it, FS will sometimes treat it as a new connection and make automatic assignments. If you have dual assignments to any axis, they will be competing with each other. So, check FS assignments.

Regards

Pete

Link to comment
Share on other sites

Hi Pete, thanks for the quick reply, I think this may be the issue, as lo and behold, "enable controllers " was checked in my GUI. I had unchecked it, but I have 4 .cfg files i swap in and out, so i guess it snuck in again. Is there a line i can add to my .cfg files to ensure all have it switched off, rather than having to remeber to do it manually each time? I had a look in the file, under the "Conrtrols" section, there did not appear to be a 1 or 0 value that I could change.

rgds, Mark

Link to comment
Share on other sites

Hi Pete, thanks for the quick reply, I think this may be the issue, as lo and behold, "enable controllers " was checked in my GUI. I had unchecked it, but I have 4 .cfg files i swap in and out, so i guess it snuck in again. Is there a line i can add to my .cfg files to ensure all have it switched off, rather than having to remeber to do it manually each time? I had a look in the file, under the "Conrtrols" section, there did not appear to be a 1 or 0 value that I could change.

Search for "Joysticks=". I think that is a 0 or 1 value.

Pete

Link to comment
Share on other sites

Hi Pete, i definitely do not have any entry in my.cfg files that starts "Joystick" have checked very carefully and used the find function. nada... Could this be manually added? thx, Mark

This is for FSX? You are looking in the FSX.CFG in the correct settings folder for your log-on user name? Here's my [CONTROLS] section for FSX, with joysticks disabled:

[CONTROLS]

Controls_Default=Standard

Controls_Current=Standard

KBDAIL=64

KBDELEV=64

KBDRUD=64

JOYSTICKS=0

Regards

Pete

Link to comment
Share on other sites

Hi Pete, yes, FSX and I just checked my .cfg files, the last entry I have in "controls" section is " KBDRUD=64"

So I guess I can add it manually without problems. strange its not there though......

I will have a test flight now and report back, many thanks for your patience,

rgds,Mark

PS: FSUIPC seems an incredible piece of software from my limited viewpoint, you are obviously an extremly talented guy, thank you !

Link to comment
Share on other sites

Hi Pete, I seem to have one small issue, since we did the .cfg edit. I cant seem to be able to use my mouse to pan view or zoom in anymore.

The FS CFG file? Sorry, I don't know anything about mouse operations there. I don't think it has any influence. But panning and zooming are virtual cockpit operations, aren't they? Perhaps you are in 2D cockpit mode? Use the keyboard control to switch. "A" isn't it? Or perhaps "S". I never remember..

None of my software knows anything about the mouse. Well, except for the facility to use the mouse wheel for elevator trim. It most certainly cannot interfere with or affect mouse operations.

Regards

Pete

Link to comment
Share on other sites

Hi Pete, you can actually pan and zoom in any of the views by using the mouse if you want. Its pretty useful. Its mapped to shift -O in the buttons, what happens is that you press this, the cursor changes from an arrow to a cross, to indicate its in this mode, but you cant actually move the view or zoom.

I wondered if it had been affected as it was programmed through the GUI, which has been effectively "disabled" by our .cfg edit. I did look and see if I could assign this function through FSUIPC, but could not see a way of doing this.

In that case I guess I need to look elsewher for the culprit, although it does seem co incidental does'nt it?

XCheers, Mark

Link to comment
Share on other sites

Hi Pete, you can actually pan and zoom in any of the views by using the mouse if you want. Its pretty useful. Its mapped to shift -O in the buttons, what happens is that you press this, the cursor changes from an arrow to a cross, to indicate its in this mode, but you cant actually move the view or zoom.

Ah, some facilities I've never heard of! So you can see you are in the correct "mode" and it still doesn't work?

I wondered if it had been affected as it was programmed through the GUI, which has been effectively "disabled" by our .cfg edit. I did look and see if I could assign this function through FSUIPC, but could not see a way of doing this.

You mean the Shift+O? It must surely be an FS control. Doesn't it get logged? Let me try ...

...Yes, it's called "Mouse look toggle". But it doesn't work here, either. Let me try things ...

... Okay. It's "JOYSTICKS=0". Seems that saying there's no joysticks stops the mouse being used like a Joystick too. Probably stops "mouse as yoke" too.

[LATER]

Yes. Confirmed. It's actually easy to check really. Look in the FSX Menu, "Options-Settings-Controls-Calibration". The "Enable Controllers" checkbox top left IS the CFG "Joysticks" parameter. Enable it there and look in the "Controller Type" drop-down. You'll see not only real joysticks but also "Mouse yoke" and "Mouse Look".

So, it looks as if you can't have it both ways. Very short-sighted of that, by Microsoft. They should certainly have separated the mouse use from the joystick use.

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.