Jump to content
The simFlight Network Forums
Sign in to follow this  
Spikey737

FSUIPC 3.96 & Windows 7

Recommended Posts

Hi

I've just installed MSFS 9 on my new Dell pc. I need to update to FSUIPC 3.96 to injoy active sky advanced.

I followed the instructions for the download but the installer could not locate my MSFS 9. The installer did not offer me the chance to browes for it, it gives an error message & closes down.

I noticed that Dell have two folders on my pc. One which says "Program Files" (which is all the staff that they installed at the factory) & another called Program Files (86) which is where all my installs are including MSFS9. I'm wondering if this is causing the issue.

Any help would be welcome.

Many thanks

Share this post


Link to post
Share on other sites

I've just installed MSFS 9 on my new Dell pc. I need to update to FSUIPC 3.96 to injoy active sky advanced.

I followed the instructions for the download but the installer could not locate my MSFS 9. The installer did not offer me the chance to browes for it, it gives an error message & closes down.

I cannot guess what that error might be. you need to give me a clue. In fact what you can do is show the Installer log itself, which is why it is produced. When you get the error message, do two things:

1. Write it down so you can tell me what it is because I cannot guess, and

2. Use the file menu on the on-screen log to save it so you can paste it into a message here. That will tell us everything we need to know.

I noticed that Dell have two folders on my pc. One which says "Program Files" (which is all the staff that they installed at the factory) & another called Program Files (86) which is where all my installs are including MSFS9. I'm wondering if this is causing the issue.

No, that is perfectly normal for a 64-bit version of Windows.

Regards

Pete

Share this post


Link to post
Share on other sites

Thank you:

Installer for FSUIPC.DLL version 3.96

Looking in registry for FS9.1 install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.1

Parameter"EXE Path"

Not there, so looking in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.1

Parameter"EXE Path"

... NOT found! ...

Looking in registry for FS9 install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.0

Parameter"EXE Path"

Not there, so looking in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.0

Parameter"EXE Path"

... NOT found! ...

Looking in registry for FS8 install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\8.0

Parameter"EXE Path"

Not there, so looking in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\8.0

Parameter"EXE Path"

... NOT found! ...

Looking in registry for FS7 install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\7.0

Parameter"path"

Not there, so looking in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\7.0

Parameter"path"

... NOT found! ...

Looking in registry for FS6.1 install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\6.1

Parameter"InstallDir"

Not there, so looking in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\6.1

Parameter"InstallDir"

... NOT found! ...

Looking in registry for CFS2 install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Combat Flight Simulator\2.0

Parameter"EXE Path"

Not there, so looking in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Combat Flight Simulator\2.0

Parameter"EXE Path"

... NOT found! ...

Looking in registry for CFS1 install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Combat Flight Simulator\1.0

Parameter"EXE Path"

Not there, so looking in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Combat Flight Simulator\1.0

Parameter"EXE Path"

... NOT found! ...

... NOT found! Asking user to find the .EXE instead ...

Then a box pops up which says "FSUIPC Installer: Found FS7

X Problem! Cannot place FSUIPC.DLL into the FS modules folder! The error reported by Windows is: The system cannot find the path specified"

Hope this helps?

Share this post


Link to post
Share on other sites

Hello Peter/Jim

I uninstalled Flt sim & reinstalled it into the Programs folder & the FSUIPC update installed with no problems.

Active sky advanced was also uninstalled & reinstalled into the same folder but now I can't launch FS from its interface, perhaps Jim can help me with that one?

Share this post


Link to post
Share on other sites

Then a box pops up which says "FSUIPC Installer: Found FS7

X Problem! Cannot place FSUIPC.DLL into the FS modules folder! The error reported by Windows is: The system cannot find the path specified"

Hope this helps?

Yes, thank you. I'm not sure what is going wrong there. I'll check it out again. Thanks.

Certainly your FS was not installed correctly (the Registry is not updated with its path)but I see you've now rectified that.

I'll work on fixing the Installer. Not sure why that wasn't presenting you with the correct dialogue.

Regards

Pete

Share this post


Link to post
Share on other sites

I'll work on fixing the Installer. Not sure why that wasn't presenting you with the correct dialogue.

I cannot reproduce your error at all, even by removing the Registry entry for FS9 which was missing in your installation.

I realise it is too late now to ask for for a screenshot of the error message over the top of the Install log, so I'm posting this for anyone else who may get this problem. I need to actually see it for myself.

This is because There is no relationship between this:

... NOT found! Asking user to find the .EXE instead ...

the last line of the Install log, and therefore the point at which the error occurred, and this:

Then a box pops up which says "FSUIPC Installer: Found FS7

X Problem! Cannot place FSUIPC.DLL into the FS modules folder! The error reported by Windows is: The system cannot find the path specified"

The very next line of code in the Installer, after logging "NOT FOUND" etc is the one which creates a File selection dialogue where the user can locate FS9.EXE. When he does so, everything continues normally. If he selects something other than FS, THEN and only then can the program generate the error above (the "Found FS7" should really be "Found unknown", because it wouldn't have been an FS executable the user selected). I am correcting the installer so that it says "unknown" instead of "FS7".

However, if this is what really happened, then the Log would have shown extra lines at the end, thus:

... NOT found! Asking user to find the .EXE instead ...

User identified path:

"F:\Program Files\Paint.NET"

===========================================================

INSTALLATION FOR FS7:

Checking if there's already a version of FSUIPC installed in:

F:\Program Files\Paint.NET\Modules\FSUIPC.DLL

... No previous valid version found.

Failed to place FSUIPC.DLL into folder as "F:\Program Files\Paint.NET\Modules\FSUIPC.DLL"

Error 3 reported ("The system cannot find the path specified. ")

Here I deliberately chose an EXE which is in Windows 7's Program Files folder, but which is not the EXE of a recognised version of an FS installation. Now the error message I get IS exactly as you reported, but all of the reasons why are properly shown in the Log.

So, I think what might have happened is that for some reason you misunderstood the need to find the FS9.EXE file, and instead selected some other EXE. Then, when you pressed OK or Select, then you got the error. I think you must have truncated the Log when you pasted it into your message here.

Regards

Pete

Share this post


Link to post
Share on other sites

Hi Peter

I removed everything again & rebooted then just went with a fresh install of FS just has I had done before but this time FSUIC found it, & Active Sky went in with no problems as did all my other add ons & I'm delighted to say that it is all working great.

Must have had an issue with the registry as you said.

But I'm up & running thanks for your support, it's so frustrating when you've paid out a serious amount on a new pc & things don't go right.

Thanks also to Jim.

Mike

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.