Jump to content
The simFlight Network Forums
bazeo21

????? In flight times in V2.3

Recommended Posts

Thanks Simon, I have SDK SP2 installed on both my machines, the client version on my 'client' laptop is v10.0.61259.0. Still having trouble connecting sometimes, no problems with everything on the same machine though.

Kind regards

Mark

Share this post


Link to post
Share on other sites

I've noticed the same thing that keeps happening on the initial try to connect (after this, it hangs at 'connecting to FS' untill I restart everything). On the initial set after pressing ctrl+s on fsx PC, within one minute on the client laptop I get an unhandled exception error (something like that!), it mentions the .net framework. Also the words 'dropped UT2 data as the last process did not finish updating in time' appear every minute the STB messages window.

Kind regards

Mark

Share this post


Link to post
Share on other sites

Hi Mark,

1) Regarding the problem with reconnect after a disconnect, perhaps try forcing STB to use the SimConnect SP1 interface and see if that makes a difference. It really shouldn't but it's worth a try. To do this, locate the application data folder for STB and create a file in there called ""IGNORE_SP2.cfg". It does not matter what it contains, it just has to exist. Next time you successfully connect go to Settings and the Statistics tab, and you will see "61242" in the Flight Simulator Client Version.

2) The exception after ctrl+s is important to understand. STB has a separate thread for listening to data from UT2, and when it gets an exception it dies and hence the message about dropped packets. Please send full details of that exception next time you see it.

Regards

Simon

Share this post


Link to post
Share on other sites

Thanks Simon, tried what you suggested with using SP1, put IGNORE_SP2.cfg as a txt document in C:\Program Files (x86)\FlyingWSimulation\SuperTrafficBoard V2.3 and started it but it still says it's using v10.0.61259.0 so dont know whats wrong there. No problem in sending you the exception error, it happens every time!

Thanks for your help. Kind regards

Mark

See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.Net.Sockets.SocketException: No such host is known

at System.Net.Dns.GetAddrInfo(String name)

at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)

at System.Net.Dns.GetHostEntry(String hostNameOrAddress)

at System.ServiceModel.Channels.DnsCache.Resolve(String hostName)

************** Loaded Assemblies **************

mscorlib

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4952 (win7RTMGDR.050727-4900)

CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll

----------------------------------------

TrafficBoardFrontEnd

Assembly Version: 2.1.1.0

Win32 Version: 2.1.1.0

CodeBase: file:///C:/Program%20Files%20(x86)/FlyingWSimulation/SuperTrafficBoard%20V2.3/TrafficBoardFrontEnd.exe

----------------------------------------

System.Windows.Forms

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Drawing

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

TrafficBoard

Assembly Version: 2.3.0.22

Win32 Version: 2.3.0.22

CodeBase: file:///C:/Program%20Files%20(x86)/FlyingWSimulation/SuperTrafficBoard%20V2.3/TrafficBoard.DLL

----------------------------------------

SimConnect Wrapper 10 SP2

Assembly Version: 2.1.0.1

Win32 Version: 2.1.0.1

CodeBase: file:///C:/Program%20Files%20(x86)/FlyingWSimulation/SuperTrafficBoard%20V2.3/SimConnect%20Wrapper%2010%20SP2.DLL

----------------------------------------

System.ServiceModel

Assembly Version: 3.0.0.0

Win32 Version: 3.0.4506.4926 (NetFXw7.030729-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.ServiceModel/3.0.0.0__b77a5c561934e089/System.ServiceModel.dll

----------------------------------------

System.Data

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_32/System.Data/2.0.0.0__b77a5c561934e089/System.Data.dll

----------------------------------------

System.Xml

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

ExternalSharing

Assembly Version: 1.0.0.0

Win32 Version: 1.0.0.0

CodeBase: file:///C:/Program%20Files%20(x86)/FlyingWSimulation/SuperTrafficBoard%20V2.3/ExternalSharing.DLL

----------------------------------------

System.Configuration

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

Microsoft.FlightSimulator.SimConnect

Assembly Version: 10.0.61259.0

Win32 Version: 10.0.61637.0 (FSX-Xpack.20070926-1421)

CodeBase: file:///C:/Windows/assembly/GAC_32/Microsoft.FlightSimulator.SimConnect/10.0.61259.0__31bf3856ad364e35/Microsoft.FlightSimulator.SimConnect.dll

----------------------------------------

msvcm80

Assembly Version: 8.0.50727.4927

Win32 Version: 8.00.50727.4927

CodeBase: file:///C:/Windows/WinSxS/x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4927_none_d08a205e442db5b5/msvcm80.dll

----------------------------------------

System.Deployment

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Deployment/2.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll

----------------------------------------

SMDiagnostics

Assembly Version: 3.0.0.0

Win32 Version: 3.0.4506.4926 (NetFXw7.030729-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/SMDiagnostics/3.0.0.0__b77a5c561934e089/SMDiagnostics.dll

----------------------------------------

System.Runtime.Serialization

Assembly Version: 3.0.0.0

Win32 Version: 3.0.4506.4926 (NetFXw7.030729-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Runtime.Serialization/3.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll

----------------------------------------

System.Web

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_32/System.Web/2.0.0.0__b03f5f7f11d50a3a/System.Web.dll

----------------------------------------

System.WorkflowServices

Assembly Version: 3.5.0.0

Win32 Version: 3.5.594.4926

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.WorkflowServices/3.5.0.0__31bf3856ad364e35/System.WorkflowServices.dll

----------------------------------------

System.ServiceModel.Web

Assembly Version: 3.5.0.0

Win32 Version: 3.5.594.4926

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.ServiceModel.Web/3.5.0.0__31bf3856ad364e35/System.ServiceModel.Web.dll

----------------------------------------

System.IdentityModel

Assembly Version: 3.0.0.0

Win32 Version: 3.0.4506.4926 (NetFXw7.030729-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.IdentityModel/3.0.0.0__b77a5c561934e089/System.IdentityModel.dll

----------------------------------------

FSRadio

Assembly Version: 1.0.0.0

Win32 Version: 1.0.0.0

CodeBase: file:///C:/Program%20Files%20(x86)/FlyingWSimulation/SuperTrafficBoard%20V2.3/FSRadio.DLL

----------------------------------------

Accessibility

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

Share this post


Link to post
Share on other sites

Hi Mark,

That's the installation folder, not the application data folder. The latter can be access by typing in "%appdata%" in the windows start button, then FlyingWSimulation and finally SuperTrafficBoard.

For the exception, can you send me your TrafficBoardFrontEnd.exe.config, and that one is in the installation folder.

Regards

Simon

Share this post


Link to post
Share on other sites

Oops, sorry Simon, I tried putting it in C:\Users\User\AppData\Roaming\FlyingWSimulation\SuperTrafficBoard, it is using SP1 but it made no difference to the problem i'm having. I've attached the requested file. Thanks for your help with this.

Kind regards

Mark

TrafficBoardFrontEnd.rar

Share this post


Link to post
Share on other sites

Hi Mark,

Putting both these problems together suggests some kind of problem in the networking configuration of the laptop. The exception says it cannot resolve a hostname. We are left to guess of cause which hostname that is as the exception handler does not say what value it is, but I guess it to be "localhost". This is a universal name that all computers should be able to resolve.

Try the enclosed file to see if it gets you around this first problem. There are other issues to resolve to, for instance you are not configured to use the STB Data Server judging from the contents of the file.

And just to double check, you don't see either of these problems if you run STB on the same computer as FSX?

Simon

TrafficBoardFrontEnd.exe.zip

Share this post


Link to post
Share on other sites

Hi Simon,

since starting this post I have bought a new laptop to be used as my client, I still have my old one and unfortunately the file you sent me in the last post did not work, STB wouldn't even start.

Anyway, on to the main reason for the post. I have a new laptop and i'm unable to connect to FSX over the network, I just get the "couldn't connect to flight simulator" message. I have reinstalled SDKsp2 so many times on both systems i've lost count, ive tried different ports too. I have the correct addresses for the pc's, im running the latest Simconnect client on my laptop (61259.0), ive got simconnect.xml in the the same place as the FSX.cfg (FSX/roaming place!!) and simconnect.cfg in C:\Users\Mark i7\Documents and it still wont connect, iv'e followed the same routines on my old XP laptop and it connects just fine (still no times ???? though). Im just trying to get it to connect on my new setup, it's driving me mad! Both machines are running W7 64bit and the network is configured (i can share files between them) with firewalls turned off. I've pasted my simconnect configs below, please tell me if i'm missing something.

Kind regards

Mark

XML:

<?xml version="1.0" encoding="Windows-1252" ?>

<SimBase.Document Type="SimConnect" version="1,0">

<Descr>SimConnect</Descr>

<Filename>SimConnect.xml</Filename>

<Disabled>False</Disabled>

<SimConnect.Comm>

<Disabled>False</Disabled>

<Protocol>IPv4</Protocol>

<Scope>global</Scope>

<Address>192.168.1.80</Address>

<Port>49151</Port>

<MaxClients>64</MaxClients>

<MaxRecvSize>4096</MaxRecvSize>

<DisableNagle>False</DisableNagle>

</SimConnect.Comm>

</SimBase.Document>

.CFG

[simConnect]

Protocol=IPv4

Address=192.168.1.81

Port=49151

MaxReceiveSize=4096

DisableNagle=0

Share this post


Link to post
Share on other sites

I suppose you spotted the obvious mistake! I know I have now! Still no luck in getting flight times with UT2 in FSX. STB-DS has the correct PC name, I press CTL+SHIFT+S in FSX, hear the beep, but no change in STB on the client, both laptops. I've also noticed exactly the same behaviour on with STB when on the same PC as FSX, no flight times. Suppose I could try reinstalling STB-DS?

Kind regards

Mark

Share this post


Link to post
Share on other sites

Disregard All, got it going! Thanks

Can I ask, does STB v3 use the same method of interaction over a network?

Kind regards

Mark

Share this post


Link to post
Share on other sites

Disregard All, got it going! Thanks

Can I ask, does STB v3 use the same method of interaction over a network?

Kind regards

Mark

It does, I'm not expecting any changes in UT2 in this regard.

Simon

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.