Jump to content
The simFlight Network Forums

FSX and STB on separate computers - problem


Pod265
 Share

Recommended Posts

I have followed all the instructions as best I can and checked out other posts on the subject but I still get the following message when trying to connect remotely:

Unhandled exception error has occurred in your application............Exception from HRESULT: 0xC000013C..

Any advice?

Thanks

Bill Miller

Link to comment
Share on other sites

This is what 13C means; it's coming from the .net framework:

316 0xC000013C {Virtual Circuit Closed} The network transport on a remote computer has closed a network connection. There may or may not be I/O requests outstanding. STATUS_REMOTE_DISCONNECT

In other words, something on the FSX computer decided to shutdown the SimConnect connection from STB. I often get this after an FSX crash, and sometimes when closing down normally. My first suggestion is to try a different port number in your SimConnect.xml (FSX PC) and SimConnect.ini (STB PC) not forgetting they have to match to the same value in each place. After that it gets more tricky, but we'll start with operating system details and what you see in the STB settings notebook on the statistics tab.

Regards

Simon

Link to comment
Share on other sites

Use "netstat -an" on both computers. Pick a port number and see if it is listed. If it not listed in either, that's the one to use. At what point, exactly, do you get this message? Also go into STB settings and the statistics tab, and tell me what it says on the right hand side.

Simon

Link to comment
Share on other sites

Simon,

I now am no longer having the previous error report but now just getting the message 'Unable to connect to Flight Simulator...'

Statistics says:

STB UT2 Server State

Opened

UT2 Callbacks

0

Last Callback Received

UT2 Dropped Packets

0

All the other boxes have 0's except following:

Airport Count

1

Cache Deletions

3

Thanks

Bill

Link to comment
Share on other sites

Just to check, after changing port values it is necessary to restart FSX and STB.

I don't know why you have the errors, and as I explained elsewhere this is happening at a layer outside of my control. What version of the SimConnect client do you have alongside STB? In case I did not ask before, did you get STB working on the same computer at FSX at any point?

Link to comment
Share on other sites

Hi Bill,

60905 is an old version of the SimConnect client, supplied with FSX when it first came out. It was updated by both SP1 and SP2/Acceleration. As a next step I recommend updating this to match the version of FSX installed. You'll need the FSX SDK installed and updated with service packs as per Microsoft's instructions. Then go to the installation folder, Core Utilities, SimConnect SDK, lib. On my computer, this is

"C:\Program Files\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\lib"

Here you will find SimConnect.msi, please copy that to your STB computer and install it. Note that sometimes it installs silently, so it has likely worked even if it does not say so. Restart STB and you will see version 60242 for SP1 or 60259 for SP2/Acceleration.

Let me know if that moves us forward.

Simon

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.