Jump to content
The simFlight Network Forums

WideFS FSUIPC and FS9/ FSX only 1 combo works


DavidG
 Share

Recommended Posts

Hi,

I have a clients flightsim setup I've been asked help fix but so far I have only managed half the.

She has 2 PC's networked via a basic router. Main PC running FSX or FS9 is Windows 7 64bit and this has FSUIPC/WideFS for fs9 and FSX (correct version for each). The second is an XP laptop with the FS9 version of WideFS and the FSX version which she say is needed. Both appear registered from within FS just fine.

When I first was called in the PC's couldn't see each other (hence me being called I guess). This was an easy fix. Then the new problem was noted and that is. WideFS connects fine and says so in both sims on both PC's. She then uses a program called VASFMC and running FSX it all works fine however FS9 running and WideFS says again connected but the VASFMC finds no sim. We tried a Procject Magenta demo and that gave an error message about no FSUIPC found??.

I guess what I need to know is what could affect one sim but not the other. Do the sims work differently with WideFS/FSUIPC? (protocols or services not installed etc) . I have disabled all firewalls etc in the hope of finding the anwser but no go. I have been a simmer for a long time but have never use WideFS or connected a second PC to FS so this is a bit beyond me now. My advice was to ditch FS9 but she likes it and has a ton of add-ons.

Any ideas would be great as I'm out of them.

Many Thanks

David G

Link to comment
Share on other sites

The second is an XP laptop with the FS9 version of WideFS and the FSX version which she say is needed.

If the laptop is a WideFS client, then it only needs one installation of WideClient no matter what version of FS is running in the Server PC (from FS98 onwards).

I guess what I need to know is what could affect one sim but not the other.

Both WideClient and WideServer produce log files which tell you (or me) what is going on. The Client log is in the same folder as the WideClient.exe, the server log is in the FS Modules folder. show me those.

I also need to know the VERSION numbers of FSUIPC3 and 4 being used. If these aren't at least 3.98 and 4.60 then please do an update and try again.

Do the sims work differently with WideFS/FSUIPC? (protocols or services not installed etc)

No.

Pete

Link to comment
Share on other sites

Ok Just got back from the ladies house and gathered this data from a failed attempt:

Windows 7 PC running FS9:

********* FSUIPC, Version 3.98a by Pete Dowson *********
Running on Windows Version 5.1 Build 2600 Service Pack 2
Verifying Certificate for "C:\Program Files (x86)\Microsoft Games\Flight Simulator 9\MODULES\FSUIPC.DLL" now ...
   SUCCESS! Signature verifies okay!
Running inside FS2004 (FS9.1 CONTROLS.DLL, FS9.1 WEATHER.DLL)
User Name=#############
User Addr=#############
FSUIPC Key is provided
WideFS Key is provided
Module base=61000000
ClassOptions: UIPCMAIN=FF7F, FS98MAIN=FF7F, FS2KMAIN=FF5E
WeatherOptions(Orig)=40003605[40003605]
InitDelay: 0 seconds
WeatherReadInterval=4
LogOptions=00000001
DebugStatus=255
      827 System time = 16/09/2010 20:57:28
      827 C:\Program Files (x86)\Microsoft Games\Flight Simulator 9\
      827 System time = 16/09/2010 20:57:28, FS2004 time = 12:00:00 (00:00Z)
     3510 FLIGHTS\OTHER\FLTSIM.flt
     3525 AIRCRAFT\c172\Cessna172SP.air
     3541 Aircraft="Cessna Skyhawk 172SP"
     8174 \\DELL\Users\Sue\Documents\Flight Simulator Files\A319 Test Flight.flt
     8221 AIRCRAFT\SMS_A319_W\a319.air
     8237 Aircraft="FSPAP A319 Air Canada (VC)"
     8892 Clear All Weather requested: external weather discarded
    10062 Advanced Weather Interface Enabled
    96050 System time = 16/09/2010 20:59:03, FS2004 time = 06:02:56 (11:02Z)
    96050 *** FSUIPC log file being closed
Memory managed: 0 Allocs, 1070 Freed
********* FSUIPC Log file closed *** *******

********* WideServer.DLL Log [version 6.78] *********
Blocksize guide = 4096 (double allowed)
Date (dmy): 16/09/10, Time 20:57:29.098: Server name is DELL
    16037 Initialising TCP/IP server
    16053 Initialising IPX/SPX server
    16053 IPX/SPX socket() failed [Error=10044] Socket type not supported
    16053 Failed to start IPX/SPX Server
    16053 Initialising UDP/IP server
    16146 Broadcasting service every 1000 mSecs
    20592 Incoming connection Accepted ok (skt=3380) TCP
    20826 Connected to computer "SONY" running WideClient version 6.780 (skt=3380) TCP
    90606 Error 10053: client socket disconnected at Client: removing (skt=3380) TCP
    95052 Close signalled to clients
    96175 Closing down now ...
Memory managed:  Offset records: 48 alloc, 48 free
Read buffer usage:  103 alloc, 103 free, max in session: 1
Write buffer usage: 1922 alloc, 1922 free, max in session: 1
Throughput maximum achieved:  30 frames/sec, 2502 bytes/sec
Throughput average achieved for complete session:  9 frames/sec, 668 bytes/sec
Average receive rate from "SONY":  1 frames/sec, 40 bytes/sec
********* Log file closed *********

and this from the second PC:

********* WideClient Log [version 6.78] Class=FS98MAIN *********
Date (dmy): 16/09/10, Time 20:57:43.828: Client name is SONY
      484 Attempting to connect now
      734 Trying TCP/IP host "DELL" port 8002 ...
      734Okay, IP Address = 192.168.1.100
      734 Connection made okay!
    11718 New Client Application: "vasfmc" (Id=348)

    70765 ****** End of session performance summary ******
    70765 Total time connected = 68 seconds
    70765 Reception maximum:  30 frames/sec, 2504 bytes/sec
    70765 Reception average whilst connected:  27 frames/sec, 1856 bytes/sec
    70765 Transmission maximum:  2 frames/sec, 70 bytes/sec
    70765 Transmission average whilst connected:  1 frames/sec, 47 bytes/sec
    70765 Max receive buffer = 432, Max send depth = 2, Send frames lost = 0

    70765 **************** Individual client application activity ****************
    70765 Client 348 requests: 370 (Ave 5/sec), Data: 15836 bytes (232/sec), Average 42 bytes/Process

    70765 ********* Log file closed (Buffers: MaxUsed 3, Alloc 2257 Freed 2257 Refused 0) *********

Hope that provides the needed info. Would be nice to get it fixed when I go there Monday.

Many Thanks

David G

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.