Jump to content
The simFlight Network Forums

Version Mismatch


Recommended Posts

When FSUIPC tries to load up UI get this message...

********* FSUIPC4, Version 4.60a by Pete Dowson *********

Reading options from "C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Modules\FSUIPC4.ini"

NOTE: SimConnect Acc/SP2 Oct07 is supported, but it isn't installed.

Trying to connect to SimConnect SP1 May07 ...

User Name=""

User Addr=""

FSUIPC4 not user registered

WIDEFS7 not user registered, or expired

Running inside FSX on Windows Vista (using SimConnect SP1 May07)

Module base=61000000

Wind smoothing fix is fully installed

DebugStatus=0

1030 System time = 13/09/2010 17:32:14

1108 FLT UNC path = "\\HPDESKTOP\documents\Flight Simulator X Files\"

1108 FS UNC path = "\\HPDESKTOP\C\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\"

2294 LogOptions=00000000 00000001

2294 SimConnect_Open succeeded: waiting to check version okay

16786 Exception 5 "VERSION_MISMATCH", Ref 227, Version 0.60905: Open: SimConnect Version incorrect!

16786 Trying another version of SimConnect ...

16880 Trying to connect to SimConnect Original ...

16880 Now running with SimConnect Original

16895 SimConnect_Open succeeded: waiting to check version okay

16895 Exception 5 "VERSION_MISMATCH", Ref 227, Version 0.60905: Open: SimConnect Version incorrect!

16895 Trying another version of SimConnect ...

An ideas on how to solve this?

Link to comment
Share on other sites

When FSUIPC tries to load up UI get this message...

...

NOTE: SimConnect Acc/SP2 Oct07 is supported, but it isn't installed.

Trying to connect to SimConnect SP1 May07 ...

...

16786 Exception 5 "VERSION_MISMATCH", Ref 227, Version 0.60905: Open: SimConnect Version incorrect!

...

An ideas on how to solve this?

Have you tried to uninstall and re-install FSX or moving it about? Because something has messed up your FSX SimConnect installation quite severely, and attempting reinstalls seems to be one of the more common causes..

It appears that:

(a) you've installed the SP1 update for FSX, but not the SP2 or Acceleration updates, and

(b) the side-by-side installation of SP1's SimConnect appears to me corrupted somehow, and the original default SimConnect is not compatible with the updated main program.

Hence the "version mismatch", which is being reported by FSX (and only relayed by FSUIPC).

You could try two easy things:

1. Try installing the FSX SP2 update. I'd strongly advise this in any case as it fixed lots of FSX problems, and / or

2. Try the interim FSUIPC4 update (4.627 or later) available in the Updates announcement in this Forum. It has a slightly different way of attaching to SimConnect which might (or might not) work.

Please let me know what happens either way. Note that even if #2 works, it is a work-around and it might not help other SimConnect client programs.

If neither of these work then I'm afraid it gets a bit desperate. You could try a complete uninstall and re-install, but I think this doesn't fix Side-by-Side library problems, and this is what you have. The only alternatives then are either a roll-back to an earlier Windows restore point, if you have one, or a complete Windows reinstall.

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.